Solved Dell Bios - F2 key does not put me in bios

July 21, 2011 at 20:21:44
Specs: Windows XP, Pentium4/ ???
Dell Bios - F2 key does not put me in bios

Dell Inspiron 5100. Broadcon UNDI PXE-2.1 bios (?)

Trying to get into bios to change the boot sequence. Pressing F2 key at Dell Logo is supposed to get you into the bios, but is not. Any way round it?

See More: Dell Bios - F2 key does not put me in bios

Report •

July 21, 2011 at 23:43:26
✔ Best Answer
Yeah it should be F2:

but you might try some of the other Dell keystrokes.

Do you just hit the key once or do you continually tap it?

Sometimes hitting the TAB key will show the posting screen in place of the logo and may give you more info.

Report •

July 22, 2011 at 04:55:19

Tried hitting F2 key once, continuous tapping and holding it down. Also Tab key. None work. This is actually only part of the problem - hard drive is locked by an unknown password and I am trying to get it to boot from the CD drive instead. Lot of people have told me the hard drive password problem cannot be solved. But I don't want to buy a new hard drive (hard to find here in the Philippines) and then find I cannot use it properly because of some BIOS setting.

Thanks for your suggestions.

Report •

July 22, 2011 at 05:20:46
Try F12 for the boot menu, but it won't do you much good if you're locked out of the hard drive. And changing the drive won't fix the password issue. Contact Dell & have the necessary documentation to prove ownership or they won't help you.

Report •

Related Solutions

July 22, 2011 at 05:43:20
Ownership documentation is on a boat in Thailand and I am in the Philippines. Computer is about 6 years old and was used as a backup to a newer computer. I think it's probably not worth the hassle given what you say about changing the drive not fixing the password issue.
Thanks - you have probably saved me time and money.

Report •

Ask Question