Computer wont power up

May 25, 2009 at 11:56:28
Specs: Windows Vista
Please help.
The power supply on my computer was making a noise so I decided to treat myself to a new cooler master case along with a new supply. My motherboard is an asus a8n sli deluxe. I have connected everything to the letter on the manual but I am getting nothing when I press the power/reset switch. No power up from fans, nothing, just a green light on the motherboard.

I tried a different, working supply and it made absolutely no difference. I have tried removing the CMOS battery on the board but it hasnt helped.

The ram stayed seated on the board and all the components - graphics card, processor etc etc are the same.

I have googled and have found people with the same problem. I cant see how the board would be gone when it was powering up fine before the changeout.

Agai, I have checked and rechecked the cables and they are exactly on the headers as described in the manual.

Totally stumped. Cheers for any help.

See More: Computer wont power up

Report •

May 25, 2009 at 12:40:49
I would open the case. Disconnect the wires that run from the front panel to the board. Then take a flat head screw driver and short out the pins on the board. Just a light touch...on

You will know when you touch the right ones as the system will start.

Bet the manual has the wiring wrong.
Post back

After thought..... do both your old power supply and the new one have the white wire. -5

If the old one does and the new one does wont boot

Report •

May 25, 2009 at 13:03:20
Cheers for the reply.
OK touched it with the screw driver and it powered up! Processor fan going okay and graphics card was running. I checked my old power supply and I cant find a white wire with -5 (or were you talking about the case leads??) Obiously the Motherboard is okay. Where do I go from here?
Thanx again for your help.

Report •

May 25, 2009 at 14:42:36
You had the case wiring (power switch) connected wrong.

Report •

Related Solutions

May 25, 2009 at 15:06:18
Hi mate thanx for the reply but I disconnected and reconnected the pins several times EXACTLY how it is in the manual. The pins on the Asus motherboard are colour coded which makes it difficult to get it wrong.

Report •

May 25, 2009 at 19:00:34
I have by process of elimination worked out there is a fault in this motherboard. When I tighten certain screws to fix into the casing the motherboard will not power up. There must be a faulty connection which is being bent out of shape when the screws are tightened.

This has left me with another problem. I have the board fixed and powered (I only used three screws). But because I removed the battery and moved the jumper it looks like Ive lost the bios. The computer powered okay but went straight to a black screen. Does this sould like the bios has gone?

Could someone post me to the best file to download (i got the 1805 bin file) and give me some pointers on what to do? Cheers

Report •

May 25, 2009 at 19:04:36
I strongly doubt that you lost the BIOS-it's built into a chip on the motherboard. What keys did you hit to try to enter the BIOS ?
"When I tighten certain screws to fix into the casing the motherboard will not power up"
The motherboard might be touching the cae then, which it should not be doing. Did you put in the standoffs ?

Report •

May 26, 2009 at 03:46:17
Hi thanks for the reply. I didnt realise there were risers to go in! Im a daftie, I'll have a look for them, Ive never fixed a mobo into casing before.

Like I say though this has left me a new problem - no beeps on startup and just a black screen.

PS: My screen is giving me a 'no signal' message so there doesnt seem to be a signal going from the graphics card to the monitor.

Report •

May 26, 2009 at 05:14:39
I was hoping that it was just a case of changing the connectors to the using a screw driver to find which pins are the I/O.

Not familiar with your board or case but some cases have more stand offs than you may need. If there is an extra one, it will short out the board. They are usually easy to remove.

Usually boards are bench tested. placed on a non conductive surface...and then powered up. it's easier to fiddle with the connections and saves from installing and having to remove from the case should things not work.

If the board is still in, loosen all the screws..wad up some news paper and tuck it under the board. This will prevent it from making contact with the case and free your hands.
You don't have to remove the screws, just loosen them enough to raise the board a bit.

The above is just for testing.

It might save time to just remove the board and make sure
there are no extra stand offs.

Report •

May 26, 2009 at 10:05:20
Hi cheers for the reply. I realised the problem was the lack of risers - when I tightened the screws on the casing the board wouldnt power up. When I installed the risers the power came on okay. Like I say though, this has presented a new problem - there now doesnt seem to be any data coming from the board. There are no beeps on post even though the speaker is plugged in and I cant see any lights on the front.

There is no picture coming from the graphics card and when I plugged in a keyboard for testing the lights came on briefly to indicate power but the caps lock key light wouldnt come on. Im thinking the contact with the case may have killed the board. Is there any way of knowing? Fast running out of ideas here.


Report •

Ask Question