Computer will not boot to anything after PXE.

June 30, 2011 at 11:09:07
Specs: Windows 7
We are attempting to do a PXE boot with a FOG server. The computer is a Gateway E4500s and it will not boot to the harddrive once it has attempted a boot to PXE.

If we set anything else, DVD drive, Floppy etc. to boot before the Harddrive everything starts up fine. If the PXE is before the Harddrive it will not attempt the harddrive at all and stops after PXE. We have also attempted to boot to a CD/DVD Drive after PXE and its just not working.

Any help or suggestions would be greatly appreciated.

I build em' and sometimes i can't fix em'.

See More: Computer will not boot to anything after PXE.

Report •

June 30, 2011 at 11:34:29
If you set it to PXE, it will attempt to boot off a network drive - is that what you want? If no network drive is found, the boot process will stall & an error message about PXE will be displayed. If you don't want to boot off a network, either disable PXE altogether or set it last in the boot order.

Report •

June 30, 2011 at 11:58:10
"If you set it to PXE, it will attempt to boot off a network drive - is that what you want?"

The computer would have to be connected either via a network cable and a wired networking adapter (on your computer), or possibly on newer computers, via a wireless network connection and a wireless networking adapter (on your computer), between your computer and an existing network.
You don't normally do that unless you're trying to connect to an existing business or institutional or other similar network.

Report •

June 30, 2011 at 12:21:18
We are in the process of building a FOG Imaging server. So yes I do want it to boot to PXE first. After PXE, the CD/DVD, then the HDD etc. However only on the Gateway model E4500s we have run into an issue where the HDD never actually starts. We figured this out by noticing the HDD light never shows any activity.

The CD/DVD drive with a mini-xp disk inserted gets to the "Setup is inspecting your system's configuration" message and goes no further.

I build em' and sometimes i can't fix em'.

Report •

Related Solutions

June 30, 2011 at 12:53:18
If the bios DOES NOT find an existing network connection to an existing network, the boot process will halt, and the bios WILL NOT try to boot from anything listed in the Boot Order or similar listed after PXE.
You won't get hard drive activity after that.

(The same thing applies if the first hard drive the bios tries to access is found to be not bootable -
the bios WILL NOT try to boot from anything else.
As far as I know, the same thing always applies if the bios attempts to boot from a USB connected drive that is not bootable.

On the other hand, if the boot order settings are set correctly to allow it,
- if a floppy disk is inserted and found to be not bootable,
- or - if an optical disk is found to be not bootable, or if it is found to be bootable and you do NOT respond to the prompt while booting and choose to boot from it
- the bios will try to boot the computer from the next thing in the Boot Order or similar list. )

If the bios DOES find an existing network connection to an existing network, the bios WILL NOT try to boot from anything listed in the Boot Order or similar listed after PXE.
You WILL get hard drive activity after that if the connection to the existing network was successful, if the hard drive has been set up correctly with the proper data otherwise.

If you want to boot PXE, what existing network are you trying to connect to ?

If you're only connected to a high speed modem, or only connected to your own LAN, e.g. via a router, then that's NOT going to work.

"The CD/DVD drive with a mini-xp disk inserted gets to the "Setup is inspecting your system's configuration" message and goes no further."

That's another subject that may have absolutely nothing to do with your boot problem.
E.g. You may have
- an optical disk problem.
Is it an original CD or DVD or a copy ?
Is it clean and free of major scratches ?
If it's a copy, a CD-R or DVD-R disk should work fine in any drive that can read it's type, but other types of burnable disks may NOT read properly in a drive it was not made in.
- an optical drive problem.
Have you tried using a laser lens cleaning CD in the drive ?
How old is it ? How much has it been used ?

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittent, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

80 wire data cables must have the proper end connector connected to the mboard IDE header - usually that's blue, but in any case it's the one farther from the middle connector on a 3 connector data cable.

- a memory errors problem - Windows Setup is VERY sensitive to even tiny amounts of ram errors that you may not have noticed previously.

Try wiping off the contacts on the ram modules, and making sure they are all the way down in their slots.
Test the ram with memory diagnostics, such as Memtest86 or Memtest86+.

Some ram manufacturer's modules do not strictly adhere to the JEDEC standards that most mboards bioses use to determine ram settings.
In that case, the ram settings in the bios Setup that the bios has automatically chosen may not be correct.
Check the ram settings in your bios - the ram voltage, and the ram timing numbers - those should be the same as for the specs for the modules themselves. Often the ram voltage and timing numbers are printed on the label on the modules.

If the voltage setting or timings settings in the bios are different from the specs for the ram, change them in the bios. The timing numbers must be as close as you can get to the same, or slower timings (higher numbers = slower) - you won't notice the difference the slower settings make.

If you have a mix of different modules
- don't mix ram that different voltages are specified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram that a higher voltage is specified for is more likely to not work properly in that situation.
- the bios settings must be those for the slowest timing settings of all the modules, or slower (higher numbers = slower).

You MAY be able to custom set the ram voltage to the higher ram voltage in the bios if you do NOT have the bios set to detect the ram "by SPD" or similar, however, you must NOT exceed the max voltage range for the modules that require a lower voltage, and that can be hard to determine, unless you can find detailed specs - e.g. if the ram is Kingston ram that doesn't have a brand name system specific part number, that info is easily found.

NOTE that we have seen, many times, the situation where the ram passes ram diagnostics tests despite the fact one or more of the timing numbers for the modules are WRONG (too low) in the bios - in that case, it's ONLY when you actually attempt to use an operating system, including one on a CD or DVD that you are attempting to boot the computer from, that you have problems.

When you boot the computer from an optical operating system disk, the bios boot order settings are ignored. (of course, that must be set so you can boot from an optical disk, but other settings in the boot order list can be wrong).
Windows' Setup will complete successfully even if that's set wrong
If that's set wrong, you don't have a problem until Windows attempts to start up for the first time after Setup has finished.

Report •

June 30, 2011 at 13:26:40
Alright I have to clear things up and explain as clearly as possible.

We are using a FOG server which is Free Open Ghost to handle our images. When the computer starts it finds the DHCP server which pushes a Mini-Linux to the computer. The computer Mini-Linux has different options set into it dealing with Memtest+86, we can Image it, Or we can choose to boot from the Hard Drive. The default is to boot from the harddrive after 3 seconds which is what it does, UNLESS we push an image to the machine from the server, then it boots to the image server and does as it is supposed to.

The problem we have run into is that after the mini-linux the harddrive and cd/dvd drive do not spin up. It goes to a blanks screen and we can go no further.

So yes, there is a network that PXE connects to, and gets its DHCP address. If there is no Image to be pulled from the network, the machine should start in its Windows environment, or start from the CD/DVD Drive.

In reference to the SATA cables, we have tried different drives, different cables, and even swapped out machines (same model) but still running into the same problem.

I build em' and sometimes i can't fix em'.

Report •

June 30, 2011 at 14:02:37
"The computer Mini-Linux has different options set into it dealing with Memtest+86..."


Bootable ram diagnostics versions can be run from a CD or DVD or floppy disk.

Maybe someone else can help.
I see there is no forum on this site for a Linux server situation, although you could try posting in the Linux forum.

I know very little about any Linux version.
I've never tried booting a computer from a network, so I don't know if it's normal for the hard drive, or optical drive if it has a disk in it, to not spin like in your situation.
I've never set up a server or a server operating system.

The mini XP CD contents failing to load normally....
There's definitely something wrong .

If the hard drive is SATA, there are no built in SATA controller drivers built into the contents of (normal) XP OS disks, but you would get a lot farther along before it would become apparent that the initial files loaded from the CD were not finding any SATA drive, if the bios has the SATA controllers in SATA or AHCI mode.
You wouldn't just get no further text after what you saw.

Have you been using the same power supply for all situations ?
If you have, failing power supplies are common.

E.g. the hard drive and optical drive not spinning.

That doesn't make sense to me that the hard drive wouldn't be spinning, or that optical drive would not be capable of spinning if it has a disk in the drive, at any time.
When the hard drive is not spinning, the bios cannot detect it and boot from it.

Some power supplies have more than one +12v output. We've seen the situation where one of them has malfunctioned and is no longer working. In one Topic I answered in on this site, a power supply had that problem. His new mboard was working fine but his hard (and optical ?) drives were not spinning.

You could try swapping it with a known good power supply.

Report •

June 30, 2011 at 14:23:36
Demonstrative exspelling
... there is logic to this madness!
Grrrrrrrrrrrrrrrrrrrrrrrrrrr... .im

Report •

July 5, 2011 at 05:53:06
Wow thanks mavis007 would have never thought to check there. I appreciate your help.

I build em' and sometimes i can't fix em'.

Report •

Ask Question