Computer sees 2 out of 4 RAM sticks. caused by bios update?

October 4, 2012 at 03:30:29
Specs: Windows 7 64 bit, i7 3.7ghz, 8GB RAM 4x 2gb TakeMS sticks
Hello all,

I've recently started having problems with my RAM memory (4 ram sticks of 2gb).

It worked perfectly fine before. Got 4 of the exact same ram sticks, but now the motherboard refuses to read more than 2 of the 4 slots at a time. (used to have 8GB, now it only sees 4gb). I've tried every ram stick individually in every slot and they all work properly. I've tried every combo of 2 sticks in all possible slot combinations and all worked. However as soon as I add the third and fourth or just a third stick it completely ignores that stick.

I'm 100% sure the sticks are compatible as they have worked properly before. Interesting aspect is that I updated my BIOS shortly before it happened (Not sure if it happened right away after updating). I've already tried downgrading my bios but the flash utility won't let me saying my backup file from the bios is 'outdated'. The Ai Suite program also can't downgrade it because the "Bios interface has been changed/altered". Could it be that the newer bios has different default settings which might cause some of my sticks to stop working(even though they're all the same sticks)?

PS. Already tried the CMOS reset, Battery reset, reseating the sticks numerous times, even moving them around which shouldn't have effect cause they're all 100% alike, also tried switching Memory remap around. My motherboard is an ASUS P8H67-M, the Ai suite (program from the motherboard) does see the entire 8gb installed, CPU-Z sees 8 GB as well but bios sticks to 4gb installed)

Hope there's someone out there able to help.


See More: Computer sees 2 out of 4 RAM sticks. caused by bios update?

Report •

October 4, 2012 at 04:58:37
If all 4 sticks are identical as u said try to configure them manual(voltage, timings and speed) in BIOS. I don't know how CPUz bypass BIOS and sees all 8GB of memory. How much windows recognize?

You know the real meaning of peace only if you have been through the war.

Report •

October 4, 2012 at 05:05:06
I have tried manually increasing the voltage a tad without result but I'll see what I can do with the voltage and timings once I get home.

CPU-z basically analyses your hardware , it doesn't copy the info given by the bios. Not sure how it works exactly but it actually does a hardware check on it's own without receiving/copying data from the BIOS. However Windows does use the bios readings, hence why windows only sees 4GB as well.

P.S Thanks for the quick response :3.

Report •

October 4, 2012 at 05:36:41
I may be wrong but BIOS is a master all of these monitoring applications takes info from BIOS with the help from OS.
May be CPUz is doing some physical check and BIOS doing both physical and deep memory check and found errors in one or two of your 4 sticks.
Try to test each of memory stick with memtest. Don't increase mem voltage, just use the voltage printed on memory stick.

You know the real meaning of peace only if you have been through the war.

Report •

Related Solutions

October 4, 2012 at 05:47:26
True, BIOS is pretty much master of all monitor applications but I do think the hardware check from CPU-Z is at least partly physical. Else it wouldn't be giving any other readings than the BIOS.

I highly doubt that there's memory errors in any of my sticks as my computer passed the memory check on every single one of them when I tried them individually. It would probably not have passed the memory test with a solo stick if it would've been faulty.

I've also used Mem-OK when all 4 chips were installed, it was succesful with no errors found , yet bios still saw only 4gb. Once Im home I'll try using the mem-ok test on each stick individually.

Aright I'll leave the voltage on what is suggested. I think that's 1.500 but I'm not quite sure, I'll have to check when I get home as well. :3

Report •

October 4, 2012 at 06:44:41
Are you sure you flashed the correct BIOS version? Post your full model number.

The updated BIOS may well be the issue. Of the 3 BIOS files available on the ASUS site, 2 of them refer to memory compatibility.

Do all 4 modules have the same EXACT part number on them?

As kuwese mentioned, manually configure the RAM settings. You MAY need to use looser timings than specified.

There is a QVL for memory at the link below as well as the BIOS updates.

Report •

October 4, 2012 at 06:59:07
Motherboard is P8H67-M H67 Rev 3.0. pretty much the one you linked exactly. If more info is needed about it I'll post all the info I know here once I get home xD.

Currently running on P8H67-M BIOS 3703, used to run on P8H67-M BIOS 0807. On 807 I didn't have issues with the memory, however there was a faulty temp.measurement in the bios version that made the computer auto-shutdown whenever it got too high, even though the measurement was false. Hence why I updated my bios and the temperature issue was resolved that way.

I'll check the part numbers once I get home, however the sticks already worked for quite a while so it shouldn't be an compatibility issue in any way. I've been to the asus site many times to check on bios updates. As for the QVL for memory.. well if the memory was uncapable to work with my motherboard I don't think running them individually would've worked. All 4 of them together worked before as well for over a year or maybe 2 years even.

PS. Keep in mind that all ram sticks work individually in all slots. :O. Just not more than 2 sticks at a time.

Report •

October 4, 2012 at 07:07:31
The QVL is simply a list of ASUS tested modules that are known to work. Doesn't mean that modules not listed are incompatible.

As I stated above, try manually setting up the RAM. You may even start by lowering the speed just to see if the stick all work then.

When using auto settings the BIOS reads the information off the RAM (SPD) and tries to use those settings.

You may find the link below useful.

Report •

October 4, 2012 at 07:23:24
I know what the QVL is but the list seemed rather unneccessary knowing that the modules already worked previously ! So I think they should be compatible :).

I will definitely try setting up the ram manually and see what happens. I'll update here as soon as I have tried it of course :).

Just read through the article(s), quite useful indeed. Definitely gonna try some things and report back here. Though it'll take a while until I'm home from work.

Thanks for all the help so far :)

PS. I hope my bios has all these options as this motherboard has a custom BIOS interface and everything which seems simplified on a lot of parts so I'll have to look for the options :3.

Report •

October 4, 2012 at 07:55:53
Asus tends to be an enthusiast brand, so I would suspect you will find many tweak settings there.

Report •

October 4, 2012 at 08:02:47
but now the motherboard refuses to read more than 2 of the 4 slots at a time.
Are you sure the BIOS doesn't see the RAM? I find it dubious that the BIOS cannot see the RAM, but a third party application can. From what I recall, CPU-Z does contain a lookup table to catch lying CPUs (programs will run slower if they think they're running on AMD), but that shouldn't give it RAM discovery powers.

Check to make sure you have the most recent chipset drivers. Also check your boot options to make Windows isn't artificially avoiding some of its RAM. Relevant keys are truncatememory and removememory. Also, check to make sure your OS is 64-bit.

There are ways to downgrade, but there's more risk than upgrading, and you'll need third party / engineering programs and a bootable copy of DOS.

How To Ask Questions The Smart Way

Report •

October 4, 2012 at 13:54:18
I am positive that the bios does not read the RAM as it clearly shows only 4 gb ram installed at the bios screen. As for chipset drivers, is there any common spot to check for these ?

All ram sticks have the same number and are completely identical. Also, boot options should not be relevant if the bios is the thing not seeing the ram. boot options are applied after the bios settings. (correct me if I'm wrong O.o) Windows 7 64 bit is my OS btw.

There's a ton of options on my bios regarding timings etc but TRC is not one of them unfortunately, unless it might be called slightly different. Which other SPD options could I try changing ?

PS. I tried lower the Mhz down to the lowest back up to the 1333 which is the highest my mobo supports. Stayed at reading 4gb. Increasing the volt didn't work either :(

Report •

October 4, 2012 at 14:36:09
Increase the CAS setting to a higher number to see if that will work.

Check the BIOS to see if there is an option to limit the amount of RAM. I haven't seen such a setting but worth a look.

The chipset drivers have absolutely nothing to do with the RAM showing in the BIOS.

"I am positive that the bios does not read the RAM as it clearly shows only 4 gb ram installed at the bios screen." Where are you seeing this? In the POST screens at start up?

Report •

October 5, 2012 at 00:09:48
Increasing the CAS latency didn't help :(

I've also looked at an option of such kind but was unable to find anything regarding ram memory limits.

Thought so, thanks for clearing that up :3

It states it at the post screen and at the Bios simplified & Advanced main screen. This motherboard uses a custom BIOS interface so it's slightly different than a regular BIOS unfortunately.

Edit : I'm thinking that it might have to do something with the dual channeling. More specifically the 2 slots it reads atm might both be running in single mode while in the correct slots for dual channel (CPU-Z says dual is being used but bios doesn't show if it's dual or not). Considering all RAM sticks work seperately but not together it might be my CPU memory controler ?

Report •

October 5, 2012 at 05:13:23
I have been following this a little bit and you appear to have tried all that I would have. You may have mentioned it but if you have not, you could see what Memtest86 shows (amount of memory is listed) with all 4 sticks installed and run it through multiple cycles.
It is possible that the older BIOS version as easier on the 'rules' for memory and that the new version does not fully support the memory even though the older version does. There are many instances when 2 sticks of memory work on a machine though 4 do not. This could now be the case with this new BIOS version.
It might be time though to contact ASUS about a possible glitch in their latest BIOS version that might be actually causing this. Maybe they have recently identified this problem and are working on it, there might be a Beta version they are about to certify that might fix it, though I would wait for the actual release before adopting it (unless they are willing to replace the board if it fails the Beta update).

[At least in this case you updated the BIOS to fix a real problem (not always the case), though unfortunately you now have another problem.]
Good luck.

You have to be a little bit crazy to keep you from going insane.
---- Save Big Bird -----

Report •

October 5, 2012 at 05:18:12
If we could backup for a bit. After re-reading your original post I am unclear about something. Did you always have those same 4 modules installed, or did you add 2?

Also, I don't believe you ever answered my question concerning the part numbers on the RAM. Are all part numbers identical?

Last question, I don't mean to insult you but are you sure you have Windows 7 64 bit version?

Please post the part number of the RAM.

It is worth noting the Asus QVL has a separate listing for modules in a 4 DIMM configuration and others. See the link below.

Are you using the supported “Supports Intel® Extreme Memory Profile (XMP)”?

Report •

October 5, 2012 at 05:28:01

I'll indeed try running Memtest86 when I'm home. Finally weekend is up so I'll be able to look into it more.

Unfortunately the memory rules might've been changed with the newer bios. Rather weird though as the bios updates mentioned 'Improve memory compatibility.'. Such a nice improvement xD;

I guess I'll see if I can contact Asus regarding this problem and see if they might have a fix for it.I wouldn't find it a problem buying new ram with more memory on each stick if only 2 slots would work. But I'd at least need the ram to run in dual channel and as of this moment I'm not sure if they do that or if it reads them as single ram modules.

It fixed a problem that was also caused by faulty software and by fixing it it created another problem in their faulty software. Guess it was still worth it to update but I of course bought the 8gb to use the full 8 not to toss 4 aside xD.

Either way, thanks for your reponse and I'll keep this topic updated when I run the mem-checks and perhaps contact Asus.

Report •

October 5, 2012 at 05:42:32
Always had the same 4 modules installed and have always worked properly for about 2 years now.

Post 11 : "All ram sticks have the same number and are completely identical.". Yes all 4 ram sticks have the exact same number. I'll post the number here once I'm back home.

I am 100% positive it's a 64 bit windows 7 yes. And I've had 8gb for over 2 years running already

The QVL list was created several years after I bought the ram and have been using it as 4 sticks throughout the years. So it's all nice and good that they made a list earlier this year but that shouldn't mean my already working and compatible ram suddenly is not compatible anymore.

I've read about XMP while at work today. I'm going to look for it but I'm afraid I do not have the option to create those profiles.

Report •

October 5, 2012 at 06:49:35
Yeah, if it's the actual BIOS screen telling you 4GB, then the chipset drivers probably won't help.

I'm not seeing anything out there about ASUS BIOS upgrades ignoring RAM, so at least this looks like a rare issue. Looking at the manual, there's a button you're supposed to press when you install RAM on the MB itself. Have you tried hitting that button?

OtheHill: Asus tends to be an enthusiast brand
Tell me about it. The last Asus board I had had a BIOS bug that prevented the board from booting out of the factory. What happened is the board set the default RAM voltage to 1.2V, instead of something sane like 1.5V. The official solution was to remove the chip and manually write the updated BIOS onto it.

Thankfully the workaround people came up with did not require an EPROM burner. It involved buying a stick of the most off-market RAM you could get your hands on, and use that to boot into the BIOS. From there, you could set the voltage levels to 1.5V, swap in the real RAM, and flash the BIOS though the supplied interface. The hardest part was getting that initial boot, as the system would only come up 40% to 60% of the time.

ASUS also suggested the board was meant for tech professionals, and that's fair; there should be a professional involved somewhere when writing a BIOS, and apparently there wasn't one on ASUS' end.

How To Ask Questions The Smart Way

Report •

October 5, 2012 at 07:12:14
Yup thought so :3.

I've searched the internet as well and actually have found a few topics with somewhat the same issue. Theirs had to do with the Dual-channel thing I described above.

As for the button I'm assuming you are referring to the MemOK button ? If so, yes I've tried it. It restarts once then It successes and says no errors found , yet still only shows half the RAM.

Sounds like Asus has quite some funky problems :P. I have yet to try out their support though and see if they're even willing to help at all :3.

Report •

October 7, 2012 at 22:19:17
TMS2GB364D081-138KE. That's the number that's on all sticks. Worked perfect for a long long time until the recent bios update I think.

With the XMP options that I got I can not make XMP profiles etc and I'm not sure on what to edit at it.

Report •

October 8, 2012 at 12:24:55
Where are you located? That number comes up as a brand is one I never heard of. The product link is below. Possibly a Russian brand?

Report •

October 8, 2012 at 13:44:47
I live in The Netherlands (europe). TakeMS is a german manufacturer. Used to be bigger on the market than they are now as far as I know :).

P.S the link you posted is the right brand yes :3.

Report •

October 8, 2012 at 16:16:38
I can't say why the BIOS update may have caused this issue but I think the problem is the memory chip density.

Your modules each have 16 - 128GB chips on them. for a total 2048MB x 4 sticks.

Any current 2GB module of DDR3 1333 will have either 8 x 256MB chips or more commonly, 4 x 512MB chips.

The memory controller may not be able to handle that configuration. Could be how many banks there are. Not sure.

What processor are you using? The processor controls the memory in your system.

Report •

October 8, 2012 at 16:36:51
Would be really weird if it would be the density or the processor, considering they already worked for nearly 2 years. Either way there's 4 banks in total (4x DIMM, Dual channel). The mobo supports up to 32GB DDR3 1333 MHZ.

My processor is a Intel core i7 2600 3.40 ghz. only thing I could imagine is a bend pin or something like that.

Report •

October 8, 2012 at 18:15:18
A single module can have 2 banks.

Report •

Ask Question