computer locks up with external USB drives

January 21, 2011 at 08:53:17
Specs: Windows XP SP3, Athlon X2/1gb
My computer locks up with external USB drives, especially when transfering large files (>1gb). These files are not corrupted; they transfer to other computers without problems. I have tried several things: updated all motherboard drivers; tried several different USB drives; greatly increased virtual memory settings for all drives involved; front vs. rear ports; and tried a self-powered external drive. I have ordered a PCI card with USB ports to try that next.
My configuration: Athlon X2 CPU, Biostar T-Force 4U (nVidia chipset), 1gb RAM, 3 HDD, WinXP SP3.
What else can I try?

See More: computer locks up with external USB drives

Report •

January 21, 2011 at 09:12:48
What's the age and type of the motherboard? Is this USB 1 or 2? If it's 1 then that's likely your problem. Let us know how the new pci card works......

Report •

January 21, 2011 at 10:48:14
Whats the file system on the drives?

Report •

January 21, 2011 at 19:16:19
Thanks for the quick responses.

The biostar motherboard is about 5 years old and is pretty stable, not counting this problem with the usb drives.

It is USB 2.0

Most of the USB drives I've tried are NTFS formatted. A couple were FAT32. It didn't seem to make any difference.

One item that I've shied away from doing is to update the motherboard bios. I tried that a few years ago on another motherboard and killed it dead. I would really like to avoid trying that on this motherboard, considering my track record on that score.

I read on one website that bmp and avi files can cause this, though the website did not say why. Those are the file types I am using. I have not tested other types of files. I might try that.

Report •

Related Solutions

January 21, 2011 at 20:35:30
NEVER flash your bios unless you have no other choice - e.g. you need to flash it to support a CPU you want to use that it doesn't presently recognize. Flashing the bios is NOT a fix-all like some people think it is. It's the riskiest thing you can do with a computer - even if you do everything right, the flash chip can physically fail while flashing.

If the external USB drives worked fine previously with this same mboard, obviously your problem has nothing to do with the present bios version.

What is the brand and max output capacity of the power supply ?

Have you checked the current readings for +3.3v, +5v, and +12v in the bios Setup - they should be within 10% of the nominal value - if any aren't, you must replace the power supply. If the reading for +5v is too low you're likely to have problems with external hard drives. If any of those voltages are too high, components will be damaged eventually.

Do you have a video card installed in a slot ?
If so, what video chipset does it have ?

Describe what you mean when you say the computer locks up.

FAT32 software partitioned drives have a max 4gb per file size limit. Some huge files, e.g. movies, may be larger that that. Other than that, it doesn't matter whether it's hard drive is using using FAT32 or NTFS software partitioning.

Your onboard USB controller(s) may be damaged but that's extremely rare - I've seen that only once in 17 years for computers I've encountered myself - it was damaged by a power failure event.

You are at lot more likely to have problems when you plug an external drive into a port in an external USB hub.
You may have an IRQ sharing problem you need to fix.
The USB port you plug the external hard drive into must be able to supply the full max USB spec 500ma.
If the USB cable did not come with the drive, it may not be adequate. Use a cable rated to comply with USB 2.0 specs.

More info....
Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Check that out first.

Rarely, not all the ports on the back of a desktop case may be able to supply 500ma each.

If you have a desktop computer, Note that I answered a Topic on this site where a guy had an external drive, which does require the full 500ma, connected to a port on the back of a desktop case - it would not work properly when a webcam was in the port next to it, but it worked fine when the webcam was unplugged. Ports on the back of a desktop case often have two ports connected to the same USB controller module that are ports one above the other - you could try connecting the cable to one of those and leaving the other un-used.

This can cause all sorts of strange problems......

Some mboards develop this problem - electrolytic capacitors were installed on them that were not properly made, and they fail eventually - the mboard manufacturer didn't know they were improperly made at the time the mboard was made.

Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components, power supplies, Athlon cpu's, etc.:

Report •

January 22, 2011 at 10:12:22
Tubesandwires, that's quite a post. Thanks.

Your advice on bios updates is sound. I wasn't hot on the idea anyway.

I don't know if my motherboard ever worked correctly with USB drives. This is something new I've been trying to do. It's possible that this problem existed since day one and I never noticed.

I don't believe the power supply or USB port current is an issue because I tried a self-powered USB drive with a 2 amp internal source (which I tested on other computers). The results were the same. So that probably eliminates all things related to the 5 volts supplied from the USB port.

I do have a video card installed, a Radeon 9200SE. I don't see the connection though.

As for the "lock up", the computer "freezes" instantly and is totally unresponsive (ie, no mouse movement, no task manager, no motion on the monitor, etc.). And it stays that way until I reboot the system. I don't see any relevant messages in the event viewer either, after I reboot.

This happens on both front and rear USB ports. I've tried them all. And without attached external USB cables too.

Your point about capacitors is well taken so I pulled the cover and examined all the electrolytics I can find. None of them had bulged sides or tops or showed leaks of any sort. I know that's not proof but that's all I can really do, short of replacing them (No, I wouldn't do that. I'd replace the motherboard first).

I'll check the website you gave on USB problems and get back to you on that.

Oh, I did try other types of files other than bmps and avi's. Same result; it locks up.

Thanks again. I'm still looking forward to trying the USB card.

Report •

January 22, 2011 at 15:56:54
"I don't know if my motherboard ever worked correctly with USB drives."

It's extremely unlikely there was anything wrong with the USB controllers when the mboard was new. It's almost as unlikely there is anything wrong with them now.

It doesn't matter whether the external drive is 3.5" and requires an external power supply to be connected to it (the ex PS must be working fine of course) , or it's a 2.5" drive that doesn't require that - the USB port the cable plugs into on the computer must be able to supply 500ma, and the USB cable must be adequate.

"I do have a video card installed, a Radeon 9200SE. I don't see the connection though."

Newer video chipsets require a higher system minimum power supply capacity. With that video chipset you're probably okay with a PS with a capacity of 250 watts or more. If the capacity is less than that, you're more likely to have problems, especially if it's under 200 watts. The max capacity is usually an intermittent rating, not a continuous rating (unless it actually says continuous), and most PSs are not intended to be continuously loaded to more than about 80% of the rating.
The brand of the PS can be a good clue - there are lots of el-cheapo power supply brands that are a lot more likely to cause you problems.

"As for the "lock up", the computer "freezes" instantly and is totally unresponsive (ie, no mouse movement, no task manager, no motion on the monitor, etc.). And it stays that way until I reboot the system. I don't see any relevant messages in the event viewer either, after I reboot."

All sorts of things can cause freezes like that.

You are normally not supposed to unplug a USB connected drive while Windows is running unless you click on the Safely Remove Hardware icon and STOP accessing the drive first, but doing that probably can't do any harm to the data on the drive when the computer is completely frozen - you could try unplugging the external drive when Windows freezes, but doing that probably won't un-freeze it.

If you're SURE it only happens when an external drive is connected, then that sounds like either you may have an IRQ sharing problem or a hardware problem.

See the "Troubleshooting USB device problems ..."
reference in response 4 for checking if you have an IRQ sharing problem.

Take a look at the 3 voltages in the bios Setup, as I said in response 4.

A faulty power supply can cause strange symptoms when even a small additional load is placed on the power supply. E.g. my brother had an excellent Antec model that would black screen and restart the computer when he tried to burn a CD. The 3 voltages in the bios were within a few percent, yet when I tried another power supply, the problem did not occur.

Try a different used power supply with this computer, if you have one in another computer, or if you can borrow one, preferably 250 watts capacity or more.

A small amount of ram errors could cause your problem.
That's most commonly caused by a poor connection of the ram in it's slots.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

Then test the ram. It should pass. (It might not pass unless you have done the preceding things first - you could try doing the ram test first, but if it doesn't pass, then try the preceding things, then test it again).

If you want to try a memory diagnostic utility that takes a lot less time to run a full pass than memtest86 does, this one is pretty good - Microsoft's
Windows Memory Diagnostic:
Windows Memory Diagnostic is limited to testing only the first 4 gigabytes (GB) of RAM.
It can be toggled (press T) to do a standard or a more comprehensive set of tests - use the default 6 test one first - if it passes one pass of that, use the latter one. A few of the tests in the latter set are intentionally slower.
If you don't have a floppy drive, see the Quick Start Information at that Microsoft link for how to make a bootable CD of the Windows Memory Diagnostic (you need Windiag.iso - you don't necessarily need to use the program they mention to add it to the CD).

A small amount of undetected ("visible" to the operating system) bad sectors on the C partition can cause your problem.

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibility, on another computer if you need to.

Seagate's Seatools will test any brand of hard drive.
Do the long test.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

If only a small number of bad sectors (LBA errors) are found, you get by by preventing Windows from using them by running CHKDSK /R C: .

(If a lot more than that but fewer than 100 are found, you will be offered the option of zero filling the drive, to see if the bad sectors can be replaced by good spare sectors, but that deletes all the data on the drive. You would need to copy the data you do not want to lose to elsewhere BEFORE you zero fill the drive. It's recommended you do that with the diagnostics provided by the same brand as the hard drive's web site if it's not Seagate or Maxtor.)

A small amount of errors in Windows can cause your problem.
Start - Run - Type: cmd, press Enter.
Type: CHKDSK /F C: , press Enter
Answer Yes.
CHKDSK will run the next time the computer boots, if you let it.

OR better still - this takes longer but it checks the entire C partition.
type: CHKDSK /R C: , press Enter
Answer Yes.
CHKDSK will run the next time the computer boots, if you let it.

Report •

January 23, 2011 at 18:46:31
Okay, I've performed most of the test you've recommended and, unfortunately, not found a smoking gun. And it still locks when transferring files.

There are only two IRQ's assigned to USB functions: IRQ 22 for Standard Open HCD USB Controller and IRQ 23 for Standard Enhanced PCI to USB Host Controller. No other function uses IRQ 22 or 23.

The power supply is a ThermalTake model, rated at 550 watts. I have a biostar utility that allows me to monitor voltages from the desktop. They are 11.97Volts, 4.92Volts and 5.05VSB. The 4.92volts concerns me a little but I have seen websites that say it isn't a problem unless it drops to 4.76volts or lower.

I did monitor the voltages as I performed a transfer but they didn't budge, right up to the point where the computer locked up again.

I took the RAM modules out, cleaned the contacts, blew the connectors clean with clean compressed air, put them back in and then performed a MemTest86 on it, but just one Pass. Later, I will go back and do a more extensive check, when I have more time.

I ran chkdsk on all three internal hard drives. No problems found.

The transfers I try to do are mostly to the H:/ drive. This is a 1 TB dynamic drive that I use for video storage. Can this be a factor? Anyway, I'll do more extensive checks later on the hard drives, time permitting.

Are there WinXP libraries, drivers, etc. for USB Operations that might be corrupted that could cause this kind of problem? Is there a way to check those without doing a complete reinstallation of the OS?


Report •

January 23, 2011 at 19:20:34
4.92v is well within 10% of the nominal 5.0v - if it were 4.5 or lower or 5.5 or higher you would have a problem.

You can never rule out a power supply being faulty until you're tried another known good working one - a used one is fine, 250 watts or more recommended for your system, if you can try one.
As a side note I have replaced one ThermalTake PS that had one of the 3 voltages near the lower 10% limit and the problems the computer user had went away.

"The transfers I try to do are mostly to the H:/ drive. This is a 1 TB dynamic drive that I use for video storage. Can this be a factor?"

You COULD be experiencing intermittent data errors.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittent, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

80 wire data cables must have the proper end connector connected to the mboard IDE header - usually that's blue, but in any case it's the one farther from the middle connector on a 3 connector data cable.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

"Are there WinXP libraries, drivers, etc. for USB Operations that might be corrupted that could cause this kind of problem?"

As far as I know, there are just the generic USB drivers that are built into Windows.
You could try going into Device Manager and uninstalling the whole USB stack (RIGHT click on the listings, select Un-install) then restarting the computer which will auto rebuild the USB stack, but I doubt that would help.
(see the Troubleshooting USB device problems reference in response 4 - how to do that is in the IRQ sharing problem info.)

Report •

January 25, 2011 at 07:10:42
My apologies but I have gone back, reviewed my posts and realized that I apparently have not provided sufficient background information to help diagnose this problem. Please, let me correct that now.

I extensively use this system for video processing. By that, I mean that I routinely rip and burn DVDs, transfer large (>4gb) files between internal hard drives and – most relevant – convert avi files to mpg. This last process involves full length movies where the avi file is filtered, color corrected, frameserved between 2 programs, compressed to mpg and stored to hard drive. This one process alone is CPU, RAM and hard-drive intensive – sometimes running continuously for 12+ hours. (It’s not a sequential process, rather it’s done frame by frame. I set it up and it runs by itself until completed.)

In the 5+ years that this computer has been processing video, not once has it locked up during any of these tasks. Yes, I could be wrong but the odds are that the power supply, RAM, CPU, hard drives and SATA cables are not the source of my problem. The ONLY time it has locked up is during a transfer of data to/from an external USB drive.

More about the lock-ups: I never attempted to move video data via USB on this computer until a month or so ago. I have never successfully moved a large amount of data without a crash. It doesn’t matter if it is one large file or a lot of smaller files (I sometimes reduce a video segment to a sequence of bitmap files in order to work on individual video frames, sometimes involving several hundred or even a couple of thousand bmp files.) It doesn’t matter which direction the data is going, ie, HDD to USB or vice versa. It will even crash if I try to Delete a large amount of data on the USB drive. (I presume that a data transfer is still taking place, from the USB drive to the Recycle Bin).

When I initiate a transfer, it will run flawlessly for at minimum of a couple of seconds, sometimes as long as a minute but typically for only 15 to 20 seconds, before it crashes. Before it crashes, the files it transfers will be “good” copies, right up to the last one before the crash.

Because it can transfer some files and due to the random nature of the crash, it is likely not a software issue, short of a resource conflict (which I have looked for and can not find). It appears to be more of a motherboard/hardware issue. I guess I’ll know more about that once the PCI/USB card arrives (any day now) and I try that.

Thanks for your patience in helping me try to work through this.

Report •

January 26, 2011 at 11:42:23
Eureka! The PCI/USB card did the trick.

I received the card, installed it and WinXP auto-loaded the driver. Works like a champ now, successfully moving very large files back and forth without any hiccups.

Okay, sure, this does not “fix” the original problem but at this point, I am tired of dealing with it, having spent too many hours trying one thing after another without success.

I really do appreciate the help. It was my hope to identify and correct the original problem but this band-aid solution gets the job done too.

Thanks again

Report •

January 27, 2011 at 07:15:24
Thanks for tying up this thread.

It appears you probably had the rare case that the onboard USB controller(s) is(are) damaged.

Report •

Ask Question