Computer is not reading my full memory

July 12, 2011 at 11:48:57
Specs: Windows 7, duel core 2.8GHz
i have 2x 4GB memory sticks DDR2 but my computer is only reading 2.50GB but when i put 1x 2GB and a 1x 1GB it reads 3GB does anyone know why i cant get my computer to read the 2x 4GB sticks?

See More: Computer is not reading my full memory

Report •

July 12, 2011 at 11:55:00
Presumably you are running 64-bit Windows 7 (otherwise you're never going to see 8GB)? It might help if you listed the make and model of your motherboard and memory.

Report •

July 12, 2011 at 12:04:35
First, when you say 'computer' do you mean it's not showing the correct amount in the bios and posting screen or do you mean windows can't see it or do neither see it right?

If the bios isn't seeing it check your motherboard specs to see what ram amounts are eligible. Also, it's not uncommon for a motherboard to see a ram stick as a smaller amount if it's not capable of seeing the full capacity. Or if the ram stick uses higher capacity chips than what the motherboard can handle then often it will show a smaller amount of ram.

You should be able to check at to see what is recommended for your board.

Report •

July 12, 2011 at 12:06:23
I am running 32-bit windows 7 and memory is Corsair XMS2-6400 duel core 2.8GHz motherboard is MSI N1996

Report •

Related Solutions

July 12, 2011 at 12:19:53
Thank you for the website, that just answered my question it is showing only 1GB is compatible with my motherboard so i guess i'm lucky to have 3GB in it right now, time for upgrades fun fun.

Report •

July 12, 2011 at 12:22:44
I'm afraid that with 32-bit Windows you are never going to be able to see all of one of your 4GB dimms, let alone both. I'd use the 1+2 GB combination and sell the 4GB dimms.

Report •

July 12, 2011 at 12:54:09
Yeah, the specs are generally based on ram available at the time the motherboard was manufactured so it's possible compatible higher capacity ram might come along later. That's probably why it's seeing the 2 gig stick.

Also, your motherboard isn't N1996. That number is some kind of Australian compliance code. The motherboard model number will be printed somewhere else on the board.

Report •

July 12, 2011 at 14:56:24
"have 2x 4GB memory sticks DDR2 but my computer is only reading 2.50GB but when i put 1x 2GB and a 1x 1GB it reads 3GB "

"I am running 32-bit windows 7 "

The 4gb virtual memory address limit for 32 bit operating systems.
An example of 3gb working better than 4gb in a 32 bit operating system.

See Response 6:

You often have more ram available for the user and Windows when you install 3gb rather than 4gb or more.

You may have not have any programs that benefit from more than 3gb of ram.

Memory Assessor
How much memory do you really need?

A better explanation I've seen.

If you have a 32 bit operating system and you have installed 4gb (or more) in the mboard, the amount of that ram available to Windows and the user is
4gb minus the amount of ram your devices require or have.
- minus the amount of ram shared with onboard video if you're using that
- and/or - minus the amount of ram your dedicated video card installed in a slot has.
If you have more than one video card installed in a slot, it would be minus the ram for all of them.
(and = Some mboard main chipsets have Hybrid video capability. If you have a PCI-E X16 video card installed in a mboard slot that is supported by that feature, it's often the default for both the onboard video and the video on the card to work at the same time, unless you change default bios Setup settings. In that case it would be minus the ram for both of them.)
- minus the amount of ram your sound adapter has, if that applies - e.g. sound cards installed in a mboard slot often have ram
- minus the amount of ram any other devices have, other than hard drives and optical drives, if that applies.

Report •

July 14, 2011 at 16:30:48
Hey guys, My name is wes, Today I took apart my pc and cleaned it, nothing unusual I do it every week. Upon completion, and do i mean thorough, My Bios, and windows 7 64 bit didnt recognize my 2nd stick of ram. Ive done everything, but its only reading the first white slot for ram and none of the other 3. It was working fine earlier, but now not, so I am worried. Everything is properly connected, all ram was securly put into place. I have a gigabyte p55a ud3p mobo w 2x 2 gb ripjaw 1600 ram, lynnfield i7 core 860, and a 1k watt power supply, graphics are crossfired 5850s. Ive googled this problem and tried the msconfig approach, as well as the boot options approach, both sticks of ram will work, but only in the one slot, kinda wierd aye... any and all help would be appriciated, thank you in advance

Report •

July 14, 2011 at 17:54:24
Every week? That's probably a bit much. Make sure that non-working slot is clean (but I suspect it is). I've never heard of this happening but is it possible you 'cleaned' some of the gold plating off the ram slot contacts?

When you cleaned it did you have the power cord disconnected?

Report •

July 15, 2011 at 08:52:40

I'm assuming, of course, that you unplugged the computer or switched off the AC power to it otherwise, while you were fiddling with plugging in / unplugging the ram, or any connection or component inside the case, at ALL times, as you are required to do. If you didn't do that at ALL times, you may have damaged the ram slot's circuits or the mboard's circuits otherwise, or the cpu's circuits (the memory controller is on the CPU, not the mboard, on modern mboards ), yourself. Some places on the mboard including some of the contacts in the mboard's slots are ALWAYS powered as long as the PS is receiving live AC power, even when the computer is NOT running.

A static electricity discharge can damage the PS or the mboard or anything connected to the mboard.
Has your system been exposed to that since it last worked properly ?
- using a regular vacuum cleaner to clean inside the computer case can do that - they produce a tremendous amount of static electricity when running, and can discharge that if you touch anything connected to the vacuum cleaner to anything inside the case.
- if you have synthetic wall to wall carpet where the computer is located and if the humidity in the room is low, your body can build up enough static electricity to damage something when it discharges when you touch something inside the computer case.

Power failure events can damage the PS or the mboard or anything connected to the mboard.

Has there been a power failure event, or a power spike or surge, or has there been lightning strikes in your area since the system last worked properly ?

"gigabyte p55a ud3p"

It doesn't matter which of the 4 ram slots you install ram in, other than the ram can't run in dual channel mode unless it's all matched pairs of the same size per pair and is installed in specific pairs of slots

The most common cause of a problem like yours is the ram module is not properly seated in it's slot. Did you try re-seating the modules in the one ram slot that wasn't recognizing the modules, several times ?
The latches at both ends of each ram slot a module is installed in should always be against the end of the module.
Sometimes one ram slot, or two ram slots on either side, are close to something that makes it more difficult to get it / them to seat properly. Sometimes one latch for a ram slot is close enough to a card in a slot that the card needs to be removed to get the ram to seat properly.

"both sticks of ram will work, but only in the one slot,"

You have 4 ram slots. Are you saying the two ram modules each only work in one slot of the 4, or in only one slot of two slots designated for running them in dual channel mode, but they each work in 3 ram slots ?

If they each work in 3 ram slots, install them in the other pair of slots designated for dual channel mode.

"2x 2 gb ripjaw 1600 ram "

Are the 2 ram modules identical ? A matched pair, and/or exactly the same part number ?
If they are not exactly the same, that can cause you problems, especially if a different ram voltage is specified for at least one module.

Report •

July 15, 2011 at 10:32:45
ok guys got it fixed, no when i clean it its just a usual, vent fan covers, and case clean, dont ever mess w the ram or cpu usually, but i read abunch of posts about the ram not working and traced it back to the ins on the mobo/ munder the cpu. one pin looked bent, just one, so i inspected and found it was broke...... i got the broke piece out of there, said a prayer and wala. It worked. my question being.. It works fine now, all stess tests, etc, not running hot or anything, should i return the board or be content with how it is

Report •

July 15, 2011 at 10:42:59
The mboard warranty NEVER covers damage caused by the user or installer or by an external event.
You, or someone else who installed the cpu, bent the pin on the cpu that resulted in it breaking off.

Report •

July 15, 2011 at 10:43:15
but yes to answer your q my ram is the exacto match, rippjaw 1600 2 g each, my pc is not on the carpet, keep in mind its my baby. I really dont do anything stupid to it. And, yes, everytime i clean the inside of case, vent covers i unplug the pc. As for now all temps are fine, passed all stress tests, boots fine, runs games fine. the pin was bent under/broken touching 3 or 4 other pins, like i said it was just one pin, i removed the pin carefully, and all is well for the time being. I dont think i can return it because they dont produce my mobo anymore, unless they gave me the new one. Anyways ty all for your quick response w vast knowledge, you guys are very helpful thanks again

Report •

July 15, 2011 at 10:45:08
but to answer your other ? tubes, it just would read only my first white slot, both ram sticks worked in this slot, but none of the others, after i got the broken pin out it read both sticks

Report •

July 15, 2011 at 10:54:34
Thanks for the thanks and for the comments and for answering some of the questions.

"it just would read only my first white slot, both ram sticks worked in this slot, but none of the others,"

That's an extremely unusual situation.

You're very fortunate that the memory recognition and the cpu seems to be working fine now, so far.
One or more broken pins on the cpu is evidence that the cpu was damaged by the installer and that would void the warranty on the cpu .

Report •

July 15, 2011 at 11:15:41
yo tubes, whats the best temp program, im running core temp- mid 30s, and speed fan says im in mid to low 20s

Report •

July 15, 2011 at 14:58:58

A core temp of mid 30s C is quite cool.
It probably can't be below room temp - e.g. 2x C - unless you're using a chilled cooling method.

wes and anyone

The short answer.....

- there is probably a Gigabyte supplied hardware monitoring utility that you can install in Windows, on the CD that came with the mboard, or if not, that you can download from the Gigabyte web site, perhaps in the software downloads for the model, that is probably more accurate than SpeedFan or other third party utilities.

The same applies to most if not all non brand name system mboards.
The hardware monitoring utility for a non brand name system mboard can be used for a brand name system mboard if you can dertermine who actually made the mboard - in most cases the brand name system manufacturer did not make the mboard - but the readings and the labeling may not be as accurate - go by the readings in the bios.

The mboard must have hardware monitoring capabilty built into it in order for SpeedFan or any program to be able to find something to read.

When your mboard has hardware monitoring capability, the mboard's bios probably has a place where you can examine the current temps, fan rpms, and voltage readings.

Usually the readings have been tweaked in the bios version's code to make them as accurate as possible for the mboard model.

Third party programs like SpeedFan make assumptions about what the readings from sensors should be according to the particular hardware monitoring chip, or built in hardware monitoring support the main chipset has, and where which sensor for what are supposed to be connected according to the chip manufacturer's specs.

The mboard manufacturer sometimes has not connected a sensor to an input at all, or it's connected to a different location that the chip manufacturer specified.

Some mboards have a header an optional external temp sensor can be connected to - that sensor is not connected by default. The mboard may or may not have come with that external sensor.
(E.g. I have an Epox mboard that has that and it came with the sensor.)

The bios version will not show readings for an input a sensor is not connected to, unless it has that header for an external sensor and there is no sensor connected to it, and if a sensor is not connected to an input it is supposed to be connected to according to the chip manufacturer, the bios version likely has the correct labeling for the reading.

The third party program such as SpeedFan usually lists the readings from ALL possible inputs, whether they actually have a sensor connected to them or not.

The readings from those inputs that have no sensor connected to them never change and may yield an oddball or an impossible reading.

If the mboard manufacturer connected a sensor but did not connect it to the input the hardware monitoring chip manufacturer specified, you can usually change the labeling in the third party program to correct that to jive with the labeling in the bios version .

If the temp or the voltage or the rpm for the same thing is considerably different in the mboard's bios, go by the reading in the bios, and usually you can tweak the reading in the third party program to make it the same or nearly the same.

The rpm of some fans may not be detected in the bios due to it not spinning within an expected range built into the bios code - e.g. it spins slower than the bottom of the rpm range, or it's a temp controlled variable speed fan in the PS that has external wiring to connect a plug to a mboard fan header, and it spins slower than the bottom of the rpm range when the PS is cool.
Sometimes you can tweak a setting in a third party program in Windows to get a reading from such a fan.

(The CPU fan rpm reading MUST be within the range the bios expects, otherwise the bios detects no rpm and the mboard will probably shut off automatically a short time after booting, after no more than a few minutes, often much less than that) .

Report •

Ask Question