Computer Doesn't Always Complete POST

July 24, 2011 at 06:25:45
Specs: Windows 7 Home Premium x86 (32-bit), 2 GHz / 2046 MB
Hi there, this has been a problem with my computer ever since I received it; as it was second-hand, I just kind of accepted it, but it has become a major problem for me recently.

My computer was bought from Canada Computers originally, then passed down to me from my mom's boss while they were replacing most of their computers with Apple iMacs. It has a Biostar K8M800 Micro AM2 Motherboard, with an AMD Athlon 64 3200+ CPU (2 GHz and not currently overclocking; that's another story, and another thread...) and 2GB of DDR2 667 MHz RAM. It has a 500W PSU and an ATi HD Radeon 3650 512MB AGP graphics card. Lastly, there is a 500GB SATA II hard disk drive in it, with Windows 7 Home Premium 32-bit as the only OS.

My problem is this: every time I start on my computer, as all computers should, it is supposed to go through a Quick Power On Self Test (POST). However, it doesn't usually complete the POST on the first try, and therefore does not beep. If I don't hear a beep saying the POST was successful, then I have to hit the Reset button on my computer. Often, multiple times. This morning, when I tried to turn on my computer, I think I must have hit the reset button at least 4 times, and in the middle I even tried holding the power button to turn it off, then turn it back on again. Eventually I was able to get the thing to start, or I would not be posting this right now.

I'm guessing this has something to do with a BIOS setting, but I'm not entirely sure the process of elimination would work for this. Do you think, if I disabled the "Quick Power On Self Test" in the BIOS, would it skip the "Quick" part and go through a full POST, or would it just disable the POST completely? I have a feeling it's just rushing through it and "forgetting" to finish.

See More: Computer Doesnt Always Complete POST

July 24, 2011 at 06:42:30
Do NOT disable "Quick POST". How about listing detailed specs on the 500W power supply - make/model & amperage ratings of the various voltage rails?

Report •

July 24, 2011 at 06:50:43
Ugh... this is going to be painful...
How about I just show you a picture instead, and you can figure everything out? There is no make/model on the actual PSU, AFAIK. It just says "ATX Switching Power Supply" on it.
I suppose this is typical of CC...

(BTW, thanks for responding so quickly!)

Report •

July 24, 2011 at 07:30:08
It's a cheap generic garbage unit that probably sold for about $15. Decent quality 500W power supplies cost at least 3 times that much.

See the +5v amperage rating at 47A? Modern systems barely use the +5v rail. The majority of the power comes from the +12v rail. That tells me one of 2 things - it's either a very old unit that was designed for Pentium 3 (or older systems) that DO rely on the +5v rail, or it's a manufacturer "trick" to falsely inflate the overall wattage rating of the unit. 32A on the +3.3v rail is overkill as well. On a modern system (p4 or newer), there's no need for either of these to be higher than 25A. And the +12v rail should be higher than 22A. At best, it's a 350W unit, but I doubt it's even capabale of that. Do you have another unit laying around that you can use for testing?

Report •

Related Solutions

July 24, 2011 at 11:17:24
Nope. The only other power supplies I have are in my dad's computer, which is out of the question, and one that is older than this one that came with a '98 machine.

So, you think it's the PSU? Say if I bought this power supply. Do you think my issues would be solved? Or even a Seasonic or Silverstone PSU, if the store has any in stock. (The only advantage of these two is the cost; OCZ is a brand I've heard positive things about, compared to obscure brands like iCAN, which I know is crappy, or Seasonic, which I've never heard of before.)

Report •

July 24, 2011 at 18:16:31
You might also want to check inside the case to make sure that there are no loose connections. Corsair & PC Power & Cooling generally are good PSU's, and I believe Silverstone is as well.

Report •

July 25, 2011 at 13:19:04
No loose connections, as far as I can tell. I've had to open the case before, and I made sure everything is snug. So, looks like I'll have to buy a PSU in the near future. Though today wasn't as bad, just had to reset it once, but... I shouldn't have to reset it at all just to get it started.

Report •

Ask Question