Complication after BIOS update

November 2, 2009 at 23:46:47
Specs: Linux i686
I have this laptop (Acer Aspire 5315) for two years now and it has always worked fine hardware wise, quirks but what laptop doesn't have them.

For the last couple of days I had an issue with the laptop it just turned itself off, come to find that it is a common issue with this particular model, and that a lot of people had it right as soon or a few days after they purchased the laptop, considered myself lucky that it took it two years for it to happen, out of reading a lot of threads on this issue, I decided to update my BIOS from 1.21 to 1.45, figured that with so many users with this issue, maybe a firmware update would cover it, hopefully.

Firmware update went fine, used it under windows, computer is not bricked it works fine. however, I had a HDD password set in case someone in the house decided to use it, the password was "sophia87", it is my own computer I set the password on it, after the bios update though, that password is not accepted by the BIOS I am right now using a live Ubuntu CD to write this, the computer is fully functional, but it appears it is near impossible to reset CMOS on this thing, I would like tips on what to do, it is not like I have any data on my HDD but I'd like to enjoy those little perks we've been enjoying for the last 20 years or so, being able to run a OS from a Hard Drive without a removable source, thank you in advance for your responses.

See More: Complication after BIOS update

Report •

November 3, 2009 at 07:21:27
update on what I tried:

Tried through ubuntu with the hard disk utility to create a filesystem on the HDD but it couldnt do it just like i tried to formate it and install it with ubuntu install, it was able to partition on the screen yet when it went into performing the task, not so much, kept giving me ooignore or retry option, never did never did hear HDD being written on.

Report •
Related Solutions

Ask Question