Compaq Presario 2100 laptop stopped working

Hewlett-packard Compaq presario 2100 ser...
July 26, 2010 at 01:05:51
Specs: Windows XP
Hello, I'm hoping someone may be able to help me with this problem.

A few years ago my laptop, which is a HP Compaq Presario 2100, stopped working. I'll try to explain the best I can what's going on:

When the laptop is plugged in and then turned on, all of the lights on it will turn on, all of them except for the power indicating light. The screen remains completely off, and it doesn't sound like the hard drive is running, just the fans. The CD drive and floppy drive both work. The weird part is that the things that do turn on only stay on for about 10-20 seconds and then everything shuts down. And no matter how long the laptop is plugged in the charge light never turns on and the battery in the laptop never gains any power. I can tell this because this particular battery comes out and has a manual indicator of power on its side.

I'm assuming that there is something wrong with the power, but I can't be sure. Anyone have any ideas? Thanks!

EDIT: I forgot to mention a few things:

-VERY rarely the screen will turn on, but it doesn't display anything, it just glows.
-Somethings the power indicator light will blink, as if the laptop is in sleep mode.
-When the laptop is first plugged in and all the lights come on, the hard drive indicator light (the one that indicates the computer is running or busy) flicks on but then right back off.


See More: Compaq Presario 2100 laptop stopped working

Report •


#1
July 26, 2010 at 07:09:53
... first remove the battery and unhook mains adapter and hold-in the power button for a few seconds.

... take a look @ this post, remove the battery and give the mains adapter plug a "wiggle"

... can you enter your >>bios<< at all by tapping the relevant <key(s)> at bootup?


.

... Posting is provided "AS IS" with no warranties
http://img692.imageshack.us/img692/...
Grrrr... ...im


Report •

#2
July 26, 2010 at 11:54:00
Tried both things, no luck. And no, I can't enter the bios at bootup, even if the screen turns on nothing shows up on it and I still can't hear the hard drive running.

Report •

#3
July 27, 2010 at 01:23:35
"...Tried both things, no luck..."

... so what you're saying is that when you wiggle the mains adapter plug with the battery removed the lights do not flash on/off(?)

... please make sure of the above as it'll determine whether the jack plug solder is cracked or not and it should function or charge-up a "good" battery!

... strange as it may seem have you tried a bootup cd/floppy to see if it'll bootup from it?

... I have had a case when a laptop was stuck in hibernation (bungled) mode showing the same symptoms apart from "your" screen glowing!

... take a look at this post #Response Number 2

... service manual download (Lithium Coin Type Battery CR1220)


.

.

... Posting is provided "AS IS" with no warranties
http://img692.imageshack.us/img692/...
Grrrr... ...im


Report •

Related Solutions

#4
July 30, 2010 at 11:21:52
The lights do not flash when I wiggle the main power adapter. I also tried using a USB boot disk, no luck there either. I have determined that the hard drive does start running, but for whatever reason the computer never boots and everything loses power after a few seconds.

Report •

#5
August 1, 2010 at 11:06:04
"...all of the lights on it will turn on, all of them except for the power indicating light..."

... still sounds like the power jack socket to me!

... even with the hard drive removed one one should be able to boot into your bios and stay "on" just from the mains adapter!

... of course your've check the adapter with a voltmeter for faults(?)


.

... Posting is provided "AS IS" with no warranties
http://img692.imageshack.us/img692/...
Grrrr... ...im


Report •

#6
October 30, 2010 at 19:59:20
your charging port is shot as well as your battery. it a quick and easy fix if you know what your doing. if not take it in to a tech. to fix it

Report •

Ask Question