Checking NVRAM... on attaching HDD's

October 12, 2010 at 02:50:38
Specs: Windows 7 64bit Prof, AMD Phenom X2 X555 / Corsair 2x2GB DDR3 1600
I got a strange problem, my comp hangs at "Checking NVRam..." when I try to install an additional HDD (Samsung 2TB EcoGreen), also tried different HDD's (Samsung SP2504C), none work, unfortunately i only have Samsung HDD's so I can't try with a different vendor HDD.

I also cannot add an additional HDD from USB/eSATA.

The funny part is the comp runs fine if i don't add the HDD, I'm writing this with that comp.

Comp Stats(All Brand New, 1 week old, currently installed):
Mobo: ASUS M4A88TD-M EVO (880G/SB850)
CPU: AMD Phenom X2 X555 @Stock, no Core unlock
Ram: Corsair 2x2GB DDR3 1600 @1333 -> max supported on that CPU
HDD1: Kingston 40GB SSD (with Intel Firmware) [SATA2] (not new, but did run fine on the old machine)
HDD2: Samsung SP2504C [SATA2] (not new, but did run fine on the old machine)
Optical: OEM Samsung CD/DVD Writer [SATA]
PSU: Seasonic S12II 430W
Case: Antec mini P182
Graphics: IGP -> HD4200

I installed Win7 64bit via USB and this worked fine, in fact all USB Ports are working.
I'm running the newest BIOS Version from ASUS.
SATA Controllers are set to AHCI, Win7 runs the AHCI Driver.

Any ideas what I could try?

Thanks for any help!

Edit: added note on AHCI
Edit2: Added note on external HDD

See More: Checking NVRAM... on attaching HDDs

October 12, 2010 at 04:44:50
Check the BIOS settings to make sure you don't have it set to run some sort of RAID.

Report •

October 12, 2010 at 04:52:57
It's all set to AHCI, I also downed the speed to 3Gb (as it has SATA3 support), no change.

I also tried with disable IDE controller (I have no IDE device in that configuration), no change.

Report •

October 12, 2010 at 06:15:26
Check your manual to determine which SATA ports to use when you wish to keep the drives separate. Also check to see which hard drive is actually set as the hard drive boot device. I believe the last one introduced in the system is the default.

Report •

Related Solutions

October 12, 2010 at 06:40:33
I'm using the correct ports, I anyway intend to use all 5 of the available ports.
My System boots fine from my SSD, so my BOOT Disk is set correctly as well.

I just can't add any other HDD, internal or external at BOOT.

If i add external HDD's while Windows is running they are detected and usable without a problem.

Report •

October 12, 2010 at 14:09:29
That indicates the BIOS settings are wrong. Most likely set to use all drive in a RAID array.

Report •

October 14, 2010 at 07:16:09
No RAID mode in BIOS. It's set to AHCI.
I know there seem to be some compatibility troubles with SB850, but even the FW upgrades from Samsung doesn't change the Problem.

ASUS isn't helpful either...

Report •

October 14, 2010 at 07:29:11
Have you set which hard drive is to be the first boot device? Now that there are so many hard drive ports there are additional selections to be made in the BIOS besides simply stating the hard drive is set as the first or second device.

Report •

October 14, 2010 at 07:56:39
Yes, I have set that, it's in a separate Menu, and it keeps changing when i plug in USB Drives, so i'm used to check that setting, as the BIOS won't take my SSD as the default.

My Port Mapping:
S1: Kingston SSD (working fine) [active and first HDD Boot Disc]
S2: Samsung SP2504C (working fine)
S3: external eSATA -> no disc
S4: Samsung 2TB F3EG with SB850 FW (not working)
S5: no disc
S6: OEM Samsung CD/DVD Writer

On a side note, if I set SATA to IDE Mode and boot into the BIOS again. All Drives are detected correctly including the not working ones, but I can't Boot into Windows as it is running in AHCI Mode.

The discs are running fine on a mobo with AMD790FX/SB600 Chipset.

Report •

October 14, 2010 at 08:06:59
Can you boot into the BIOS screens when additional drives are connected or won't the process go that far?

Look for an option to increase the seek time for configuring hard drives. Your BIOS may or may not include that option. If present, set to maximum time.

Report •

October 14, 2010 at 08:24:21
Yes, I can even select the disc in the HDD Boot Order, so it is detected.
But it does not Boot up.

Now i unplugged the CD/DVD writer and plugged in the additional HDD at it works...
So i guess this is a Power issue, I guess I have to check how my PSU is splitting it's 12V Rails and calc the Amps, oh always this new tech. ;-)

Report •

October 14, 2010 at 09:03:40
OK then, the current recommendations are to use a PSU with one +12V rail of sufficient amperage to serve all needs.

If your PSU is running that close to capacity on at least one of the 12V rails it may be too small. Post all your specs including the PSU model.

Report •

October 14, 2010 at 09:27:01
CPU: AMD Phenom X2 X555, TDP 80W
Ram: Corsair 2x2GB DDR3 1600
Discs: 1xSDD, 3xHDD (that's the plan)
Optical: OEM Samsung CD/DVD Writer
PSU: Seasonic S12II 430W (17A per Rail)
Fans: 1x120mm, 1x200mm
Graphics: IGP -> onboard
Cards: 1xPCIe Creative X-Fi Titanium, 1xPCIe NEC USB3 (from ASUS)

According the ATX Spec dual rail PSU's should have one rail for the CPU and one for the rest, i guess i'm hitting the limit on the second one.

Report •

October 14, 2010 at 09:46:55
I found this three year old review (linked below) that states in part "The SS-430GB also features dual +12v rails each rated at 17 amps, with a total output of 360w (30 amps) across both rails simultaneously".

You may be correct about the draw.

Report •

October 14, 2010 at 10:28:24
thanks for your help.
I guess i'm going to buy another PSU either with single rail or quad rail. ;-)

Report •

October 14, 2010 at 13:28:51
Just for the Info and for other having the same issue.

ASUS sent me a Beta BIOS Version, which solves the Issue.

Report •

October 14, 2010 at 15:29:55
That is interesting. However, I don't understand why your could get the hard drive to work if substituted for the optical drive.

If the BIOS is the issue then shame on Asus for releasing the board with a defective BIOS.

Maybe this utube video is appropriate after all. I am linking to the thread here where the video link was originally posted.

Report •

October 15, 2010 at 02:42:06
lol... that's funny. :-)

I guess the BIOS only managed to manage 3 internal SATA devices,
or it has something to do with the compatibility Issues between SB850 and Samsung (Which are proven to exist, as there are FW updates from Samsung for the newer Drives, this is uncommon for Samsung).
You may notice I basically only have Samsung discs/drives except for the SSD.

btw: it appears that my PSU is a 30A single rail PSU. Seasonic is just marketing it as such...

Report •

October 15, 2010 at 05:54:08
Your PSU has TWO +12V rails with each having 17A. But as PSU makers do they fudge the numbers by stating the total you can get from the PSU from the +12V rail is 30A. Look at the link below to see the details on that unit.

Report •

October 16, 2010 at 04:10:25
Well, it doesn't really matter but Newegg is not a good source for spec's. They just state what the manufacturer is stating, which makes sense.

This is for the 380 but you can guess the whole line is built the same way at least for the low watts parts.

Multiple +12V Outputs - Enhanced +12V current capability broadens utilization possibilities.
Not really multiple 12V line; it has current protection to keep electrical energy in each output wire from exceeding 240VA.

There are even other tear down sources that indicate it, also the respected review sites don't lose one word on that topic, i wonder why. ;-)

Report •

October 16, 2010 at 06:27:39
Most review sites get paid to review. Hardly unbiased. They should get the specs right though.

Report •

February 22, 2011 at 15:24:09
Thanks for that. I'm having exactly the same problem with the same disk and M4A78 PRO Mobo.

Report •

February 22, 2011 at 15:49:12

You need to start your own thread here at CN in the hardware forum. Provide specs and as much detail as you can.

Report •

February 24, 2011 at 01:23:54
Thanks for pointing out the obvious OneHill. I was actually replying to Norgs post:
"Just for the Info and for other having the same issue.
ASUS sent me a Beta BIOS Version, which solves the Issue."
But I now see that replies just get tagged on the end so may appear out of context.

Report •

Ask Question