Cheap Netbook no longer power up - Help

Sim-one electronics / 10.2" netbook, 160gb hd,...
January 31, 2010 at 15:33:24
Specs: Windows XP
I recently bought a really cheap Sim-One Electronic branded laptop from Hong Kong, without warranty. It was working fine for the first couple of days, Then I tried using it running on battery. I worked fine until the battery ran out and it hibernated. After I charged it for about 4 hours it still wouldn't turn on. And it still won't turn on now. The power cable works fine, and the battery charging light comes on the netbook when I plug the cable in. When I press the power button to turn it on, it whirrs and then all the lights go out. I've tried everything short of pulling the computer apart! Can't find a repairer around here that will touch it because they can't believe it's not under warranty. I know I didn't pay much for it (AU$400) but I'd really like it if I could get it to work.
Thanks for any suggestions

See More: Cheap Netbook no longer power up - Help

Report •

January 31, 2010 at 21:51:23
Check the manual to see if there is a way to do a 'hard' reset.

Report •

January 31, 2010 at 22:28:10
No there isn't but thanks for the suggestion, Any other ideas?

Report •
Related Solutions

Ask Question