CD-ROM driver in Virtual PC 2007 for NT 3.1

June 10, 2010 at 08:16:46
Specs: Windows NT 3.1
Hello.
Does anyone know how to get the CD-ROM working in Windows NT 3.1 under Virtual PC 2007? I can't find the drivers of it and don't know how to install too. Would someone like to share the drivers of this and a guide to make it work too?

Thanks a lot!
Best Regards!


See More: CD-ROM driver in Virtual PC 2007 for NT 3.1

Report •

#1
June 10, 2010 at 09:36:12
What is the host OS?

Report •

#2
June 10, 2010 at 09:49:52
Thanks for the reply! The host OS is Windows 7 x64 English.

Report •

#3
June 10, 2010 at 09:54:31
I don't think you need to install any drivers in order to access optical drives when using Virtual PC.

What is the problem? When you are in Virtual PC you don't see the optical drives anywhere?

Are your optical drives SATA type?


Report •

Related Solutions

#4
June 10, 2010 at 11:53:09
On the same host OS and configuration, NT 3.5 and NT 3.51 will automatically install the CD-ROM driver and show in the File Manager, but not for NT 3.1, only floppy and hard drive are shown in the File Manager, so I thought the driver has to be install manually. The CD-ROM can be detected when using the bootdisk during the installation, but not for Windows itself. And yes, my optical drives in the host OS is SATAII.

Thanks for help!


Report •

#5
June 10, 2010 at 12:13:34
I am not sure about it but you may have problems getting SATA drive to run in an OS that wasn't designed to utilize them.

Usually the issue with hardware is just the opposite. You can't run old hardware on a newer OS due to driver support. So you run in a compatibility mode for an OS that will support the hardware. In this case I don't think the OS can support SATA devices.

I have no experience with NT 3.1.


Report •

#6
June 10, 2010 at 13:19:28
No, you can't get a cd drive working without the correct setup. It will be seen as the vpc emulated cd drive not the hosts drive.

If you are trying to install then you need. "Setup Disk for CD-ROM Installation." a floppy or it's image.
http://support.microsoft.com/kb/103939


Report •

#7
June 10, 2010 at 17:56:27
@OtheHill: That means if I run the NT 3.1 in a computer that has a IDE optical drive will solve the problem? Thanks!

@jefro: Is "Setup Disk for CD-ROM Installation." equal to "Windows NT Setup Boot Disk"? If not, where can I get it? Thank you!


Report •

#8
June 10, 2010 at 19:42:34
Ultimate

As I stated I have no working experience with NT3.1. That said, I would assume that OS should have no problem configuring an IDE ATA/ATAPI optical drive.


Report •

#9
June 11, 2010 at 16:28:23
In VirtualPC the client OS has no knowledge of the real hardware (except the CPU). The client sees only the emulated hardware provided by VirtualPC. It will see any CD drive supported by the host as an IDE.

And that is likely the problem. When NT3.1 was released it was expected that most users would be using SCSI CD drives. Support for IDE CD drives were not nearly as good.

You will probably need to obtain a driver. I have no idea where you might find one - if one is available at all. The version of IDE emulated in VirtualPC is more advanced than anything available when NT3.1 was released in 1993.


Report •

#10
June 12, 2010 at 01:31:13
I've just found out that VPC 2007 doesn't support SCSI devices emulation, so the only way to get the optical drive in VPC is the IDE drivers for NT 3.1 (if it exists).

I've tried on VMware too, but the SCSI optical drive was not detected by the setup, seems I done something wrong, would anyone like to guide me how to emulate a SCSI optical drive under the same OS and configuration?

Thanks so much for help!


Report •

#11
June 12, 2010 at 07:49:31
VirtualPC provides emulated hardware to the client OS. In the case of HD's and CD's they will be presented as IDE, regardless of what they might be in the host. Except for the CPU the client OS has no knowledge of and cannot find out about real hardware in the host. You do not have a choice in this. There is no provision for emulating other hardware, such as an SCSI CD.

I don't know about VMware but I suspect it is much the same.

If you wish to use a CD with NT3.1 in VirtualPC you must have an IDE driver. Otherwise the best you can do is to capture an ISO image of a CD which you have created in the host.


Report •

#12
June 13, 2010 at 01:59:27
@LMiller7: Do you know where can I find the IDE CD-ROM driver for NT 3.1? Thank you!

Report •

#13
June 13, 2010 at 04:57:16
As I said before, I have no idea where an IDE driver for NT3.1 might be found, or if one is even available. This is a very old OS which very few members of this forum have used.

Report •

#14
June 13, 2010 at 10:13:10
Thanks for all the replies, I appreciate all the helps! I'll try to find the driver, if can't, I'll leave it alone.

Report •

Ask Question