can't use usb memory

July 31, 2014 at 12:03:54
Specs: Windows 8
Packard Bell easynote te69bm - won't read usb memory sticks - why- reads first of all but then refuses. tried different memory sticks and they work on other laptops

See More: cant use usb memory

Report •

July 31, 2014 at 13:23:53
Is the device recognized in Device Manager?

If so, is the power management disabled for all of your USB ports?

Are these what revision (version) is both the ports you have tried and the memory sticks?

"...reads first of all but then refuses..."

So it properly recognizes and reads the drives, but then stops?

Does it stop during a file operation or just after it hasn't been used in a while?

If the latter is true, I'd definitely look into power saving options.

You should also read these articles from Microsoft:

How many different USB ports have you tried?

Could you list the make and model of the USB drives you have tested?

Have you used a different device (Mouse, Keyboard, Printer) in any of these ports?

If all that fails, it is possible that it is just a problem with the USB ports which point you should contact PB about warranty info:

User Info Page Biography for full specs.

message edited by NT56erbx

Report •
Related Solutions

Ask Question