can't see ide hard drive in bios

August 21, 2011 at 14:46:53
Specs: Windows XP, 550 mhz, 448MB
award bios says no primary hard drive, and won't boot.
so I put windows XP installation disk in, it sees the HD and all the partitions that were on it, deletes partitions, formats, and does the install to the point of reboot, which of course fails because of bios.
the HD is a WD1200AB 120g ide.
under windows installation, I can see files with a dir command, I can read the log with a type command, and I can do a chkdsk.

BUT spinrite 6 also cannot see the HD.

I think there must be some change needed in the BIOS, but don't know what.
the type for the WD is set to AUTO.

I can send snapshots of the bios screens if that would help.
I have been reading the BIOS section of the ASUS P3V4X motherboard, to no avail.

this is an 11-year-old computer I am just trying to get the O/s back on it so I can give it away instead of throwing it in the dump.

thanks for any help

See More: cant see ide hard drive in bios

Report •

August 21, 2011 at 16:49:19
I find your explanation hard to believe. If the BIOS doesn't recognize the HDD, there's no way you could format or do anything else with it. Assuming the drive is good, the only thing(s) that could be wrong would be the IDE cable, the master/slave jumper setting, or the IDE controller on the motherboard.

Report •

August 21, 2011 at 21:53:38
Was the drive previously working in that computer?

Does it, or did it ever, have a drive/bios overlay on it?

Is there more than one hard drive connected in the computer?

Report •

August 22, 2011 at 04:50:55
hi mickliq, yeah, so do I find it hard to believe! but that is exactly what is happening.
the boot sequence in the bios is CD, then the WD hd; attempting a normal boot, we get "insert a bootable disk & re-boot" (not precise wording but you know the msg)

but with the windows installation disk in the CD, windows does its setup, then displays all the partitions, delete, format, etc.
the guy at spinrite (not Steve) told me that this is because Windows install does not use the bios.

Hi DAVE, yes there are (were ) 2 drives , the second one being a 40g seagate.
the Windows install does NOT show that drive now, so I am assuming it is the one that conked.

and yes, both drives were working normally as I used REVO UNINSTALLER to clean up the system.
when I saw it has an 'EVIDENCE REMOVER' function, that says it just does a thorough wipe of all DELETED space, I started that, giving it all partitions on both drives - exactly what I wanted, to clear out all deleted space where all my personal data had been.
well revo finished, but the system was frozen, and on the re-boot, the clanking began, and as described previously.

so the WD 120g drive is there, Windows formats it (I have done this 3 times now, creating new ptn on unused space, etc), writes on it (and afte it is finished I can READ the log file, using 'type' command).
but somehow the bios doesn't see it. I reset the bios to default, have tried different settings for the WD, but nothing yet.
guess my next step would be to contact the bios folks, ASUS.

OR just give up and recycle it as scrap. except for the monitor which is an Acer 20 inch flat screen.

thanks for your replies,


Report •

Related Solutions

August 22, 2011 at 21:32:55
With two drives connected it's possible the drive you're trying to install to isn't set active.

With 98 and probably XP, the MS partitioning software won't create an active partition if one already exists. So if the second drive is already set active then I don't think you can set the first one active. If a partition isn't active you can partition, format and install an OS but it won't boot.

The XP partition command is DISKPART. When booting from the XP disk and starting the setup I'm not sure if you can run diskpart separately because I've never tried it that way. And if you can I'm not sure if you can remove the active byte on one drive so you can set it on another one.

Given my uncertainty you could temporarily disconnect the second drive and redo the install. That will force XP setup to set the drive active.

Or you could use third party software like AEFDISK. I know with that you can remove and reset the active byte.

Anyway, given your description, an active partition problem seems the most likely reason.

Report •

August 31, 2011 at 20:31:57
askd to mark a best answer - there is no answer to the problem, since Dave's last suggestion is not the case.

Report •

August 31, 2011 at 21:38:52
You don't need to choose a 'best answer' especially if nothing has helped.

Report •

Ask Question