Can't see data on Sata drive

Hitachi Deskstar 7k1000.b hdt721010sla36...
February 26, 2010 at 08:00:23
Specs: Windows XP
I reformatted my 160gb SATA HD yesterday, only to find that my secondary 1TB SATA HD is saying it needs to be formatted. It is recognized by Windows, but I can not access the data that was on it.

I've done this many times with IDE drives, so I figured it was the same with SATA drives. Before I reformatted, I backed up at much as I could on a 40gb IDE drive, and that works fine. But, I ran out of room for the larger files. I would really like this drive to work. Any suggestions?

See More: Cant see data on Sata drive

Report •

February 26, 2010 at 12:23:09
OMG! After numerous searches and many failed attempts using "recovery" programs, I found the issue. Disk Management was reporting the drive as having a 32mb partition. This lead to a search which revealed a strange problem where large capacity drives sometimes randomly change their partition size to 32mb. Using the program they linked to allowed me to not only get the partition back to normal, but the data remained intact! Solved!

Report •
Related Solutions

Ask Question