Can't load WinXP after switching SATA connect

Asus A8n32-sli deluxe motherboard
July 12, 2010 at 20:38:45
Specs: WinXP Home
Hi all, I'm hoping someone can help me with a SATA problem.

I have 2 Western Digital WD740GD hard drives in a RAID 0 config. They are connected to my ASUS A8N32-SLI motherboard using the SATA1 and SATA2 connectors.

Because a new graphics card blocks these connectors, I want to move the drives down to SATA3 and SATA4.

I tried just switching the cables and enabling the SATA3 and SATA4 controllers in BIOS, but when I do that I don't get past the WinXP blue bar loading screen. It freezes briefly then goes into a reboot loop. Trying to start Windows in safe mode has the same result, though I can see it's hanging up at Mup.sys.

When I put the drives back on SATA1 and 2, everything works fine again.

Did I miss a step? Is there something in Windows I need to edit to register the change? Thanks in advance for your responses.

See More: Cant load WinXP after switching SATA connect

July 12, 2010 at 21:01:04
You may have knocked the ram while you were in there.
Remove the AC power to the case, make sure the ram, and all cards in slots, are all the way down in their slots, or remove, replace the ram

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

If that doesn't help

"in a RAID 0 config."

That may be related to your problem. You may need to reconfigure something about the RAID array.

"Trying to start Windows in safe mode has the same result, though I can see it's hanging up at Mup.sys."

Safe mode always lists what is being loaded, then the screen stays the same for a while, then you see the logon screen if nothings wrong, it goes to the desktop screen, etc. . Mup.sys or whatever is the last thing on the list doesn't necessarily indicate the boot is hanging on Mup.sys or whatever - usually something else is the problem.

"a new graphics card "

If your power supply does not have enough capacity to handle the graphics card being on the system, it may be the power supply that's causing your symptoms.

Your power supply must have at least the minimum capacity required to support a system with the graphics card you are using installed, or the max graphics card you might install in the future.
(Onboard video - video built into the mboard - IS NOT A CARD ! )
If that info is not in the ad for the video card, you can go to the video card maker's web site and look up the specs for the model - often under system requirements - the minimum PS wattage, and, more important, the minimum amperage the PS must supply at 12v is stated. If you don't find that, any card with the same video chipset including any letters after the model number has very similar minimum PS requirements. Some power supplies have two or more +12v ratings - in that case, add those ratings to determine the total +12v current capacity.

If you're a gamer...
In most if not all cases, the max capacity rating of the PS is an intermittent rating. It's recommended that you do not load your PS to any more that 80% of that rating if you are going to be using something that puts a constant load on it, such as playing a recent game for hours on end. In that case, you multiply the min capacity stated for the system with the particular video chipset on the card by 1.25 to find the min. capacity of the PS you should get.

If you need to get a PS with more capacity, you can usually replace it with any decent standard sized standard ATX PS.

Standard (PS/2) power supply size - 86mm high, 150mm wide, 140mm deep, or 3 3/8" h x 5 7/8" w x 5 1/2" d , or very close to that, though the depth can be more or less for some PSs.

Don't buy an el-cheapo PS.
See response 3 in this:

Report •

July 12, 2010 at 22:17:10
Thanks very much for the reponse.

While troubleshooting, I've switched back and forth a few times now between SATA1-2 and SATA3-4. Windows loads every time the drives are connected to 1 and 2; fails to load when connected to 3 and 4. So I don't think loose RAM or bad cables are the problem.

That doesn't rule out a physical problem with the SATA3-4 connectors on the motherboard, but BIOS does recognize the drives when plugged into SATA3 and 4. Is that sufficient evidence that those connectors are working properly?

As far as PSU goes, I'm using a Seasonic S12 600W, which according to the new card's minimum requirements should be more than enough. I should also note that for troubleshooting purposes I put my original graphics card back.

I do have a feeling that the problem has to do with the RAID configuration, but other than enabling the SATA controllers in BIOS, I haven't a clue where to look.

Report •

July 13, 2010 at 09:38:27
Ok, so I missed a few things you stated.

I know very little about RAID arrays, but I did find this in a instructions pamphlet for a ST Lab SI A-142 EIDE PCI hard drive controller card that supports RAID (Silicon Image chipset) that I scanned before I sent the card to my brother (I have a slightly older version of the same card that had no such pamphlet) .....

"Resolving conflicts

If after a disk failure, if the replacement disk was previously part of a RAID set (or used in another system), it may have conflicting metadata, specfically in reference to drive connection information. If so, this will prevent the RAID set from being either created or rebuilt.In order for the RAID set to function properly, this old metadata must be first overwritten with new metadata. To Resolve this, press F4, the correct metadata, including the correct drive connection information, will be written to the replacement disk. "

So - it appears you need to re-write just the metadata in order to correct the drive connection information.

Take a look in the Asus manual for the mboard model - there is often info about RAID and the specific keys you use in a manual for an Asus mboard that has RAID capabilty built in.

Or look on the Asus web site for info about RAID.


You may also need to rebuild the RAID array.

From the same pamphlet...

"Rebuilding a failed mirror set

As the bios boots press F3 when prompted to enter the RAID bios.
Press F1 to dissolve an array.
Press the number of the mirrored array to be dissolved.
Press Y to confirm, Be sure you delete the correct array.
Press Esc to exit the RAID bios, then immediately turn off the computer.
Replace the hard drive with a new drive of equal or greater size, then restart the computer.
During the boot process, press F3 to enter the RAID bios.
Press F2 to create an array.
Press F2 to create a mirrored array.
Answer N for automatic setup. (No)
Enter the number of the source (good) drive.
Enter the number of the destination (new, blank) drive
Answer Y to copy from the source to the destination drive. (Yes)
Anser N to decline offline copy. (No)
Answer Y to enable auto rebuild. (Yes)
When asked Are you Sure? press Y to accept. (Yes)
Press Esc to exit the RAID bios and reboot the computer."

Note that you don't let the computer load the operating system after deleting the existing RAID array, until the new RAID array has been made.

In your case, you probably must make a RAID 0 array in order to be able to access your existing operating system data properly.

Rebuilding the RAID array may not apply to a RAID 0 array, I don't know.


The lowest designated level of RAID, level 0, is actually not a valid type of RAID. It was given the designation of level 0 because it fails to provide any level of redundancy for the data stored in the array. Thus, if one of the drives fails, all the data is damaged.

RAID 0 uses a method called striping. Striping takes a single chunk of data like a graphic image, and spreads that data across multiple drives. The advantage that striping has is in improved performance. Twice the amount of data can be written in a given time frame to the two drives compared to that same data being written to a single drive.

Below is an example of how data is written in a RAID 0 implementation. Each row in the chart represents a physical block on the drive and each column is the individual drive. The numbers in the table represent the data blocks. Duplicate numbers indicate a duplicated data block.
---------------Drive 1 Drive 2
Block 1-------- 1 ----- 2
Block 2-------- 3 ----- 4
Block 3-------- 5 ----- 6

Thus, if the 6 blocks of data above constitute a single data file, it can be read and written to the drive much faster than if it were on a single drive. Each drive working in parallel could read only 3 physical blocks while it would take a single drive twice as long because it has to read 6 physical blocks. The drawback of course is that if one drive fails, the data is no longer functional. All 6 data blocks are needed for the file, but only three are accessible.


* Increased storage performance
* No loss in data capacity


* No redundancy of data

Report •

Related Solutions

July 13, 2010 at 10:41:46
When dealing with SATA when it comes to windows XP, go into the BIOS and make sure that all the SATA ports are turned to compatibility/IDE mode. If not XP will hang, BSOD, or loop forever without the proper drivers installed.

Don't know if someone already pointed that out or not, the replys are WAY too long to read.

PowerMac 9600(1 ghz G4)
512mb RAM
50gb SCSI
ATi 9200 PCI

Report •

July 14, 2010 at 16:18:21
Tubesandwires: Thanks again for your response. I think you're on the right track. Other research I've done also says I have to rebuild the RAID array for the new SATA ports.

There are two utilities that load at startup and I'm wondering which I need to use to make the new array. One is the Silicon Image RAID utility (F4 at startup). Problem is, I get a "No device detected, Utility disabled!" message when I try to access it (even when the drives are on SATA1 and 2). I've updated my BIOS and SATARaid BIOS versions, but that hasn't fixed the problem.

The other is the MediaShield utility (F10 at startup). I can access this one, but the option to make a new array is grayed out. I can delete the existing array, but I don't want to do that until I'm sure it won't result in data loss.

Outlander: All SATA ports are enabled in BIOS, as is nVidia RAID function. Is there anything else I should adjust in BIOS?

Report •

July 14, 2010 at 22:53:51
Flashing the bios is NOT a fix-all !

You may have noticed that you are often told NOT to flash your bios unless you must, where bios updates are listed on the mboard model's downloads page, and often also in the mboard manual.

NEVER update your bios version, unless you find specific info for a bios update, (or for bios updates newer than the one on your mboard but older than the one you're flashing with, since the newer bios updates usually include all previous fixes), e.g. release notes on the same page where the bios updates are, that specifically says it will fix a problem you are having, or unless you need to update the bios to support a CPU your present bios does not support.
Flashing the bios is the riskiest thing you can do with a mboard ! The relatively primitive bios flash chip can only be flashed a small number of times, and the flash chip can even physically fail the FIRST time you attempt to flash the bios !
If the flash chip physically fails, your mboard cannot boot the next you attempt to boot after flashing, and forever after. The bios chip must be replaced with another one that has already been flashed beforehand. On most mboards these days, the bios chip is soldered into the mboard rather than being in a socket. The soldered in bios chip can be replaced by specialists, but you have to ship the mboard to them, wait for it to be shipped back, and it is often cheaper to buy a new mboard instead !

Those directions I quoted were for a Silicon Image chipset EIDE PCI card with RAID capability. Since SATA controllers became available, EIDE controllers are sometimes called PATA controllers.

Look at the manual for your Asus mboard model.
If you do not a drive controller card in a mboard slot, you have two drive controllers that have RAID capability built into the mboard.

One may be for an EIDE RAID capable drive controller, the other for a SATA RAID capable drive controller,

...or you may have two SATA RAID capable drive controllers and the main chipset EIDE controller has no RAID capabilty (in the latter case you would probably have more than 4 SATA headers available).

If a drive controller, EIDE or SATA, has RAID capability, it loads it's own line early in the boot sequence, and you can access the RAID utility for it at that point if you wish, within, say, 5 seconds - by pressing a stated key - if you don't press the stated key, the boot sequence continues.

You can't make a RAID array unless at least two hard drives are connected to the same RAID capable drive controller.

You DO NOT have to set up a RAID array for any RAID capable drive controller, but the option is there if you want to do that. If it's a SATA RAID capable drive controller, it's also capable of running SATA drives in SATA non-RAID mode.

(By the way, when you load SATA drivers, if you are given the option of either the drivers for a certain chipset without RAID support, and drivers for the same chipset WITH RAID support, if the chipset IS capable of RAID, load the drivers for the RAID capable chipset even if you don't want to use a RAID array - in my experience, the non RAID drivers will NOT work for a RAID capable chipset.)

"No device detected, Utility disabled!"

That indicates there is no hard drive connected to that Silicon Image RAID capable drive controller. In that case, it does NOT load the capability to load the RAID utility, because there is no need to.
The message is normal for that situation - you can ignore it.

E.g. if the Silicon Image RAID capable controller is EIDE and you have no EIDE hard drives connected to it, of course, no suitable hard drives will be found connected to it.

"The other is the MediaShield utility (F10 at startup). I can access this one,....."

That indicates there is at least one hard drive connected to that RAID capable drive controller.

" ....but the option to make a new array is grayed out. I can delete the existing array,...."

My guess is there's nothing wrong with that situation - it's grayed out because it's grayed out when an existing RAID array is detected.

"I can delete the existing array, but I don't want to do that until I'm sure it won't result in data loss."

As I have said, I don't know much about RAID arrays.
You need to do more research.

The directions I quoted don't directly describe what to do about your situation, but it seems the Rebuild procedure for when you have a RAID 1 array does not delete the operating system's data on the drive that's still okay.

Did you look in the Asus manual for your mboard to see what info it has about setting up a RAID array etc. ?
Did you look on the Asus web site for RAID info ?

"Outlander: All SATA ports are enabled in BIOS, as is nVidia RAID function. Is there anything else I should adjust in BIOS?"

You shouldn't need to adjust anything.
If the bios having the SATA controllers set to SATA mode worked fine before, Windows obviously has the drivers for the SATA controllers installed in the operating system. It sounds like you ARE able to access the first drive, but not the second one, I would guess because the metadata has the wrong drive connection info when the drives are connected to SATA 3 and 4.

Report •

Ask Question