Can't initialize disk - write protected. Data recovery help.

April 1, 2013 at 09:40:26
Specs: Windows 7, 2.6/4GB

I have a WD 2 TB external hard drive, which had a hidden partition created using TrueCrypt.

After using the drive for about 6 months, it suddenly stopped working one fine day.


- Can't see in My computer
- Can see in Disk Mgmt
- Unable to initialize disk, says: Write-protected.
- Unable to recover data using TestDisk, says: Partition: Read Error
- Tried a lot of other tools like PhotoRec - they see the uninitialized disk, show me the correct size 2199 TB, but just unable to recover anything from it.

I have done the basic steps of restarting my laptop, changing the USB cable etc..

Please help me as I have been trying to figure this out myself for the last 1 month now :( Please!

See More: Cant initialize disk - write protected. Data recovery help.

Report •

April 1, 2013 at 09:41:45
I forgot to mention that my external drive does not have a write switch to turn off.

I also tried the ThumbScrew registry change but nothing worked.

Running TestDisk again till I get someone to help me here. Its at 9% right now, looks like many more hours to go. will post the results here.

Report •

April 1, 2013 at 11:14:40
Did you look at this testdisk information?

Encryption is a risky business. Why did you have a hidden encrypted partition in the first place on an external hard drive?

You may or may not be able to recover the files depending on what you have previously done to that drive in the last month.

Report •

April 2, 2013 at 05:43:53
Hi OtheHill, first of all thanks for your response. I wasn't expecting this as soon as this.

I did look at the link you had pasted in your reply and it talks about using the TrueCrypt Rescue Disk which as you would imagine I do not have. I know I have made a total fool of myself by creating a hidden volume on my external hard drive. No excuses.

But you make mistakes so you can learn and never repeat them.

Can you suggest any way I may not have tried so that I can get some of the data back. The hidden volume should be around 200 gig, while the total consumed space would be around 500 gig.

I have seen some older posts where you have helped people out and I'm kind of hoping that you would help me out too.

Please :(

Report •

Related Solutions

April 2, 2013 at 07:21:30
Go to Computer> listing/s for the external drive> Hardware> highlight the drive or partition> properties> volumes> Populate.

Do you see two partitions listed? If so, repeat the highlight and populate for each and post the information garnered here.

Report •

April 2, 2013 at 10:10:52
This is what I see there

Disk: Disk 1
Type: Unknown
Status: Not Initialized
Partition Style: Not Applicable
Capacity: 2097150 MB
Unallocated Space: 0 MB
Reserved Space: 0 MB

Should I remove the drive from the device manager, restart my laptop and try attaching it again?

Report •

April 2, 2013 at 10:50:51
I don't think removing from device manager will help.

Try running Easeus Partition Recovery. Get it at the link below. Read ALL the help files. Keep in mind that you had more than one partition. I assume the format type was NTFS?

Do you know you encryption password?

How many partitions were on the drive? Do you know the sizes?

Report •

April 2, 2013 at 13:54:38
I know the encryption password and I know that I had just one partition, except the TrueCrypt hidden partition. Not really sure about the sizes, but the hidden one should be around 300 GB and the normal one should be around 500 GB.

Format was NTFS.

I'll run the Easeus tool and update the results here.

Report •

April 2, 2013 at 14:38:52
If the drive is 2TB and you had a 200GB partition and a 300GB partition then what about the other 1500GB? Was it unallocated?

Report •

April 3, 2013 at 01:11:33
Sorry the partition sizes that I gave you were actually the used space in each partition. They should be around 600 GB hidden and the rest around 1400 GB as the standard partition.

Also, I ran the Easeus Software and it does not find any partition information. So I am unable to recover it. Any suggestions please? I need to get my data back... :(

Report •

April 3, 2013 at 05:58:17
Accord to TrueCrypt there is no crack or backdoor password so any program trying to work with file recovery would not be successful I don't think.

That said, I would try booting to a live version of Linux. Puppy is small and can be run from a CDR. Linux may be able to read the drive. Get Puppy from the link below.

The partition needs to be initialized. I haven't found a method to initialize without formatting.

A quick format does not actually overwrite data, just changes the MBR on the disk.

So, while risky, I think your only recourse other than professional recovery is to format and then use file recovery software.

Once the drive is initiated Easeus or testdisk may be able to repair the partitions and you would be whole again. This assumes the disk is not defective.

Is the external under warranty?

Post the brand and full model of the external drive.

I think there are cloning programs that can clone that hard drive. You would need an exact duplicate of the hard drive itself, not necessarily the enclosure part. That would provide you with redundancy so anything tried now would not necessarily be the end of the line.

How much time, effort and cash you put into this is dependent on how important the files are.

I think you have now learned the importance of keeping at least two copies of any files you need to have.

You may also wish to run a drive fitness test on the external to see if it is damaged. Get the test from the manufacturers site.

Report •

April 4, 2013 at 11:41:52
First of all, thanks for trying this hard to solve this problem. Really appreciate it.

I'm not good at all with Linux, dont have a linux system and no idea about how to use puppy. But I'll read some docs and try to do it.

My drive is under warranty, its a Western Digital 2 TB drive. Model No. WDBABV0010BBK-PESN.

I'll run a drive fitness test as well. Though, I do not have enough cash to buy a duplicate drive for the cloning as you suggested.

Also, I'm unable to initialize (and format) the drive as it is "write-protected". I have done a lot of things to get around that error, but it doesn't initialize. Any help around that would be great.

If it comes out fine in the fitness test, I think somehow fixing the write protected error and then initializing and formatting the disk is the only option.

I will post the results of both the tests here. And thanks ever so much for trying to help me out here.... Thanks.

Report •

April 4, 2013 at 12:32:55
I did some more research on your issue. I originally thought your Write protect message was due to the truecrypt program. However, it seems as though many others with the same, or similar WD external drives have the same issue.

Look at the links below. I found these by Googling for "Initialize a write protected drive", without the quotes. The third link below is to WD support. I suggest you contact them with this issue.

Report •

April 9, 2013 at 05:26:30
What is your current status?

Report •

Ask Question