Can't get Iomega eGo RPHD-TG external HDD to work on laptop

February 18, 2013 at 15:54:24
Specs: Windows Vista, intel pentium dual cpu t2370 @ 1.73GHz RAM 2gb
I know this is tl;dr but I wanted to provide as much information as possible.

The gist: I can not get my external hard drive (iomega rphd-tg) to work on my windows vista laptop.

The back story: A friend gave me a hard drive which he had previously used on his apple computer. Right before he gave it to me, he connected it to his computer, opened the drive, and deleted the handful of old work files he had on there.

When I got home, I found my computer did not recognize the hard drive, but it was found in device manager. After doing some online research, I ended up reformatting the drive into the fat32 format via the fat32formatter utility. After many many hours, and at about 90% completion, I got an error saying it didn't work. I tested it, and sure enough, I couldn't access it.

The following day when I turned on my computer the drive was there and 298gb were free (even though this is supposed to be a 320gb HD). I accepted the 20gb loss and began using the hard drive.

After transferring a bunch of high quality avi files to the iomega, I began to test a few out. I found some of the video files were jumpy or sped up, while some were only a split second long. Further, I had the newly transferred files divided into 3 folders. The third one went completely missing! The following day I checked again and the third one was there but the other two weren't!

At this point I decided I should reformat the drive and start fresh. At first I tried using the format options windows provides, but they gave me errors and made my hard drive useless all over again. If I open "my computer" and check the properties of the the external drive it shows 0 bytes free 0 bytes used.

Ok, so now I decided to try to reformat again with the fat32formatter hoping there wouldn't be any errors. Well, it didn't even take a second before the same error messages I got after 90% formatting last time popped up again.

I am completely stumped and overwhelmed here. Whenever I have had technical issues in the past I have always been able to solve it through online research. I've finally cracked. This one is beyond me. Any help would be highly appreciated!

BTW I have two cable options. A USB to micro USB and a 4pin to 6pin firewire cable. The former is what I have been using since the latter hasn't even connected the HD to the laptop.

See More: Cant get Iomega eGo RPHD-TG external HDD to work on laptop

Report •

February 18, 2013 at 23:17:35
First off, you ought to know that the stated capacity of a hard drive is always higher than what you actually get. That's because drive makers use the decimal system which assumes that 1GB = 1000MB. The true ratio is 1GB = 1024MB

This means the true capacity of a 320GB drive is really 286GB.

You should test the drive to see if it really is faulty as it seems to be. Test it with SeaTools for Windows:

Report •

February 19, 2013 at 16:04:39
Phil22, thank you for responding and thanks for your suggestion.

I am aware of the 1gb = 1024mb ratio. Forgive me if I wasn't clear enough. On my friend's computer the external hdd had 320gb of space, where on my computer (after the failed conversion to fat32 somewhere around the 90% mark) it said it was 298gb. Since 298 is 93% of 320, I figured the error had made part of the drive unreadable. But I don't really know that much about hard drives so it was merely a guess.

Anyway, my drive failed the "short drive self test" in the SeaTools program (screenshot: However, in the SeaTools guide there is this screenshot ( that says:

"When testing internal drives and Short DST fails, consider running SeaTools for DOS. It has the ability to do sector repair. SeaTools for DOS does not support USB or other external drives at this time."

Since the hdd in question is external and I'm using a usb cable, clearly that won't work for me. Is there any other program that performs those tasks? Or is there a better way to proceed?

Thanks in advance.

Report •
Related Solutions

Ask Question