Can't figure out which component is bad

June 28, 2011 at 13:52:34
Specs: Windows 7 Home Premium 64-bit SP1, Intel i3-2100
I have built several desktop computers for family and friends, but this one is giving me a lot of problems. Here are the specs:

Biostar H67MH motherboard
Intel i3-2100
OCZ ModXStream Pro 500W PSU
Corsair XMS 4GB DDR3 1333 RAM
Seagate Barracuda 500GB 7200 RPM SATA 6.0Gb/s
Windows 7 Home Premium 64-bit SP1

So here is the situation. I put the computer together, installed windows, and plugged in a USB wireless adapter so I can do some updates. I restarted the computer and everything seemed to be working fine, so I left it on over night (nothing extra running on it). The next day, I look at the screen and it had a BSOD error, and it would not boot into windows. Windows would start to load but before it got to the welcome screen, it would always show another BSOD error. But the errors seemed to be random and was always a different message. I played around with it and finally got into windows. I saw on Biostar's website that there was a BIOS udpate, so I started to update the BIOS and then I got another BSOD error in the process. Now when you try to turn it on, it just beeps a couple times and nothing shows up on the screen.

I changed the jumper to reset the BIOS, but it didn't work as easily as I thought it should (never had to do it before so I thought I was doing something wrong. I eventually found a post that said to hold some keys down while powering on the system and it worked). When windows loaded, it was acting a little funny, so I decided to clear everything, and reinstall windows. This time, instead of using my USB wireless adapter, I hooked it up to the router with a cable. I reinstalled windows, did some updates, installed some other software, and just played around with it a bit. I put a video on to play repeatedly and it went 2 days without any problems. So I thought it was okay to give to a friend.

When they got it and tried to transfer their files over to the new computer, they started getting the BSOD error and they couldn't get it restarted. The only info I have is that it was a "1E" stop message ("STOP: 0x.....1E(....,...,...,...)").

At first I was thinking maybe it was bad RAM, because windows wouldn't load right, and I have read where that is always a good place to start. I ran memtestx86 and it didn't find any problems. I kind of feel like there may be something wrong with the motherboard.

Can someone help me figure this thing out? What does it sound like to you? Any help will be appreciated.

Note: I don't have extra parts to swap out and test. I usually just buy what is needed, when it's needed.

See More: Cant figure out which component is bad

Report •

June 28, 2011 at 15:08:44
Sounds like memory errors. Look at the tested memory list linked below and also download the memory test utility from the second link. Run the test from a the boot.

You didn't list any Graphics card.

Report •

June 28, 2011 at 16:00:29
Thanks for the reply. The list Biostar provides is just memory they specifically tested. There is no way they are going to be able to test every make and model of memory. It shouldn't be a compatibility problem. If there is a problem with memory, it would be a bad module.

As I mentioned, I ran memtest already and didn't get any problems. But I will run it again tonight and let it pass through several times.

I just got the computer back and set it all up, and when windows was trying to load, I got a new BSOD message "STOP: 0x...7f" and then the next line says "tcpip.sys". Does that still sound like a memory issue?

Report •

June 28, 2011 at 17:45:54

Report •

Related Solutions

June 28, 2011 at 18:19:24
Thanks again for the help. But I have googled and searched all over trying to figure out what needs to be done. Giving me links for basic stuff like this really isn't getting me anywhere. The reason I posted is because I have not found a solution through my own research. You cannot "fix" BSOD problems based on someone else's experience. That is why I'm asking for help on the forums.

I can't get the computer to boot at all right now. I'm running the memory test like you said and will post the results as soon as I can (probably tomorrow morning). If anyone has any other opinion or suggestion, please let me know. Thanks again.

Report •

June 28, 2011 at 21:23:24
That link deals with the error you posted. tcpip.sys.

Scroll down and look for threads that mention that.

Report •

June 29, 2011 at 07:30:52
Like I said already, I've been there done that. I'm getting so many different messages, I don't think it is a software issue, which is what that particular error usually ends up being.

I ran the memtest86+, again, last night and it never found any errors. Does that completely rule out a memory problem? Is that a pretty thorough test?

What would the next thing to test?

Also, I forgot you asked about the video card earlier. This mobo is an H67 so it has onboard video. I didn't add any extra card since this is going to be used for office work only.

Report •

June 29, 2011 at 08:24:07
You posted " I just got the computer back and set it all up, and when windows was trying to load, I got a new BSOD message "STOP: 0x...7f" and then the next line says "tcpip.sys". Does that still sound like a memory issue"?

I responded with a link that addressed that error.

One other point to note. Windows has had issues with SATA III hard drives in the past. Not saying this is a problem, necessarily but it may be. I have no personal experience using SATA III drives but I can think of some situations where settings could come into play.

Are you booting with minimal hardware connected? No add in cards or external hardware other than wired mouse & keyboard and monitor.

Can you set in the BIOS screens without the computer acting up? Have you checked all temperatures and voltages in the BIOS? Voltages should run within 5% of the base.

Reading some of the threads in the link about tcpip.sys it addresses the network. After all tcpip deals with the workings of your network adapter and your connections to the internet.

When you installed the motherboard drivers are you sure you used the 64 bit versions?

Report •

June 29, 2011 at 08:53:31
Well I'm not going to argue with you about your links. I've told you I have been there and done that. I have researched the specific errors I'm getting myself. I know what tcp/ip is and it doesn't make since why that would be a problem. There are so many different messages that I don't think it's software. But I don't have a clue at this point.

Yes I am booting with minimal hardware. The only thing plugged in is the monitor, keyboard and mouse. I can't understand why I got that message with tcpip.sys because it happened while windows was trying to load and there was no "network" activity going on. I didn't even have the ethernet cable plugged in.

I think your ignoring or not thinking about the entire problem here. The tcpip.sys message I got was just one message. I just posted that as an example. Every time I try to turn the computer on, I get a new message. Most of the time, it doesn't point out any extra information (it just gives the "STOP" message number).

I can go into BIOS, because the problem occurs when windows is trying to load. I never overclocked or changed any of the setting in BIOS. Like I said already, this is for an office worker, so there is no need to do that. However, I went in and clicked to "Restore Defaults" in the BIOS setup anyways.

As far as the drivers, there weren't any options when installing them from the disc. So I assume it did the right one (especially since it was working for several days before it started acting up).

That is what I don't understand. After I installed windows the second time, it worked for several days without any problems. So I gave it away and they immediately started having problems with it (the exact same problems I encountered the first time I tried to install windows).

This is my first post on the forums because most of the time, you can find a solution somewhere online. But I have yet to find any situation like this on Google. I really feel like it is a hardware problem but I don't know what. I'm not overly experienced with PC builds so I may be wrong.

Any other thoughts on what could be causing this? Should I just reinstall windows again, and hope that the 3rd times a charm?

Report •

June 29, 2011 at 11:11:13
I was simply responding to your question. If you don't want my help then that is fine. Just say so. If you accept my help, do so graciously. You obviously do not know what the problem is.

You stated that you had the system running for two days and then tried transferring files. I assume you used the network adapter for that task.

Windows 7 DVD probably doesn't have the correct drivers so will either supply none, or supply a generic driver.

First go to Device Manager and see if all hardware is working properly. Then download the correct drivers from the link below and install them. If Windows balks and says the best driver is already installed, try to over ride that message. The motherboard manufacturer is the best resource for the correct drivers.

I believe the graphics are part of your CPU, not the motherboard.

See the link below for details on your CPU and which graphics are included. You need to install the drivers for that Intel graphics and Windows 7 x64.

Report •

June 29, 2011 at 11:30:43
I'm grateful for your help, and thanks for walking me through it. You just aren't reading the post fully.

When they were trying to transfer their files over, they were using a flash/thumb drive. No networking, no external hard drives... nothing that should require going to a website and downloading a driver.

I know that the Windows DVD does not have the drivers for hardware other than generic ones. All motherboards come with DVD's with drivers and software. So, the first thing I do after installing windows is insert the mobo DVD and install all the drivers and software from that. When running that DVD and installing drivers, there is nothing that says x64 or x86. So I assume it installs the appropriate ones.

I can't get windows to boot; therefore, I can't get into device manager.

So let me do a brief summary:
I built the computer, installed windows, installed drivers and software from mobo dvd, did updates, let sit overnight, then I woke up to a blue screen. Had problems getting windows to boot and was given a different blue screen error every time. Finally got it booted, tried to update the BIOS, got a blue screen during process, had to reset CMOS with the jumper (which was quite a problem too). Finally got BIOS reset but windows was acting funny.

So I reformatted the hard drive and reinstalled windows, installed drivers and software from mobo dvd, did updates, left it on continuously playing a video and other daily task (browsing the internet, etc.) for a few days and never had a problem.

Gave the computer to friend, they plugged in flash drive, got a blue screen, now I can't get windows to boot at all. It always blue screens while windows is loading right before the welcome screen appears, and it is always a different STOP message too.

I have run memtest86+ and let it sit overnight and it hasn't found any errors.

I have to get this fixed. If you or anyone can help me I would greatly appreciate it.

Report •

June 29, 2011 at 13:25:48
With all the random error messages and quirky behavior, I'd send the mobo back and start again. Plugging in a usb device should not wipe windows, as you well know.

Report •

June 29, 2011 at 13:32:13
Thanks for the reply grasshopper. That is kind of what I felt, but I was wanting someone else's opinion on the matter. I'd hate to go through that process and then find out that there was a problem with something else.

But there really isn't an easy way to know for sure if it is the motherboard, is there? Thanks again.

Report •

June 29, 2011 at 13:46:54
I would say it's the board. When they plugged in the usb stick, that created a problem it shouldn't have. All the random errors seem to point to a confused board :)) If it's not the board, it's most likely a faulty psu, but why would that wipe the hard drive. I don't think the drive is wiped as much as it's just not recognized. Good Luck.

Report •

June 29, 2011 at 13:53:22
I am beginning to think the chip set drivers for the H67 chip set are the problem. I have been helping another user with poor performance issues on that same chip set.

Below is a link to a diagram of that chip set. As you can see, it is highly integrated. Basically all subsystems are on one chip except for the graphics which are integrated into the CPU, which in turn is controlled by the H67.

Therefore, it is extremely important that the latest chip set drivers are installed. Also the latest graphics drivers for the Intel 2000 GPU.

Some questions. Do you have the hard drive connected to one of the 2 SATA III ports? (you should). In the BIOS are you using ACHI or IDE settings for the hard drive?

In the end, Grasshopper may be right about the board. I would try a few more things before RMAing the board.

I have also come across lots of folks with graphics issues when using the i32100.

forgot the link

Report •

June 29, 2011 at 13:59:17
OtheHill makes some good points, but why would it work for a few days, then fizz. I would try his suggestions first, but I have my doubts.

Report •

June 29, 2011 at 20:19:15
You wrote that you tried to update the bios and then got a bsod. So I assume that you tried updating from within Windows ? Did the update go thru completely ?

Report •

June 29, 2011 at 21:03:19
I had an issue with "tcpip.sys" a while back causing blue screens not to your extent but just the same. It turns out it was caused by an MS update for my NIC driver. I never download updates for my hardware from MS but the wife noticed there were new updates and assumed coming from MS they would be good. When I was getting the BSOD's they were not always the same the tcpip.sys was just one I recognized so I worked out from there. I removed the drivers for my NIC went to the manufacturers site and got the right drivers and all has been well. It may not be your only issue at this point but it may be worth looking at. Try booting in safe mode does that allow you to boot? I don't think that had been covered yet.


Report •

June 30, 2011 at 07:44:11
Sorry for the late reply, I thought I posted one last night but I guess I didn't hit the right button to submit it.

@grasshopper: It recognizes the hard drive and its not like its "wiped". If the HDD was wiped then windows wouldn't even start to load. It blue screens right before the windows "Welcome" screen.

@OtheHill: Yes the HDD is connected to the SATA III port (the "1st" one if that would matter), I forgot to look at the ACHI/IDE setting last night. But I haven't changed anything from the defaults any BIOS, and I have even restored all BIOS settings to default too incase something did get changed.

@kx5m2g: When I was trying to update BIOS, it was through Windows, and no it did not go through completely. I was watching the progess, and it said it cleared the BIOS and then the next step (applying the update) was probably about 25% done when I got a BSOD. When I tried to restart it, the computer just beeped at me. I ended up resetting the BIOS/CMOS with the jumper.

I know you shouldn't try to update the BIOS unless something isn't right. But I was going through this problem I'm dealing with now, so I was hoping a BIOS update would have fixed it.

@likelystory: I haven't tried going into safe mode this time. The first time it was doing this, I did try and it wouldn't let me in either.

Last night after I get in late, I tried to turn the computer on and windows came on up; the first time that has happened since I got it back. However, when you try to click on "Computer" or a folder to launch windows explorer, I get a popup message saying "No such interface supported". So I can't navigate to any file. The software installed will launch without any problems though. That could probably be fixed pretty easy with the windows disc and doing a repair. But I still feel like it's a hardware problem and it would be a waste of time to go through all of that.

I'm just about ready to RMA the mobo anyway. OtheHill, you said there may be a few more things to try before RMAing. Let me know so I can get this sent back ASAP.

One more question: I used an OEM copy of windows and I read where that locks the key to the mobo. If I RMA the mobo, will I still be able to use that same disc? Or will I be okay as long as the mobo is the same model?

Thanks for all the help guys.

Report •

June 30, 2011 at 08:20:05
Unless I missed it, you didn't say anything about checking temperatures and voltages in the bios as suggested in response #7. Also, what psu are you using ?

Report •

June 30, 2011 at 09:09:04
Everything is set up as default. In the BIOS menu, if I remember correctly, most of everything has a setting either "auto" or "default". I can't give you the exact numbers or anything right now since I'm at work.

This doesn't sound like a PSU problem to me, but I may be wrong. The PSU is OCZ ModXStream Pro 500W. Rest of the specs are in original post. I have used this model or the bigger models for all of my builds, and I haven't ran into anything yet.

Report •

June 30, 2011 at 11:31:15
A PSU is just as likely to be defective as is a motherboard. All hardware is suspect.

As asked, have you tried booting into safe mode (F8 at start up)?

You also need to check the voltage on the RAM.

Heat sink could also be installed wrong, causing higher temperatures.

I suggested you verify you are using the latest drivers back in #14.

Report •

June 30, 2011 at 12:17:29
I feel like we are going around in circles here. Everything is getting power. It worked for days without anything going wrong. So that is why I was saying, "I don't think it is the PSU". But like I said, I haven't ruled it out though.

And like I said, I have not tried booting into safe mode this time. However, when it was doing this the first time, I tried and it did the same exact thing.

And like I said, the voltage on the RAM hasn't been changed from the defaults. Besides, considering THE ENTIRE topic and everything going on, RAM does not really make since to me. But since I don't have a clue where to go from here, I'm won't rule it out.

It's not a temperature issue for sure. The computer was shut off and unplugged for a full 24 hours before I got it back. The first time I plugged it up and tried to run it I got all the messages. So its not like its shutting down because it gets too hot. It will only run for about 15 seconds, and it would not get that hot in that short period of time.

And like I said multiple times, I can't get into the dang computer (or windows rather) to do anything with drivers.

I will look at the exact voltages tonight to put everyone's mind at ease. I'm going ahead and submitting an RMA for the mobo for now since I know it make take a day or 2 for it to go through. I will keep working through it and hopefully I can get it working before they asking me to send it back.

I'll post back later and if you have any other suggestions let me know.

Report •

June 30, 2011 at 13:02:20
You know, for someone that doesn't know what the problem is you sure know what it isn't.

If the heat sink is not installed correctly the CPU can over heat in less than 15 seconds. We are not saying that is the problem but you need to check everything. Same goes for the PSU. There are three rails with different voltages.

The proper method to troubleshoot is to eliminate the things that you can.

With that, you could try downloading a live version of Linux, like puppy. Install to a CDR and boot to it. Live versions do not install to hard drive. They run off the CDR.

That will absolutely tell you if the issue is hardware or software. If Linux runs OK then it is something in Windows. Probably drivers. If Linux doesn't want to run stable either, then there is most likely a hardware issue.

Report •

June 30, 2011 at 13:26:59
I also would not assume that because you reverted to the default settings in the bios, that those are the correct ones for the particular hardware that you are using. In particular you should check the SATA settings for the hard drive. Hopefully getting another board will solve the problem. I am still curious whether you could stay in the bios for any length of time without the computer shutting down.

Report •

July 1, 2011 at 07:40:07
@OtheHill: I've done my research, and I am simply stating what does and doesn't make since to me. The main reason all of my posts are so long, is because you keep asking me the same questions that I've already answered.

I looked at the voltage settings in the BIOS last night, and like I said it has "AUTO" selected and there is no way of knowing which one it uses. It's just a drop down list with auto, default, and a bunch of numbers. I also looked at the RAM in BIOS and it was saying 1.5v. So I would assume, the "AUTO" setting looks at that and runs it at 1.5v too.

And I left the computer in the BIOS menu for a few hours last night and didn't have a problem, to answer your other question.

I will download and try the Linux thing, but there are several people who have pointed to a faulty mobo (I've been on other forums with the same problem). Maybe if you would think things through a little bit and quit making me repeat myself, we may be a little further along and you can see that by now.

Report •

July 1, 2011 at 07:53:58
OtheHill is very knowledgeable and just trying to save you some steps. Since you've already installed the OS and it ran fine for a few days, then fizzed, I would still say it's the mobo. It is also possible it could be a faulty PSU. Without parts to swap, it's hard to say what it is. There's only one way to find out for sure. RMA them and start over.

Report •

July 1, 2011 at 09:14:19
I understand. And I didn't mean to be an a** about it. I was just saying with what I'm seeing, some things just don't make since, and most of everything points to the mobo, like you said grasshopper.

I got an email back today from Biostar, so I will send the mobo back and hope that fixes the problem.

Thanks again to grasshopper, OtheHill, and everyone else who posted.

Report •

July 1, 2011 at 10:08:27
Good Luck and let us know how you make out.

Report •

July 1, 2011 at 17:16:55
@OtheHill: I downloaded and tried using puppy linux and its not booting. When it is loading, it says "Loading drivers.... done" then the next line fails saying "lupu_525.sfs not found. Dropping out to initial-ramdisk console..." But that's when it stops. I burnt the iso to a disc, used it on my laptop, vmware on my laptop, and an hp desktop without any problems. I even went through the instructions to make a bootable flash drive and that didn't work either.

Does that make it sound like it could be something else other than the motherboard?

Report •

July 1, 2011 at 18:00:47
If puppy tries to boot but can't then you probably have a hardware problem. Before sending the board back I suggest you check the voltages and temps in the BIOS. Stay in the BIOS for at least ten minutes and check again.

Report •

Ask Question