Can't create partition on 160GB HDD

March 6, 2009 at 10:59:28
Specs: Windows XP SP2
I'm trying to install XP SP2 onto my new 160GB HDD. As it is new i tried to create partitions on it using XP setup but it won't make any!! I tried my WIN98 Bootable CD and tried using Fdisk to make partitions, but that won't work either. Can someone help me on this, I'd really appreciate that.

See More: Cant create partition on 160GB HDD

Report •

March 6, 2009 at 12:12:53
Tell more, is this a sata or ide drive, what errors are you getting.

Report •

March 6, 2009 at 12:22:34
use window vista dvd to partition and then install windows xpsp2
cause it is easy to partition in it.

Report •

March 6, 2009 at 12:24:12
The mboard bios must recognize the hard drive.
If it doesn't Setup cannot find the hard drive.

If your mboard is older than about 2001 or so, it's bios may not recognize the drive as it's proper size, or may not recognize it at all, keeping in mind the binary size the bios and Windows sees is always smaller than the decimal size hard drive manufacturers use. .

If it is an IDE drive, the drive must be jumpered correctly.
You don't mix cable select jumpering with master / slave jumpering for two drives on the same data cable.
The blue connector on one end of the 80 wire data cable must plug into the mboard.
Some drive models e.g. some Western Digital ones - have two ways they can be jumpered as Master - single, when by itself on a data cable, and with slave present - when there is another drive jumpered as slave on the same data cable - such a drive must be jumpered the right way .

If it is a SATA drive,
- a SATA-II drive may not be detected on a mboard that does not have SATA-II support unless a jumper can be installed on pins on the drive to force it to be seen by the mboard bios as a SATA drive.
- it must be connected to a SATA header that a drive connected to that header can be booted from. If this is a generic desktop computer, see the mboard manual.
- depending on settings in your mboard bios, Setup may not see the drive at all. What you can do about that depends on whether you have a laptop or a desktop computer . If the SATA controllers in the bios are set to IDE compatible mode or similar, Setup will find the drive in any case, if nothing else is wrong.
If you need help regarding that, we need to tell us the make and model of your mboard, or the make and model of your brand name system.

If the drive already has one or more partitions on it that take up the entire drive space, you can't make another partition until you have deleted at least one partition. If you have a brand name system, see below - you don't normally delete any partitions in that case.

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

If the hard drive is on a brand name system, and it already had the original software installtion on it, and you want to be able to re-install the original brand name software installation,
- if you delete the second smaller partition on the drive, or otherwise delete the data on it , you lose the ability to restore the original contents of the larger C partition with a single Recovery CD - you must use a Recovery CD set in that case to restore the original brand name software installation.
- DO NOT install Windows on the second partition when you have not deleted the contents of the first one that still has it's original brand name software installation - doing that will TRASH your original software installtion, you will have a dual boot situation, and neither copy of Windows will work properly, and the only way to recover from that is to use a Recovery CD set if want to recover the original brand name software installation.

Report •

Related Solutions

March 6, 2009 at 12:24:22

Most folks aren't going to have a Vista DVD laying around.

Report •

March 6, 2009 at 13:50:59
Thanks guys for your MB is a 965 chipset and i just bought a new 160GB SATA HDD with a IDE2SATA Adaptor ofcourse.. Idea is to have WIN XP [SP-2 i guess, not sure] installed to this new 160G HDD, but while set up i can't create any partitions. It gets to the page where it asks to create partitions but when i try to create a partition it goes back to the page where again it says the whole disk is unpartitioned. I've tried using fdisk from my WIN98 bootable CD but there again it says it has created a primary partition but when i reboot it, its not there, says whole disk is unpartitioned....Im done...i need help from you guys.....:(

Note: it is getting detected in the BIOS...Only thing is i can't partition it using neither the XP set-up nor the Fdisk utility

Report •

March 6, 2009 at 14:26:43
You don't need fdisk. WinXP CD can perform the partitioning.

Report •

March 6, 2009 at 15:33:00
PCI SATA drive controller cards are rock solid reliable. The same cannot be said for some IDE to SATA adapters, according to users reviews I've read on the newegg and the tigerdirect web sites. Some just plain don't work or don't work properly. Make sure it's fully seated, and that the SATA cable latches into it's sockets properly as I described above.

If the 160gb drive is SATA-II (capable of up to 300mb/sec data transfer speeds) are you SURE the adapter supports SATA-2?
Some of them DO NOT - if the drive has pins on which you can install a jumper to force it into SATA mode (150mb/sec max) you may have to install a jumper.
If that doesn't help, you probably bought yourself an lemon IDEtoSATA adapter.

If you get a PCI SATA drive controller card, DO NOT install in it (or any card but a PCI video card) in the last PCI slot closest to the center of the mboard - that slot shares it's IRQ with the video and that frequenly causesproblemswith any card except a PCI video card.

Report •

Ask Question