Can't burn DVD

April 11, 2010 at 23:35:41
Specs: Windows Vista
I can't burn dvd, it worked perfectly fine before, but suddenly it got error.
I tried to burn it with Nero, after about 3% , it said " Burn failed at 8x bla bla bla" then i tried to burn it with File Explorer it said "This drive is ini use. Do you want to format it now?" I click yes but the it said "Windows unable to complete the request" But I dont use the drive,it's a blank DVD anyway..
Anyone can help me?
I don't know the drive name, but my laptop is Toshiba Satellite L300-20D. Thank You

See More: Cant burn DVD

Report •

April 12, 2010 at 02:19:23
Un-install nero & try another burning soft

Report •

April 12, 2010 at 08:21:49
I had been finding that Nero was very gender or manufacturer specific. If you do not have plugged in and working a model on their private list, things may work OK once, but not everytime then.


Report •

April 12, 2010 at 09:46:48
i tried to use other software.. failed to burn..

Report •
Related Solutions

Ask Question