Can't boot bios on Dell/xp boots ok

Dell INSPIRON 6000
January 12, 2009 at 19:20:34
Specs: windows xp home edition sp3 , 2gb
I spilled about a table spoon of liquid on my Dell Inspiron 6000, immediately turned it off, removed the keyboard and cleaned it off, then put everything back together.

I used it for an hour afterwards, then a strange crackling noise came from the speakers. The noise would come on periodically so I turned it off.

When I restarted I got a blue screen saying "memory parity error". I restarted again the blue screen was gone, and it tells me a NIC adapter is having problems, and asks me to press (S) to shut it off. When I tried pressing 'S' it didn't respond (more like it froze), so I restarted again.

This time I can finally boot into windows. But now my 'new hardware found' wizard went berserk, and kept on telling me there is new hardware found, non-stop. I had a look at my Device Manager and noticed the following had exclamation marks on it:
-OHCI compliant IEEE 1394 host controller
-intel pro/wireless 2915abg network connection
-Ricoh R/RL/5c476(II) or compatible cardbus controller
-SDA standard compliant SD host controller

All of the above showed an error message saying "this device cannot find enough free resources that it can use".

At the time I realized:
-my soundcard was not working (+ the volume control speaker icon disappeared from task bar)
-I lost the wireless internet functionality (Intel PROSet unable to detect a wireless adapter, and also my wireless profile under Network Connections is gone)
-my SD card slots on the side of my laptop not working

I let it sit for a night and turned it on again the next day, and the soundcard magically seems to be working again, while the rest of those devices are still showing the same error message in Device Manager.

I tried booting into the BIOS by pressing F2 at startup, but it gives me a black screen. I tried pressing F12 for boot menu at startup, it takes me to the selection page, but when I touch any key on my keyboard it freezes. I thought I may have a faulty keyboard so I tried doing it from a USB external keyboard, however the results are the same.

So now I have a Dell laptop that can:
1) boot into windows with a few device not working
2) freezes when booting to bios or bootmenu

Where can I narrow down the problem? Is there something else I can try?

See More: Cant boot bios on Dell/xp boots ok

Report •

January 12, 2009 at 19:26:56
If you can get into Windows then see if you can get to Device Manager. If so, remove all devices with the exclamation marks and then reboot.

That procedure would work better from Safe Mode. However, from your post it doesn't sound like you can get to safe mode.

Report •

January 12, 2009 at 19:53:47
I would say you didn't do a good enough job cleaning up the spill. You probably should have used a blow dryer to help dry things out, then left the keyboard off to let things air dry overnite. What was the liquid?

Report •

January 12, 2009 at 20:01:30
If you can get into Windows then see if you can get to Device Manager. If so, remove all devices with the exclamation marks and then reboot. That procedure would work better from Safe Mode. However, from your post it doesn't sound like you can get to safe mode.

I can't do this in safe mode so I tried doing this from the normal windows xp mode. I removed all the devices with exclamation marks and rebooted to windows xp. When xp loads it reinstalls all the devices for me. with the same exclamation marks/errors.

Report •

Related Solutions

January 12, 2009 at 20:10:26
The spill was to the upper right side of the keyboard (above the backspace key and to the right of the F12 key) all the way to the edge of the laptop.

I did blow dry after cleaning it off. However, some of the devices with errors I mentioned is right on the edge of that side of the laptop: IEEE mini port, USB ports, SD card slots and headphone jack (= soundcard?). Among these only the USB ports and soundcard are working fine (however it was the soundcard which initially had problems). These do correspond to some of the errors shown in the device manager. I'm no expert in laptop architecture but does the wireless card does share a connection with some of these devices? I think the wireless adapter is also located under the upper right side of the keyboard. I don't think the spill went that far down, as everything was dry underneath the keyboard when I took it out, and it wasn't a heavy spill.

Report •

January 13, 2009 at 03:05:09
You still didn't mention what the liquid was. If a sugary liquid you may need to rinse as well as dry. I suggest you Google for how to clean up spills on a laptop.

I think dis-assembly may be needed. Hopefully the components aren't damaged. The fact that the BIOS and OS can still see the components is probably a good sign.

Report •

January 13, 2009 at 05:23:15
The liquid was a thick yogurt drink. It definitely had sugar content. I will look up the dis-assembly and cleaning instructions now.

Is there any reason why XP can boot up normally and see its components (even though with device errors), but the BIOS and bootmenu freezes when I try accessing it? What would stop the BIOS menu from loading while XP can function normally?

Report •

January 13, 2009 at 06:17:03
The BIOS starts to configure the hardware and normally hands it off to WinXP. If the hardware is non responsive then who knows?

You could try a live version of Linux to determine if the issue is with WinXP or the hardware.

Knoppix installs to and boots from ONE CDR. Get the first listing from the bottom of the list that is 696MB.

Report •

January 13, 2009 at 18:33:48
Yeah I agree with OtheHill that the laptop needs disassembly.

Liquid is one of the worst enemies a computer has.

WinSimple Software

Report •

Ask Question