Can't access data on USB stick

Microsoft Windows xp home sp2
December 12, 2009 at 09:20:05
Specs: Windows XP
USB mem stick seems to load, but when I click on E: I get, "insert cd into drive E:. Under Disk management, the size of the stick is there as wellas how much is used and free, but it says"unknown partition" and I can't access anything.
If I go to the command line I can't run chckdsk, and drive E: is unavailable. I can't choose another letter, but the letter isn't the problem. Any ideas how to get my data back?

See More: Cant access data on USB stick

Report •

December 12, 2009 at 12:11:25
Why can't you use another drive letter? Have you tried the flash drive in another USB port or on another computer?


Report •

December 12, 2009 at 12:18:00
Try recovery software or a version of Linux. Knoppix runs off one CDR.

One other option may be to use testdisk to fix the partition.

Below are some recovery programs.

PC Inspector (freeware)
Zero assumption Recovery
The demo is limited
It will only recover 'up to' four folders per run
But you can make multiple runs
IMO the best, but not free

Relying on a flash drive to archive files is risky. Of all types of media those are the least reliable.

Report •

December 12, 2009 at 12:34:18
The option isn't available to change drive letters, I've already tried that, adn I've tried about 7 different USB ports in various PCs asn laptops. It's as if the OS notices there is something there, but that's as far as it gets. So close and yet so far. I'll try the other options in the second reply and see if I get anywhere. All I need is to access it once and get the stuff off...

Report •

Related Solutions

December 12, 2009 at 13:00:29
The drive isn't being recognized. When I try to run any of the recovery programs, the drive doesn't show up as any option... I hope it isn't toast. If I could just get the OS to recognize it, then I could get to the data.

When I click on My Computer, open or explore, the drive shows up as removable, adn it has a drive leter, but when you click on it nothing happens, and it asks to 'Please insert a CD into drive E:"

Report •

December 12, 2009 at 13:30:34
Try testdisk to repair the partition.

Report •

Ask Question