Solved canon printer won't power on

July 18, 2014 at 12:45:26
Specs: Windows 7
All of a sudden my Canon MX410 printer will not power on. No lights, no sound, no action. I have plugged and unplugged from machine and wall and it has been plugged into a surge protector power bar...?? I am baffled as to why??

See More: canon printer wont power on

Report •

#1
July 18, 2014 at 14:43:26
✔ Best Answer
I assume you've tried different AC sockets and without using the surge protector? If it has a power adapter rather than a straight cord the problem may be with the adapter. If you wiggle its connection to the printer and it momentary powers up then the problem is there. Sometimes the wiring in the plug gets twisted around and breaks inside the insulation. Or the adapter may be dead. If you have a voltmeter you can check the voltage at the output plug and see if it shows anything.

If it's not the adapter or power connection in general it's got to be internal--maybe a fuse inside the printer. You can check to see if you have access to a fuse but most of the time they're not meant to be opened up by the consumer.


Report •

#2
July 18, 2014 at 15:57:21
Thank you so much for your advise. It turns out that it was indeed an adapter problem! I turned the printer over and secured and snugged up the connection of the adapter to the printer and the power came on. Thank you so much for pointing this out!! I am thrilled to be "back in business" :)
DAVEINCAPS you are awesome!! Thanks so much!! :)

Report •

#3
July 18, 2014 at 20:20:38
You're welcome. If the problem persists you may need to get a new adapter but I imagine it'll work OK as long as the connector is snug and the power cable isn't moved.

Report •
Related Solutions


Ask Question