canon mg7500 series pixma printing blank pages

Canon / Pixma
March 14, 2016 at 10:02:34
Specs: Windows 10, i7-5700 / 16gb
Prints fine if i "copy" something using only the printer lcd control panel., or print graph paper using only printer control panel... Scans okay too and lets me save pdf to my laptop... BUT printing wirelessly from laptop prints ONLY BLANK PAGES.. Same issue from two different laptops, a WIN7 and a WIN10. Printer wakes-up flips open front like normal, makes happy printer sounds like normal, then only spits out a blank page of paper.

Right-click on printer, General tab says it is named "Canon MG7500 series Printer", and that model number in "unavailable"... then on Hardware tab it says Type= "print queues" and that Location = "a root print gueue".

Device Mgr--> Printer-->canon... right-clicking on "update driver s/w" says "best driver s/w already installed.

in EVENTS i see this from last time I re-installed the printer.... Driver Management concluded the process to install driver mg7500p6.inf_amd64_f852888b57cf6641\mg7500p6.inf for Device Instance ID SWD\PRINTENUM\WSD-EB952735-2E71-48AB-A58C-26BDAEF0CC8C.003F with the following status: 0x0.

For the love of god, do not answer with "need to check print heads" or "are you using Canon ink?" because it prints out a copy of whats on the glass platen just fine.

See More: canon mg7500 series pixma printing blank pages

Report •

March 14, 2016 at 19:40:38
Has it always done this or did this behavior just start? Have you looked on Canon's website for firmware upgrades for the printer?

Report •

March 14, 2016 at 22:15:32
i have got a message on the printer lcd screen like, "there is a firmware update available on the server" so then I go (on lcd printer screen) to Settings - Device settings - Firmware Update, and ... "you have the latest firmware.

After posting my original message earlier today, I again briefly unplugged/replugged pixma and was soon able to print so it is an intermittant issue. It feels like the message " a firmware update is available on the server" is somehow holding up actual printing... until you relieve the message by running the official 'Firmware Update' process step that does nothing? Most puzzling, but to anyone with this issue I suggest these steps, 1) unplug modem, wait 1 min and plug back in, 2) unplug printer, 3) restart PC and wait for wi-fi to showup, 4) plug Pixma back in, 5) print something from laptop, being sure that printer exactly = "Canon MG7500 series Printer" with no other text like WS or (1) or whatever. If you have the firmware update available message on the lcd screen DO the steps, Settings - Device settings - Firmware Update FIRST before the unplugging.and restarting.

Report •

March 15, 2016 at 08:13:09
Do a printout of the configuration of the printer, then go to Canon's website and look at the firmware revision. Compare the firmware version on the config sheet with the version on their website.

Has this printer ever worked right or is this new behavior?

Report •

Related Solutions

March 15, 2016 at 09:42:32
Yes, it worked fine for months, then every so often I get the bank paper thing. Itis now 'fixed', at least until it starts printing blank pages again.

I like your idea of comparing to Canon website, but how exactly would someone "printout of the configuration of the printer" like screen prints of all the tabs in Printer properties? (uggg).

Report •

March 15, 2016 at 09:47:13
The next time it happens, I will be looking carefully to see if the lcd display has the 'firmware update available on the severer' message.... then I will again do the steps in #2 reply and document better.

Report •

March 15, 2016 at 12:21:43
There should be an option from the screen itself to print out configuration pages. It also might be listed under the printer properties in Windows.

Report •

March 15, 2016 at 12:30:32
Hey, I found this webpage which might be useful. It shows how to connect your smartphone to the printer and view the configuration. It also looks like you can check the firmware version.

Another good link

Hey, did you check your printheads? Sorry, I couldn't resist.

message edited by THX 1138

Report •

Ask Question