Canon ImageClass 4150 suddelny scans slowly

April 17, 2011 at 14:51:04
Specs: Windows XP
My Canon ImageClass 4150 printer/copier/fax/scanner has worked well in the several years I have owned it -- until very recently, when the scanner mysteriously slowed down. It has gone from scanning about 3 pages per minute to about 1 page per minute, and it now makes a loud noise while scanning. While scanning, it moves a page a few inches, stops, moves a few more inches, stops again, and so on.

What can be done to restore its normal scanning speed? I tried uninstalling and reinstalling the software, with no success.

Thank you.

See More: Canon ImageClass 4150 suddelny scans slowly

Report •

April 18, 2011 at 08:35:36
Your ImageClass 4150 requires a USB 2.0 connection that is working properly.
If you're having problems with that, scanning is probably the most noticeable thing that is likely to be slower.

Printers / multifunction Printer whatever devices often do not come with a USB cable.
Whatever USB cable you use must support USB 2.0 standards.

The USB port you plug it into must support USB 2.0 standards. The ImageClass 4150 will work when plugged into a USB port that supports USB 1.x standards too, but max data transfer speeds will be a lot slower.

If you have loaded or re-loaded Windows XP from scratch, Windows must have at least SP1 updates installed in it in order for it to support USB 2.0, AND you MUST install the main chipset drivers for the mboard after Setup has finished in order for the built in USB 2.0 support to be installed by Windows.

Plug the USB cable into a USB port that is built into the mboard for the greatest chance the USB 2.0 support will actually work properly - the ImageClass 4150 may not work as it should when it's plugged into an external USB hub, or into front case ports or ports in a plate on the back in a slot space on a desktop case.

It's possible in some bioses to disable the USB 2.0 support and leave just the USB 1.x support enabled. Bios defaults always enable the USB 2.0 support by default, if the mboard supports USB 2.0.

Report •
Related Solutions

Ask Question