cannot partition 2tb hard drive above 1tb

July 3, 2009 at 01:16:09
Specs: windows vista
I am having problems with my 2TB Western Digital Green Caviar hard drive. I install it and the computer sees it but when I try to format the whole thing it freezes at 54%. I have searched everywhere online, called technical support, took the hard drive back for a new one and even took it to Best Buy Geek Squad an no one could give me an answer. I did notice that if I created at partition of 1TB it would work and I could use it but it still won't let me format the other 1TB partition. Any ideas. Thanks.

See More: cannot partition 2tb hard drive above 1tb

Report •

July 3, 2009 at 15:44:09
Does the BIOS recognize it as 2TB?

WinSimple Software
CompTIA A+ Certified

Report •

July 4, 2009 at 12:12:34
I don't know much about the BIOS. I know how to get to it but once there how do I find out if it recognizes it as 2TB? And if it doesn't see it as 2TB then what would I have to do to fix it? Thanks.

Report •

July 4, 2009 at 12:47:34
Watch the POST screens at start up to see if the WD drive is properly identified by both model and FULL capacity.

If so, then download and use Data Lifeguard Tools to partition and format the hard drive. I recommend that you use a small partition for Windows. Maybe 30GB. Then make a second for your programs. The size of that one will defend on how many programs you need to install, maybe another 30GB. Additional partitions can be created to store various types of files.

Look at the first link below for ideas on partitioning. Look at the second to get Data Lifeguard Tools for DOS. Burn to CDR and then boot to the CD to use the tools.

Report •

Related Solutions

July 5, 2009 at 17:57:33
So I found where to look in the BIOS and it sees it as a 2000GB drive. I want to use it as a 3rd extra harddrive in my computer, not install windows on it. My main hard drive is 500GB, my second hard drive is 1TB and the third one is the 2TB I am having problems with. I tried using the Data Life Guard Tools but the CD that came with it wouldn't work on Vista and I couldn't find a Vista version on the site. I will try the DOS one. I don't know if this matters or not but when I tried to partition it the first time I chose Master Boot Record instead of the other one (GTS or GUID or something like that). I thought that maybe if I tried formating it in that way that it may work but I can't seem to get that option again when trying to format. Do you think trying the other formatting option would make a difference and if so how do I get to make that choice again? Thanks.

Report •

July 5, 2009 at 17:59:56
I suggest you use the Data Lifeguard Tools for DOS and not mess with the Vista tools at all.

Report •

July 6, 2009 at 10:48:41
I tried using the Data Lifeguard Tools for DOS and it keeps coming up with some error about some file not being found when I try to run it. I am booting my computer up from the CD and following all the instructions so I don't know what's wrong. Best Buy tried telling me that it is possible that the hard drives that they recieved all came from a bad batch which is why even though I've taken it back and tried multiple ones I am coming up with the same problem. Does that sound possible to you? Do you think I should just give up on trying to get the 2TB to work and just settle with another 1TB?

Report •

July 6, 2009 at 10:53:46
Can't answer your last question because you still haven't told us what is the make & model # of this PC.


Report •

July 6, 2009 at 11:58:57
Sorry about that. It is a Gateway desktop model number GT5656 with 32 bit Windows Vista Home Premium Service Pack 2 installed. Processor is an AMD Athlon 64 X2 Dual Core Processor 6000+ 3.00 GHz and 3.00GB of RAM. I just tried calling Western Digital customer support and they said that it is probably a limitation with my motherboard and that I needed to contact Gateway to find out if my motherboard can support 2TB hard drives. I tried calling up Gateway customer support and because my computer is 3 years old and out of warranty they can't give me that information unless I pay them for it. Is there a way that I can check out the kind of motherboard I have by myself and find out if it can or cannot handle 2TB hard drives? Thanks.

Report •

July 6, 2009 at 12:09:34


Report •

July 6, 2009 at 12:16:09
Is Data Lifeguard Tools starting when you boot the computer?

Is the 2TB drive connected?

Report •

July 6, 2009 at 20:05:39
Thanks XPUser. I looked at the specs and it says its an ECS MCP61P-AM Motherboard. But when I physically look at the motherboard I see MCP61PM-AM REV:1.0A. Do you think it's a typo that on Gateway it says just 61P and on my motherboard it says 61PM or are those 2 different motherboards. Also what I see on the motherboard is HT2000. I tried searching online using those model numbers (I'm assuming their model numbers) and I couldn't find anything on the hard drive limit for it. Maybe I was just wasn't looking in the right place. If someone can find out for me with the information that I just gave I would really appreciate it. Thanks.

Report •

July 9, 2009 at 13:22:52
Can anyone help me figure this out with the specs I just gave above? I've been searching online but I can't find anything that says hard drive capacity limit for a motherboard.

Report •

July 9, 2009 at 13:40:29
"Do you think it's a typo that on Gateway it says just 61P and on my motherboard it says 61PM or are those 2 different motherboards."

No typo, just Gateway not knowing exactly what motherboard revision they'd be using when the machines were built. There's always a time lag between publishing specs and actual production runs of their machines.

What is the exact error message you get when trying to run Data Lifeguard Tools?

"I've been searching online but I can't find anything that says hard drive capacity limit for a motherboard."

You already did.

"So I found where to look in the BIOS and it sees it as a 2000GB drive."

The motherboard does, in fact, see the 2Tb drive.

Again, what is the exact error message you get when trying to run Data Lifeguard Tools?


Report •

July 16, 2009 at 09:12:01
Hello Clutz450

I am also having the same problem. I bought 2x 2TB WD 20EADS internal Hard Drives, and couldn't get windows to format them. I tried with one being MBR, the other GUID. Didn't make a difference, but the GUID was totally unrecognisable. The format failed just over 50% on the MBR drive. I thought this was a problem with the disks, so returned them and got 2 new replacements.

I got the replacements, and the same problem was happening. I raised the issue with WD help and they have indicated that this isn't a problem with the drives, but with Windows not recognising the drive, ie a ceiling on the capacity. I tried in XP (32), Vista (32 and 64), on a total of 3 different PCs, all with the same outcome - failure.

I was able to partition the drive as 1TB, but windows failed to format the remaining space.

Since then, WD said that I should use their data lifeguard tool. I tried the version for windows but it had the same problems and when running the test reported a cable problem - note, there was no cable problem.

In the end I used the DOS version (, which booted up fine and the tests I ran were good. I then wrote zeros to the drive (took 6.5 hours!!), believing that this would 'format' it and windows should now be able to see it. The write zeros worked, and I rebooted in windows, the disk management tool saw the drive as RAW. Upon initialising the disk, windows STILL WANTED TO FORMAT THE DRIVE. Initially I didn't say yes, but it wouldn't let me access it, so I said yes, and it once more failed to format - same error as earlier.

My conclusion is that the drives are not faulty, and that windows need additional "something" to be able to see large volumes.

So I'm stuck atm, going to look up some articles on Microsoft's website.

Any help appreciated!


Report •

July 16, 2009 at 11:58:33
Hi again,

I've been investigating the motherboard issue raised in a previous post and believe that the model I am using is causing the issues.

I installed the hard drive into another machine (note - the 3 other machines all had same model motherboards).

Upon installation, I initiated the drive and created a new simple volume and formatted it. It worked first time! I tried again with the second disk and it worked as well.

I then installed the 2 drives onto my original PC and as they had now been formatted, they were detected and worked as you would expect. Done under Vista 32 but have no reason to think they won't work under xp or v64.

I recommend this as a workaround if your motherboard doesn't support this sized drive.

I'm currently in the process of filling it to ensure the entire size can be fully utilised.

Hope this helps others.


Report •

July 16, 2009 at 15:56:16
If the full capacity is seen in the POST screens at start up then there is nothing wrong with the motherboard.

Report •

July 17, 2009 at 06:51:26
The full capacity was seen during POST.

Report •

July 17, 2009 at 08:36:36
Then the motherboard is OK.

If you can't get Data Life Guard Tools to work from the boot then contact Western Digital for further help.

Report •

July 27, 2009 at 19:10:02
Sorry I haven't posted in a while. Been busy with other things and havn't really had time to mess with my hard drive. I tried what chris1234 said about formating it in another computer then putting it back into the other computer. I tried that and it worked. It sees the whole drive. It's going to take me a while to fill up the whole drive to see if it will actually read and write the full 2TB though but hopefully everything will be ok. Thanks.

Report •

August 18, 2009 at 12:52:52
See the forum posts, especially the last few posts, at the HP PC gaming/Voodoo Forum:

Also, see the Seagate recommendation to update your SATA controller driver, at this URL:

I struggled for weeks with this problem, trying to get a 2TB hard drive working with my 32-bit Vista PC. I finally solved it by following the instructions at the first URL, above, and updated my Nvidia nForce SATA driver. This is apparently only available from Nvidia, not through the routine MS software and driver update service.

Now I can create a nominal 2TB partition and easily format it, and it also passes chkdsk/f/r testing (in a command prompt window, under Vista). It also now fully passes my HP-supplied PC Doctor hardware tests. Before I updated my nForce SATA driver, I couldn't do any of these things.

Beware of using a standalone disk partitioning utility instead of updating your drivers. I tried this and although it did create a nominal 2TB partition and formatted it, when I tried to use it the hard drive behaved erratically and failed both the above-described tests. Now I'm comfortable using it normally since it passes all the end user tests I can do.

I hope this helps. I was greatly relieved to find such a simple solution and relieved that it does not involve some problem with Vista.

Report •

August 18, 2009 at 13:10:55

Your suggestion doesn't work if the hard drive in question is the primary drive that will have the OS installed on it.

The folks that made the drive are in the best position to have a utility to partition their drives.

Report •

Ask Question