Bios won't load after reset.

January 21, 2013 at 17:07:17
Specs: N/A, Intel Core i3-2310M dual-core / 4GB
I am working on my HP ProBook 4430s Base Model laptop. I replaced the cmos battery with a new one and after putting the laptop back together, I powered it on and it said "Cmos check-sum is invalid" (something else about restarting to configure) and asked me to hit enter to reboot. I hit enter. After it restart, I try to go into the bios and it takes me to system diagnostics. I even tried entering into other bios options (boot device option, system info, etc..) with the same results. The only thing I can go into, other than system diagnostics, is HP SpareKey Recovery (which I do not need). My hard drive is blank, so no os is installed.

Things I have tried:
hard reset
cmos reset
installed another new cmos battery
multiple diagnostics (hardware is working)
checked for over-heating (found none)
bios update with a cd and usb stick (won't load neither)

P.S. I can remove the cmos battery (tried all 3) and reinstall it only to get the same results all over again.

See More: Bios wont load after reset.

Report •

January 21, 2013 at 17:38:29
The only way to get rid of a Cmos check-sum is invalid is to re-write the CMOS memory which recreates a brand new checksum which was lost when you removed the battery.

When you re-boot look closely at the first screen and it should give yoo a key or key to enter BIOS. Dont wait and allow it to to system diagnostic which it will do if it cannot find anything to boot from.

You need to bee looking for a Save Configuration option.


Report •

January 21, 2013 at 18:02:14
When I push F10 (my key to enter bios) it automatically takes me to System Diagnostics.

Update: I got into bios through the startup menu (pressing esc key). I set my bios up and clicked on "Save and Exit" (no "Save Configuration" option in my bios). Upon reboot, I tried to enter bios again (just to be sure) and it takes me to system diagnostics again.

Report •

January 22, 2013 at 02:51:25
Save and Exit should have solved the CMOS Checksum Error

Have you lost the CMOS Checksum Error?

That is probably the way it is designed. As you got the Save and Exit option you were in the BIOS. Most OEM computer have very limited options.

Try putting a bootable disk in the CD/DVD drive and see if it boots from that.

It is probably going to System Diagnostics because there is nothing to boot from and the machine had nowhere else to go.


Report •
Related Solutions

Ask Question