bios update presario F712NR

September 21, 2011 at 23:24:58
Specs: Windows Vista Ult 64 bit, AMD 64 Athlon X2
Hi, please excuse my french on MS-Win, but I am being honest...

I have big problem with the internal wireless Broadcom switch staying "off" or "RED", no matter what I do, it stays in that state.
Received the laptop with WinVistaCrapHomePremium, CD-Boot with Ubuntu, nada, stays red...
Tried to look after bootup in Setup BIOS, by pressing F10, barely any changes to make AND no setting for BIOS or Wireless, or testing memory, except for what version of BIOS is installed.
I upgrade to Windows 7 UltCRAP64, same thing....
Changed wireless chip to Intel and Atheros, result--> no change.
Checked the wires connectors, everything.
Last resort, start g00gl1ng....

Some sites mention bad motherboard, HP won't agree. Some sites say, upgrade to F.1F, and I quote: "WORKS LIKE A CHARM!!"
Sure!! OK...

I have the previous version, F.1C, just checked it again.
Started g00gl1ng again....

Found the link after a while, an "ftp" link to a softpaq from HP, but guess what?? They removed the file...."INCREDIBLE"!!!! Why do they do this??????

Tried starting from the sofpaq ftp folder, clicked on pub, found the link again, clicked on it...nada.
Downgrade to XP, worse!!

Here I am, re-installing WinVistaUltCrap64, hoping to eventually find the Bios ROM upgrade F1.F or something.

Can someone please do me a great favor and give me the link to download?
Perhaps that will make the wireless work, I hope.

If it is really bad motherboard, I feel obligated to tell the owner to purchase an external USB wireless, bla, bla, bla....

Well, hope to hear soon from ya, thanks in advance.


See More: bios update presario F712NR

Report •

September 22, 2011 at 00:04:12
This is the bios download page for that model:

It only listed one bios download--version F.20--and it's there so I don't know where you're trying to find it.

Report •

September 22, 2011 at 00:27:59
Hi DAVEINCAPS, are you screaming at me?

Tell you what, I already downloaded that file when I had Win7UltCRAP64 installed, and got a blue screen, Gates favorite channel...
Then, I tried it with WinXPCRAP, and it would not even execute it.

Here is a copy of the listing:
root@century-ltsp:/home/hector/Downloads# ls -l sp480*
-rw-r--r-- 1 hector hector 2689128 Sep 23 03:10 sp48036(2).exe
-rw-r--r-- 1 hector hector 2689128 Sep 14 04:20 sp48036.exe

But, now that I did a clean install of WinVistaUltCRAP64, you are right, the bios version is F.20, thanks, appreciate it very much. I have now the latest BIOS version installed.

The bad news is, still no wireless, still RED light, still OFF, still NO DEVICE IN DEVICE MANAGER......

Now, DAVEINCAPS, got any suggestions?
Thanks in advance, I know you will find the answer for me.


Report •

September 22, 2011 at 00:40:36
My only guess on that would be a driver issue. But I'd think it'd be OK if it was original hardware and you did a restore. But check in device manager (or whatever the equivalent might be in Vista) and see if it shows any problems.

Report •

Related Solutions

September 22, 2011 at 03:42:01
Download AIDA64 and check the GPU temp. Many hp laptops with nvidia GPU have overheating issues(HP fault), when GPU start to overheat the first component to go bad is wireless card then the proble become worse(random bsod and sometime no picture on screen).

We can not fight new wars with old weapons, let he who desires peace prepare for war - PROPHET.

Report •

Ask Question