BIOS update has caused CMOS Checksum Bad

American megatrends inc. / Ms-7350
August 10, 2011 at 00:49:20
Specs: Windows 7 Home Premium x64 (build 7600), 2.4 ghz Intel Core 2 Quad Q6600 processor with 4 gig of ram
Hi all. I recently formatted my computer running windows xp and bought windows 7 to upgrade it. When I upgraded the computer it was getting very high CPU spikes without me running hardly anything at all and so I decided to update my bios but now when my computer starts up it says Press F1 to run SETUP or F2 to load default values and continue. When I go into setup it takes me to the blue BIOS screen and F2 starts the computer. Incidently the computer still has the high CPU spikes so the flash hasn't really done the job I wanted it to do so I'm pretty stuck now.

My board details pre the update we're as follows:

MS-7350 1.0, Bus Clock: 267 megahertz, BIOS: American Megatrends Inc. V2.3 07/12/2007.

My new update is V2.6 07/29/2008 with all else being the same.

My computer has a 2.4 ghz Intel Core 2 Quad Q6600 processor with 4 gig of ram and I'm running a 64 bit win 7.

Can anybody help with this? I have spent so much time trying to get it right but not getting anywhere fast so any tips or suggestions would be greatly welcomed.

See More: BIOS update has caused CMOS Checksum Bad

Report •

August 10, 2011 at 01:15:28
You need to enter the BIOS, set the settings to your requirement and then save those settings. If you have done this and the settings are not being retained then it may be that your battery is dead.

Or it may be that you need to clear the CMOS (your motherboard manual should tell you how to do this - normally there is a jumper that you short for a few seconds) and then reapply the settings.

Report •

August 10, 2011 at 02:13:29
high CPU spikes without me running hardly anything at all and so I decided to update my BIOS

One thing you should never do with a computer is update the BIOS just on the off chance it might fix whatever the problem is - it is a recipe for disaster.

BIOS updates are something that should only be done when necessary to fix a particular problem that is known about. If the manufactures information does not say it will fix your particular problem. then dont do it.

The basic principle is that when you have problem the BIOS is the very last thing you look at, it is a last resort when all else has failed, only just behind the CPU in the order of things that might be broke. . The BIOS does not stop working for no apparent reason and that reason is usually an hardware upgrade


Report •

August 10, 2011 at 04:10:36
Thanks for your replies. I have gone into the BIOS and tried to save some changes (like boot from CD as priority 1 but when I save the changes it doesn't take them.

Stuart I spent ages trying to find the problem and I updated the bios as a last resort. Unfortunately it hasn't worked and now if I want to put my old bios back I can't because I can't boot from the CD.

Since I can't boot from my CD on startup now I tried to do it in windows (with the new bios update) and it's telling me that the version of AFUDOS.EXE is not compatible with the version of windows I am running. It says 'check your computers system information to see whether you need a x86(32 bit) or x64 (64 bit) version of the program, and then contact the software publisher.'

I have contacted my motherboard company to see if there is a BIOS update compatible with Windows 7 so fingers crossed i get something back that will solve the problem. I'll keep you informed.

Report •

Related Solutions

August 10, 2011 at 05:46:30
BIOS updates should NOT be performed from within the Windows environment unless absolutely necessary.

I believe the MS-7350 is the P6N SLI Platinum. Would that be correct? If it is, it seems like you're using the wrong BIOS.

Report •

August 10, 2011 at 05:56:18
If you can boot into Windows and it runs OK I doubt that you have the wrong BIOS file installed. More likely that you are using a USB keyboard or the CD you are trying to boot to is not made correctly.

You have not stated what your issues are that made you resort to flashing the BIOS but if you haven't installed the available drivers from MicroStar I suggest you do so. The link to them is below.

Report •

August 10, 2011 at 15:17:16
"so I decided to update my bios "

Why don't you decide to put the previous version back on?

You still don't get it though. Your bios update will only affect those issues stated in the errata for that revision. No where in the errata does it state this bios update addressed cpu spikes.

1/3 of highway deaths are caused by drunks. The rest are by people who can't drive any better than a drunk.

Report •

August 10, 2011 at 18:45:25
It makes NO SENSE AT ALL to flash the bios if the bios version worked fine previously with the same hardware !
That does not include problems caused by you installing incompatible ram or changing which ram you have installed, which is another subject.
If the bios version worked fine previously with the same hardware, usually the only time you legitimately may need to flash the bios to a newer version is if you installed a cpu the bios doesn't recognize properly !

When you have flashed the bios, you ALWAYS get a Cmos Checksum Error or similar message after that when you boot the computer.
You MUST go into the bios after you have flashed the bios and set at least the current Date and Time, Save settings, because those have been set to bios defaults.
You get the same message and have to do the same things after you have removed the Cmos battery and then re-installed it, or after you have moved a jumper on the mboard to clear the Cmos, then moved it back, with a desktop mboard. Doing those things sets the Time and Date to bios defaults too.

When you have changed the bios version, you should ALSO load bios defaults (or remove and re-install the Cmos battery, or move a jumper on the mboard to the clear Cmos position, move it back) , because usually flashing the bios does NOT clear the previous contents of the Cmos part of the bios and your changed bios version will probably not work properly until you have loaded bios defaults.

"when I save the changes it doesn't take them."

If you removed the cmos battery,
- usually it must be installed so the the + marking shows on the top (horizontal battery socket) or the side (vertical battery socket) when it's installed .
- make sure the battery socket contact that touches the battery on the + side is touching the battery - if it isn't, the easiest way to fix that is remove the battery, bend the contact farther than it needs to be, install the battery.

If it's installed backwards, or if the contact on the + side is not touching it, the bios behaves as if it's dead or not there.

If that doesn't help, the cmos battery is probably too weak or dead - replace it.

If you moved a jumper on the mboard to clear the cmos, you must move it back to it's original position.

If you're not sure about either of those things, see the manual or the info for your mboard !

"the version of AFUDOS.exe is not compatible "

AFUDOS.EXE is the flash utility for flashing the bios !
If you use it in Windows, it must be the correct version - 32 bit (a.k.a. x86) or 64 bit - whatever your operating system is.
If you use it on a bootable Dos floppy or CD, usually it must be the 32 bit (a.k.a. x86) version.

The version of AFUDOS.EXE must also be compatible with using it with the bios flash chip model the mboard has, and the bios update.
In some cases, the flash utility version changes for newer bios updates for the same mboard model.

"I have contacted my motherboard company to see if there is a BIOS update compatible with Windows 7 ..."

Bios versions are NOT operating system specific.

Report •

August 10, 2011 at 19:46:43
High CPU spikes can only be caused by software. It cannot be caused by hardware.
Check again you used the correct BIOS for your board model AND version.
Clear CMOS with jumper and THEN reset BIOS to defaults.

To solve the high CPU spike you have to find the problem by systematically eliminate all possible software issues:
Scan the computer with Malwarebytes.
Run msconfig and go to start tab. Uncheck all except Microsoft and your antivirus program. OK and then restart the machine.
Uninstall any programs you do not use.
Install Process Explorer from Microsoft and see exactly what processes are using how much CPU%. Run Process Explorer with nothing else running. If you were very careful you can achieve 90-95% system idle on a mfg. built system and 98-100% system idle on a custom built system. If you get spikes from antivirus program, wait them out and check again when it is finished. Hover pointer over name of process for more information. Google the names of any that are apparent problems and see what results you get to see if it is something you can remove or deactivate.
Finally some antivirus programs are known to be system hogs like Norton and McAfee, if you have one of these uninstall it and use Avast instead (free version).

You have to be a little bit crazy to keep you from going insane.

Report •

August 10, 2011 at 20:42:31
I searched the MSI web site with MS-7350

Two models found.


Manual - English -

Therefore P6N SLI a.k.a. MS-7350 version 1.1

Bios versions 2.x series

P6N SLI Platinum

Manual - English -

Therefore - P6N SLI Platinum a.k.a. MS-7350 version 1.0

Bios versions 1.x series

Did you use the correct 1.x series bios update version for mboard version 1.0 ?
Are you sure you have mboard version 1.0 ?
The mboard version is usually printed on the mboard beside the model number on MSI mboards, although in some cases for MSI mboards the version number is the same there for different versions in the same series, e.g. 1.x, and the difference is one of the main chipset chips is different (a newer or older revision of the chip).

The bios updates for the version 1.1 mboard ( Bios versions 2.x series) cannot be sucessfully used with the version 1.0 mboard (Bios versions 1.x series), and visa versa !

Report •

Ask Question