BIOS shows both RAMs, but Windows don't

February 21, 2011 at 10:12:54
Specs: Windows XP
I have Pentium4 ar 3.2 GHz, motherboard ASRock 775VM8 with two DDR DIMM slots.
I had 1 GB of RAM. Decided to put another one 1 GB of RAM. BIOS shows them both, but in Windows System Properties there is text: 1 GB of RAM. What is the problem. Help!
Thanks

See More: BIOS shows both RAMs, but Windows dont

Report •

#1
February 21, 2011 at 11:08:34
See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:
http://www.computing.net/hardware/w...
.......

If that doesn't help....

The ram modules must be compatible with using them in your mboard.

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT all the way with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard's main chipset, or in the case of recent mboards, compatible with the memory controller built into the cpu.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
http://www.computing.net/hardware/w...
Correction to that:
Mushkin www.mushkin.com

Once you know which module ID strings (part numbers) work in your mboard, you can get them from anywhere you like that has ram with those ID strings.

If you have brand name ram, it is usually easy to look up whether it's ID string (part number) is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.
.....

When you have more than one ram module installed, all the ram modules must be compatible with being used with each other present.

E.g. the Crucial web site says for your mboard model:

Each memory slot can hold DDR PC2700, DDR PC3200 with a maximum of 1GB per slot.

If the new module, or the original module, or both modules are PC3200, they are available with several different voltages specified for them in the SPD chip on the module that the bios reads to determine ram settings.

If you have a mix of different modules
- don't mix ram that different voltages are specified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram that a higher voltage is specified for is more likely to not work properly in that situation.

You MAY be able to custom set the ram voltage to the higher ram voltage in the bios if you do NOT have the bios set to detect the ram "by SPD" or similar, however, you must NOT exceed the max voltage range for the modules that require a lower voltage, and that can be hard to determine, unless you can find detailed specs - e.g. if the ram is Kingston ram that doesn't have a brand name system specific part number, that info is easily found.


Also.....

Some ram manufacturer's modules do not strictly adhere to the JEDEC standards that most mboards bioses use to determine ram settings.
In that case, the ram settings in the bios Setup that the bios has automatically chosen may not be correct.
Check the ram settings in your bios - the ram voltage, and the ram timing numbers - those should be the same as for the specs for the modules themselves. Often the ram voltage and timing numbers are printed on the label on the modules.

If the voltage setting or timings settings in the bios are different from the specs for the ram, change them in the bios. The timing numbers must be as close as you can get to the same, or slower timings (higher numbers = slower) - you won't notice the difference the slower settings make.

If you have a mix of different modules
- don't mix ram that different voltages are specified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram that a higher voltage is specified for is more likely to not work properly in that situation.
- the bios settings must be those for the slowest timing settings of all the modules, or slower (higher numbers = slower).


Report •
Related Solutions


Ask Question