Solved BIOS Problems with MSI 970A-G43

Custom / N/A
January 25, 2014 at 20:48:03
Specs: Windows 8.1 64 Bit, AMD FX-8350 8 Core @ 4.0 GHz w/ 2x4 DDR3-1600
Hey Everyone,

Just tried to go into the BIOS menu for the first time, and I'm having some issues. First off, I'm running BIOS Version E7693AMS V10.3. Anyway, when I loaded the BIOS by holding F11 when the computer started up, it brought me to a completely unreadable menu. Based on comparing my screen to images in the user manual, all it is displaying is the top left hand corner of the screen. All that is accessible is a menu that tells me about the amount of RAM installed, the BIOS version, and a few other things. It also displays the CPU temp and half of the current time. While navigating the few menus I could get to, the screen glitched out on several occasions, partially displaying the current menu, and the first menu. Does anyone know how I might be able to recalibrate the screen or something?


See More: BIOS Problems with MSI 970A-G43

Report •

January 25, 2014 at 21:35:00
✔ Best Answer
F11 is supposed to be the boot order menu. The DEL key gets you to bios setup. What happens when you use that one?

message edited by DAVEINCAPS

Report •

January 26, 2014 at 06:58:46
Yeah, just tried it, no luck. Brings up the same menu as pressing F11.

EDIT: Actually, pressing F11 gives me the option to boot off of the HDD or go into BIOS, whereas DEL takes me straight to BIOS.

message edited by NT56erbx

Report •

January 26, 2014 at 07:33:44
Also, do you know how to use the Screen Capture? The BIOS menu actually lets you take a picture and save it to a USB drive, but I can't figure out how to upload the picture. Whenever I click Add a Screen Capture and Begin Process, it just says Loading Screen Recorder... and never does anything.

Report •

Related Solutions

January 26, 2014 at 20:10:19
But the screen it displays is too large to fit your monitor? Do the arrow keys work to move it around? You might want to try a different monitor. Or check the manual to see if there's a way to toggle the screen size. Might be a problem with the video adapter. Are you using a video card or does the motherboard have on-board video?

I don't know anything about the screen capture. Is it seeing the USB drive OK? With older motherboards you had to enable legacy USB support in bios. It doesn't seem like yours should be that way but you can check it out.

Report •

January 27, 2014 at 13:24:53
I had actually tried it on two different monitors before posting, with the same results. I just tried it on my TV and it worked fine... I guess I'll just have to move my computer downstairs every time I want to access BIOS.

I looked through the manual, and there wasn't anything in it about changing the screen size. I'm using a Radeon 7870 graphics chip.

Thanks for the help!

Report •

January 27, 2014 at 19:48:29
That's an odd one. You've tried several monitors and they're all the same. Were you using the same data cable for all of them? That's the only other thing I can think of.

Report •

January 28, 2014 at 09:31:32
One was HDMI and one was DVI-I to VGA (used a converter). The one that ended up working was also HDMI.

Report •

January 28, 2014 at 17:49:34
Maybe it's a problem with the converter. You might need to look into different cables if there's a connection problem with the monitors.

Report •

Ask Question