bios not detecting cdrom correctly

Microsoft / Proffessional, service pa...
April 5, 2009 at 10:23:52
Specs: Windows XP , amd opteron dual core x2/2 GB
My cdrom is sometimes detected in bios, not always, and when it is detected i list it with weird spelling like _JEC DRD[RS JD)3150A instead of NEC DVD RW ND-3550A

And it doesn't work either, it hangs my computer if I attempt to read or write anything.

What could be wrong?

Many Thanks

See More: bios not detecting cdrom correctly

Report •

April 5, 2009 at 10:50:27
The motherboard is having a problem communicating with the drive (dropping bits). Try reseating the cable at both ends.

Report •

April 5, 2009 at 11:06:49
I checked the cables today before posting this, they are not lose.

But do you actually think that reseating them might help?

Report •

April 5, 2009 at 11:55:48
Yes, they do not have to be loose to have a poor connection. It can be caused by oxidation on a contact. It's certainly worth a try. The other (but less likely) alternatives would be a problem with the cable itself or circuitry in the drive.

Report •

Related Solutions

April 5, 2009 at 11:57:52
Many thanks, I will try reseating the cables and see if it helps.

Report •

April 5, 2009 at 15:07:03
Also, you may actually have a bad ribbon cable. Try a different cable if reseating it doesn't help.

John W. Borelli
IT Specialist

Report •

April 6, 2009 at 08:16:36
Thanks John, will try that too.
I don't dare to touch anything right now, want to finish off a deadline first. Figure I will do all of this during easter.

I don't know, but could uninstalling the ide controllers in device manager help? I haven't tried that. I guess though that they do not have anything to do with the bios though?

Report •

April 6, 2009 at 09:08:21
Uninstalling the driver is not going to help. This is not a bios problem either.

It's just one bit that is sometimes failing to get through between the drive and the motherboard controller.

Report •

April 10, 2009 at 05:59:49
Well, the problem persist after all, after all the steps below. Now I am really clueless as to what to do next. I am starting to suspect that I may have a virus of some sort, disabling my cdrom. If it is a virus, could it be hiding in my mbr or bios? and thus disabling the cdrom?

Hi guys,

I thought I would give you an update on what have happened since your helpful assistance. I hope the report might give other help or hints if they find themselves having a similar problem.

I tried the steps in the following order:

I tried reseating the cables at both ends. That didn't work

I plugged in another working drive, same problem.

I replaced the cable with a new one, that didn't work either.

Then I tried another ide slot on the motherboard and that seems to have worked. I am not totally sure though that everything is working properly. Windows did not detect the drive automatically at startup, I had to go to "add hardware" inorder to get windows to detect it. Also, at one startup, I couldn't see it in the boot sequence. It shows up in device manager with the correct lettering now and not with some weird spelling like before.

However, in windows, when I click the cdrom drive without a cd in it, it doesn't alert me that there isn't a cd in the drive, which make me suspicious that something isn't right after all, since that was one of the symptoms with the problem I had before.

Best Regards

Report •

Ask Question