BIOS Menu doesn't show up (Boot Menu Or Setup)

Benq laptop / R43
June 15, 2013 at 15:26:41
Specs: Windows 7, Dual core/ 2Gb Ram
Hi I have a BenQ Joybook R43 laptop , my windows is corrupted and can't start for some reason , but now i tried to reinstall my windows i putted the Windows XP CD Installation disk into my DVD Drive and then i waited till i see the boot logo (BenQ blablabla ) it told me to press F9 For boot menu or F2 To setup , i tried clicking both of them and it didn't send me to a boot menu or anything it just acts like i didn't press the keys and yes the keyboard is working and i tried doing the same with different USB keyboards ,. any ideas how to reach the boot menu so i can choose CD or USB or what the fuk i can ?

New Update , The booting is set default to hard disk which have corrupted windows that can't boot up .

New Update , Some times it takes more than 10 minutes to boot up to the Windows XP loading boot screen before it automatically restart of course and some times it takes 10 seconds to boot up to the boot screen idk why .

The screen flicker a lot before i can see the boot screen (that's for the 10 minutes one )

See More: BIOS Menu doesnt show up (Boot Menu Or Setup)

June 15, 2013 at 15:50:33
The boot menu key should work if the keyboard is OK, in old machines USB keyboard only work in OS environment. Change the boot order in BIOS (1.dvd drive 2.hdd etc).

You know the real meaning of peace only if you have been through the war.

Report •

June 15, 2013 at 16:05:16
There is the problem i pressed the key F2 or F9 that showed up , but it didn't send me to the BIOS Menu It just completely ignored me and went booting like default from HDD

the keyboard is working fine both keyboards laptop keyboard and the external one.

but it's just not sending me to the boot menu or the setup even if i press the key from my laptop .

P.S : There is no PS/2 plug in my laptop so i think it supports USB .

Report •

June 15, 2013 at 22:18:08
I guess you know this from the manual:

"To select a boot device manually, press the <F9> key when the
BenQ logo appears on the screen during system startup. The
Boot Menu will appear. Use the up and down arrow keys to select a boot device, and then press <Enter> to confirm"

If it's going ahead and booting into windows it likely means you pressed the key too late. Start tapping it as soon as you turn it on.

To have a USB keyboard work during bios setup you need to previously have 'legacy USB support' enabled in 'advanced configuration' from the main bios menu (F2 during BenQ logo).

Here's a downnload for the manual if you don't have it:

Copy and paste.

Report •

Related Solutions

June 16, 2013 at 04:36:01
guys i swear i press the F2 Or F9 keys i spam pressing them after i press the power button .

But it doesn't let me go to the BIOS menu or boot menu if you don't believe me i will record it for you .

Report •

June 16, 2013 at 08:42:04
This sounds like a hardware problem. If you are using windows xp no doubt your hard disk is very old. You will usually need to replace your hard disk. When you do go into the bios and boot from cd. Windows will load perfectly. I tried this on a sony vaio laptop and it worked fine. However one time i tried to boot from the cd and the cd had scratches on it.
I tried a local laptop repair company in central London called ninatec and they installed windows vista. They upgraded my ram and made it faster. I would recommend you do this too as windows xp is a bit outdated. Try to do it ourself just make sure you have a good disk to boot from. Hope this helps.

Report •

June 16, 2013 at 12:53:46
Yeah, the hard drive may be bad but that shouldn't be the reason it's not going into setup. As I mentioned above, the USB keyboard won't work for that unless legacy support was previously enabled so you need to be using the laptop's keyboard.

Another thing you can try is to temporarily disconnect the hard drive. Then it can't boot into windows and you should then be able to go into setup.

Report •

June 16, 2013 at 16:06:00
none of replacing the hard drive or anything above worked, i sent it to a computer shop which told me he had to replace the BIOS as it was corrupted .-.

Report •

June 16, 2013 at 18:18:08
Thanks for posting back. We hope they get it fixed for you.

Report •

Ask Question