BIOS listed 40GB hdd as 6GB

May 9, 2010 at 04:06:41
Specs: Windows 7
I have a 40gig hard drive that was working fine. I
booted up today and it had problems. Further
investigation show that the bios is only reporting
it as 6gig now. Anybody any ideas?

See More: BIOS listed 40GB hdd as 6GB

Report •

May 9, 2010 at 06:56:28
How about some additional specs on your rig?

Is this a laptop?

Are you running Windows 7?

This would indicate a fairly modern computer. Modern computers are capable of configuring 40GB and larger drives. Therefore, I would guess that either some settings in the BIOS have been manually configured or the drive or supporting hardware are damaged.

All the above assumes no physical changes were made inside the computer.

Is this drive a solid state drive?

Report •

May 9, 2010 at 07:07:57
Sorry yeah,

Additional details..

Windows 7 64bit
Athlon x2 245

Has been working fine for weeks. Shut down yesterday and
booted up today and it asked to format it. Declined and
investigated. Thats when I noticed in the bios. I have updated
the bios no joy. The system has a 500gb disk in and that is
fine. Admittedly this is just an old drive to store unimportant
stuff and what not, it is just surprising that it has gone down
to 5.9gb. I have tested it in another machine that is running
win7 32bit and it is the same. If the problem is with the drive I
dont understand. I was thinking drives either work or they
dont. it isn't the 8.4 or 137gb issue so why has it gone to 5.9?
Various different FDISKs detect it as that as well. Weird.

This isnt solid state it is just an old Seagate ata100 drive

Report •

May 9, 2010 at 08:30:14
If the mboard detects a 500gb drive fine, your mboard bios does NOT have (a) drive size limitatation bug(s), and it detects drive sizes larger than 137gb fine.

However, the bios Setup must be set for the controller connection the old drive is connected to, to detect the drive properly.
E.g. Auto detect, by the method Auto or LBA.
If that's set to something else, the bios could detect the size of the old drive incorrectly.

If there's nothing wrong with that setting, a 40gb drive is relatively old, and the drive is probably in the early stages of failing.

Check your hard drive with the manufacturer's diagnostics.
See the latter part of response 1 in this:

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibility, on another computer if you need to.

In this case, use Seagate's SeaTools, the long test, to test the drive.

If the hard drive itself tests okay, any data problems found can be fixed, one way or another.

Report •

Related Solutions

May 9, 2010 at 09:47:14
If I understand you correctly, you have tested that drive in another system and got the same results?

If so, then the drive has broken. There are multiple read/write heads and multiple platters in modern hard drives. So it is possible to have a drive partially fail. In your case the PCB (printed circuit board) might be the problem.

I agree that running a drive fitness test will tell you more.

One question for you. Did that drive have multiple partitions on it?

If you have another IDE cable try swapping that out.

Report •

May 9, 2010 at 10:00:43
Yes I have tested in a different system and got the same

There was only one partition on it. I tried a different cable and
it has gone into another machine in place of a working drive
so I think I can rule the cable out.

It's an old drive that was sat in the bottom of a drawer
somewhere. I only installed for some spare space to keep
unimportant stuff on...downloads - zip contents etc.

I wasn't aware that they could partially fail. I thought it would
be an on or off kinda thing but like you say some of the heads
or platters have probably gone.

Thank you all for your replies

Report •

May 9, 2010 at 10:07:26
I had an IBM Deskstar 60GB drive that did something similar. In that case each time I tried to run a repair on it the size decreased. I RMAed the drive and was sent a "reconditioned" piece of junk that ran only a few months.

Report •

May 9, 2010 at 10:42:15
Go to the Disk management and see what it says for the drive.
Right click 'My Computer' > Manage > Storage > Disk Management.

Just for kicks, try chkdsk /r

The three most important things in computing:
1. Backups, 2. Backups and 3. Backups.

Report •

Ask Question