Solved Bad DVD drive?

October 18, 2011 at 13:59:34
Specs: Ubuntu 10.04 + WinXP SP2
After a long time during which I hadn't used it at all, I discovered that my DVD drive doesn't burn CD-Rs anymore, or at least not correctly.

1) In Ubuntu, it does recognize the blank CDs, but after I click on "Burn" in Brasero to burn an image disc it spins and spins for a couple of minutes and then tells me there has been an error while burning. The CD is ejected untouched. If I try the "simulate" option, it simply lasts much less, and the outcome is the same. If I try to drag and burn any file (not image), it's the same.

Still, when I tried to burn a DVD, it worked (almost) fine! In the end I got a writing error message again, but the job was done, the DVD usable: a couple of videos and a pdf file were readable. Only the last file, a subtitle file, was corrupt and wouldn't open.

I suppose this means at least that the laser is functional.

2) I checked out in Windows XP (I have a Windows partition on the same laptop). Here too, the system reads CDs and DVDs, but I cannot burn an image disc at all. Unlike in Ubuntu, if I drag a file it WILL be burned... with an "unknown error" message in the end. The disc looks actually burned, however it is not readable (it appears empty to the system) and also not writable anymore. In Windows I didn't try with a DVD yet. I uninstalled and reinstalled the drive (Device Manager), with no improvement.

I tried a different make of blank CD-Rs, but the result is the same. I cleaned the laser lens with cotton and alcohol - nothing.

I must add that, when reading, the drive seems to work slowly. It takes a rather long time to access the files on a disc.

Laptop: HP Compaq 6720s
Drive model: HL-DT-ST DVDRAM GSA-T20L
Firmware version: NC08

See More: Bad DVD drive?

Report •

October 18, 2011 at 14:10:47
Have you cleaned the lens?

MOOOOooove! OH and you're welcome!

Report •

October 18, 2011 at 14:26:50
Unfortunately, yes.

Report •

October 19, 2011 at 08:01:48
✔ Best Answer
Normally, when an optical drive is acting this way, it's either bad media - the disk(s) themself(ves), or a hardware issue. Sounds like you've troubleshooted the media issue, which leaves hardware. Speaking as a technician, optical ROM disks are pretty inexpensive and aren't really worth a lot of troubleshooting time. When they act this way, we may try a flaky ROM drive in another PC to see if works, if not, toss & replace it.

MOOOOooove! OH and you're welcome!

Report •
Related Solutions

Ask Question