Solved BackupNow EZ - software won't start

July 15, 2011 at 10:12:19
Specs: Windows Vista, 2.00 GHz / 4 GB
I have the BackupNow EZ software that came with Toshiba Canvio external HD. For many months, I was able to start the software to manage backups. Now, when I try to launch it, I can see the EXE running in Task Manager, but the UI never pops on screen. Just sits there consuming RAM and CPU cycles.

I have a Dell Studio laptop running Windows Vista Home Premium. Anyone else have this issue?

See More: BackupNow EZ - software wont start

July 15, 2011 at 11:10:22
Problems like yours are COMMON.

Troubleshooting USB device problems including for flash drives, external drives, memory cards.
See Response 1:

Check ALL of the that out first, including it's info at the links. .

If the USB port and the USB cable connection(s) you're using ARE capable of allowing the external drive enclosure and the hard drive inside of it to be recognized properly....

If you have not dropped the drive or otherwise damaged it, your problem was probably caused by you NOT clicking on the Safely Remove Hardware icon in your Taskbar and STOPping accessing the drive BEFORE you unplugged the drive while Windows was running.
See response 2:

There are several programs that you could try that will probably fix your problem.

Specifically, links to some programs that can repair the data damage are here -
see response 2:

That post also has info about testing the external enclosure's hard drive. Apparently, the Windows version of Seagate's SeaTools can test any hard drive brand when it's in an external enclosure.(The bootable Dos version of it CANNOT.)
Do the long test.

129 file recovery programs with ratings:

Report •

July 17, 2011 at 10:32:03
Thank you. It most likely is due to hot unplug of the external drive. I stopped it, unplugged, then plugged it back in and the drive is recognized - can see the files on the HD. Just can't get the backup software running to restore it.

Any suggestions?

Report •

July 17, 2011 at 19:43:46
✔ Best Answer
If you have damaged data on the Canvio external HD by unplugging it while Windows was running without STOPping accessing it first , there is no way of knowing which data has been damaged.
In that case, unplugging it and plugging it in again does not fix the data damage that was done.

You could try un-installing and re-installing the backup software but I suspect that won't help.

I tried looking on the Toshiba US site in the Support for hard drives but all I get is "
Oops! This link appears broken.DNS error occurred. Server cannot be found."

I found info on the Toshiba UK site that seems to indicate the NTI Backup Now EZ software is installed on your internal hard drive, not on the external hard drive.

You could try going to Control Panel - display set to Classic view - Programs and Features, Un-installing the Backup Now EZ software, and installing it again by downloading and installing the latest version of it found at the first link here:
How to make a backup and restore by using the "NTI Backup Now EZ" software?

If that doesn't help, you need to repair the data damage on the external hard drive by using a data recovery program .
OR - you could delete the data on the external hard drive and make a brand new backup.

NTI, makers of the Backup Now EZ software

General FAQs

Backup Now FAQs

Report •

Related Solutions

July 18, 2011 at 08:03:27
Thank you for researching this for me; I really appreciate your help! I ended up deleting the data on the backup drive and setting up a new backup/schedule. (It was truly just a backup, not data I had archived off my internal HD, so I didn't mind losing the files.)

And I will forever STOP the device before pulling the plug. Good lesson.

Thanks again!

Report •

July 18, 2011 at 19:16:31
We're glad to hear you soved your problem.

Thanks for the Thanks.

Report •

Ask Question