Asus Transformer T100CHI Nightmare What should I do with it

March 14, 2019 at 01:42:39
Specs: Windows 10, 4GB
I bought this Asus Transformer T100CHI (Windows10) and one month after the warranty ended I had a major issue. It won't charge and the screen is damaged. TLDR*

First of all though, right away, I had this issue where once in a while I would go to use it and the screen was unresponsive to touch. I would work around this by plugging in a mouse clicking on anything and boom the screen would register touch again. This was super annoying and I had hoped it would go away with a Windows/Driver/System update but it never did.

The second issue I came across was the inability to use any other usb charger other than the one and a half foot charger that came with the tablet. Doing so would result in the message "Current Low Unable to Charge". This was just an absurd design, slightly less than a completely proprietary charger but still ridiculous.

Those annoyances aside, the major issue that finally put the nail in the coffin turned me away from ASUS completely. One day, one month after the warranty ended, I plug the tablet in to charge, I notice the charge light come on and I walk away. An hour later I come back and the light is off. Now, I know it was really close to dead so the fact that it fully charged in one hour was puzzling. I unplug it and plug it back in and no charge light. Ok I say and I try to turn it on and nothing. I tried holding down the Windows button and the Power, I tried pushing the Power button many times, nothing. I tried doing what some called a 24 hour trickle charge by connecting it to a computer USB.

At this point I don't understand what is going on I can only assume something has failed internally. I turn to the internet and find website after website, thread after thread, post after post of Asus Transformer Tabs with failing or faulty batteries. Some had a quick fix where you just disconnect the battery from the MB and plug it back in (I guess some have a trigger where if the Tab senses a power surge in the charger it disables power to the battery). Now, to my surprise, I realize that this model I bought is a fully sealed system (Previous tablets/phones I have owned I could easily open and repair). I am thinking I should contact ASUS before messing with it any further since going internal meant possible damage.

Given the fact that my previous tablets/phones lasted years before failing or not at all and I had just bought the Tab not too long ago I decide to check the warranty status. I find out that it was just a month past the one year warranty. After reading all those faulty battery stories, how close the warranty had expired and the good business I had done with another company (LG fully replaced my LG G4 almost 2 years after the warranty expired because the phone had a manufacture default that caused the phone to corrupt the OS and not boot afterwards) I was confident that ASUS was willing to work with me. I was so incredibly wrong...

I contacted ASUS support via their Support Forums and I was told that they would not allow any leeway when it came to my warranty expiring despite the claim of a faulty battery flaw. After providing them with links to all of my sources showing that there was a flaw they stated that they would be willing to do the repair for $280-320 since it was out of warranty. After telling them how absurd that sounded given the fact that I paid $260 brand new with a warranty, they responded with something even more ridiculous. They tell me that it would actually, after repair, shipping and reshipping cost $395, I shake my head in disbelief.

I have a mint condition product that may just need a battery replaced or could just be swapped out with a similar used Tab they have laying around and this company just told me that one month after my warranty expired they can fix my Tab for almost two times the cost of a brand new one with a warranty?

I put this Tab in a dark corner and chose to ignore the existence of tablets all together. One year later I decided to bust the crap out of the digitizer to try the battery disconnect work around and nothing. Still no charge, no power, just a $260 POCrap.

TLDR*
Do I just put this thing in the trash and act like it and ASUS never Existed? Is there a way to test if it is just the battery? Is there any part of it that can be utilized in another form? Should I regain hope in Tablets and purchase another one?

These are from the same thread:
https://ibb.co/3hq8gwD
https://ibb.co/93XfS9m

message edited by ToolPunk


See More: Asus Transformer T100CHI Nightmare What should I do with it

Report •

#1
March 14, 2019 at 02:50:48
Hi Tool, pity you are not in the UK.

Here many Manufactures and / or Sellers offer a one year Guarantee,
forgetting that by Law it can be two Years or more.

Being aware of this has helped many Users in trouble.

Good Luck - Keep us posted.


Report •

#2
March 14, 2019 at 05:21:27
If you can locate head office - especially the CEO type(s), and write to them about the issue you might get some redress. Often works...

Start by saying how you have always regarded Asus as a reliable brand name, and have had some of their products in the past. But if their current response to your problem is now the norm then remind them that, neither will you continue to buy/use Asus products, nor recommend them.

Remind them of the once mighty Pan Am. which s no more. It became so large - and evolved into such appalling customer service (I speak from some experience of that), in effect became very arrogant and so on, that customers simply voted with their feet. Thus Pan Am as was - is no more... Is Asus seeking to emulate Pan Am?

Address it the top (wo)man in person; mark it personal and confidential. Likely it will be opened by his/her PA nonetheless, but it will get to him/her. It will then be either ignored - in which case you know what to do in the future re' Asus brand - ignore/abandon it! Or, (s)he will instigate action to resolve the situation to your satisfaction.

Be polite, rather than arrogant, abusive; but do indicate clearly your total dissatisfaction with their product and reliability at this time. Reminding them of course that in the past Asus was brand name you could rely one (well sort of...)


Report •

#3
March 14, 2019 at 08:54:53
Hi Tool,

trvir's advice is good, but keep your letter short (not overly long) but comprehensive.
Not like your first post in this Thread..

Is this yours?
https://www.youtube.com/watch?v=IBo...

Good Luck - Keep us posted.

message edited by Mike Newcomb


Report •

Related Solutions

#4
March 15, 2019 at 01:29:26
@trvlr
That is exactly how I handled myself when dealing with their customer support. Since I had actually previously owned an ASUS Android tablet that is still working today after 8 years. That is also why I could not believe the response I was receiving from them. I was being treated like someone who stole some 10 year old tablet off someone and was trying to pull a fast one over them to get a free tablet. Apparently between the first ASUS Tab and this W10 Tab, their Devices and customer service must have went down the shoots.

@Mike Newcomb
That ASUS T100 is the version that is easily repairable as I noted above. The T100Chi I purchased ended up being a sealed system leading to having to break the screen to do the battery test.

https://www.youtube.com/watch?v=7zW...

message edited by ToolPunk


Report •

#5
March 15, 2019 at 23:32:20
**Update**

Since I had to break the screen anyway to check the "unplug the battery and plug it back in" trick, I decided to try something else to rule out the battery. I clipped the wires to the battery harness, attached them to a fully charged 3 volt battery pack and plugged the charging cable in. At first nothing happened but after I connected the 3 volt battery pack a second time to my surprise the Orange charging light came on. When I pushed the power button the light just flashed and the Tab did not turn on. I am assuming since the Tab's pack is 3.8 volts there is a wattage/voltage difference so the Tab couldn't turn on.

Next, I figured, connect the Tab's pack back and if I get nothing like before then it's safe to say it's probably the battery pack. To my surprise again, the light came on! My next thought was to just leave it alone on the charger for a day or two and see what happens. Today the white Fully Charged light is on and the Tab booted up with no issue!

So my theory is this, the Tab's battery pack dropped so low something did trigger whatever these other people are talking about. The battery was so low though, the main board did not register the fact that I unplugged it and that I plugged it back in. So when I used the other battery pack, it did register and flipped the "OK To Charge" back on.

Well now to order a Digitizer and fix my Tab for $28 vs ASUS claim it would cost $395!

message edited by ToolPunk


Report •

#6
March 16, 2019 at 04:41:48
Well done... If I read your information correctly, it would seem that Asus deliberately made it a sealed unti to ensure that only their techies can “legally” service it. Especially as Asus had told you they could - but for a rip off price?

Equally it seems the unit is almost designed to fail (as you describe) at some stage, thus forcing the user to dump/replace it; or pay huge service/repair bill?

And tak for the update.

Incidentally what is the digitiser you refer to? The battery of course is obvious, but the digitiser and how it relates to the problem?

message edited by trvlr


Report •

#7
April 23, 2019 at 23:57:34
@trvlr
All you have stated based on what I have said is to be true. They built it as a closed system and I had to break away the Glass Digitizer to get to the screws to open the unit. The screws are hidden behind the glass digitizer, which they UV glued to the LCD mounting bezel. If you are not careful you can damage your LCD so be careful. At first I thought they just glued the Digitizer to the Mounting frame but is it literally glued to the entire LCD. I am currently slowly working the glass digitizer off with applied heat. After removing the digitizer you can remove the LCD bezel frame screws and lift off the frame and LCD screen. There you find the battery and MoBo.

Report •

Ask Question