ASUS P5N-D Disk Boot Failure

January 18, 2011 at 14:11:35
Specs: Win7 x64, intel quadcore/4GB DDR2
Recently I installed a new hard drive and OS. Things were working peachy keen for about a month, but now all of a sudden I'm getting a DISK BOOT FAILURE error whenever I try to start up.

In total, I have a 500GB external, 150GB internal, and (this is the new addition) a 1TB main OS drive. On previous systems, I used to get these errors constantly, and I usually resolved them by 1.) changing the boot order in the BIOS 2.) switching SATA positions or 3.) disconnecting everything but the main drive. This time, none of these methods seem to work.

When I try using the Windows repair disk, the setup doesn't detect any operating systems to repair. I can tell that the drive is still being read, however, as I can navigate it through the explorer window that pops up if you choose the option to install HDD drivers.

I'm reluctant to think that this is the fault of the hard drive, as it had been working perfectly for one month prior. As mentioned, this has happened to me multiple times before, on multiple motherboards and multiple hard drives, and before, my last resort method was to totally format the hard drive and start over (which I would like to avoid if possible).

At this point, I'm absolutely out of ideas. Any help would be much appreciated.

See More: ASUS P5N-D Disk Boot Failure

January 18, 2011 at 14:28:17
Is that the entire message "Disk Boot Failure"? Or is there more to it such as " Disk Boot Failure, Insert System Disk and Press Enter"?

Disconnect the 150GB HDD & the external 500GB, then try booting up. Also, make sure there's no disk in the CD/DVD drive.

Report •

January 18, 2011 at 14:35:26
The full message is indeed "Disk Boot Failure, Insert System Disk and Press Enter"

I tried disconnecting both of the other drives and now I'm getting "invalid partition table"

Report •

January 18, 2011 at 15:20:48
You need to repair the master boot record (MBR).

Report •

Related Solutions

January 18, 2011 at 15:39:49
Tried entering the commands given on that page and I keep getting "Could not open the volume root directory: The parameter is incorrect."

Report •

Ask Question