ASUS Motherboard Stops Recognizing SATA Controller

Asus P8b ws workstation motherboard - in...
July 25, 2012 at 17:49:03
Specs: Windows Home Server 2011, Intel Xenon E31275 3.40GHz / 16Gb RAM
I have an ASUS P8B WS motherboard in a CoolerMaster case running Windows Home Server 2011 for nearly one year. The OS is running on a Samsumg 830 128Gb SSD and the other drives include two 1Tb WD Caviar Black Sata III drives and five Samsung 2 Tb "Green" drives.

I initially added a SuperMicro S508-18N SATA/SAS controller (which required a driver) to handle the "Green" drives where all of my Home Server data are located. I had nothing but trouble with that controller. It would constantly lose drives. Therefore, I eventually changed to a more expensive Intel SASUC8I SATA/SAS controller card (which is a rebranded LSI SAS3081E-R) whose driver is included with Home Server 2011 (i.e., Windows 2008 R2). This system had been running well for the past several months.

Then, very recently, I realized that there had been several updates to the ASUS BIOS, including one that was just released on July 17 along with several other motherboard software updates. Therefore, I decided to install all of these updates. All of them, installing the BIOS, installed without any problems so I thought I was "home free". Then, I rebooted the system...

What I found was that my IBM controller card was no longer being recognized. There were no errors, the bootup process just skipped totally by the controller and went right to Windows. Consequently, none of the data drives on that controller were being recognized. I tried a different
PCIe slot with the same result.

Then, I tried that IBM controller in my Windows 7 Ultimate workstation and it was indeed recognized and seemed to work fine. So apparently, the problem is not with the card. I then tried again several times in my Home Server with the same result: "no go".

I then tried the SuperMicro controller that I had stopped using. It "was" recognized and all of my data drives did spin up. However, as was typical with that controller, it quickly lost one of the data drives (of course, it was the one was the one with most of my data). So I removed that card and went back to the IBM card.

I then tried to clear the CMOS, first using a couple of techniques I had read about on the internet. The first of these was to continually press-and-release the CTRL key while the system was booting. This did indeed seem to clear the system cache. I went into the BIOS reset the defaults. Initially, I left the SATA mode at "IDE" but later changed it to "AHCI". No matter what I tried, it still would not recognize the IBM controller card.

I then tried the second technique which was to hold down the INS key while booting. This also appear to clear the system cache but starting causing other issue. Up until I tried this technique, I did not have any problems booting the system. It would just bypass the IBM controller. Now, however, I started having numerous problems booting. Oftentimes, the BIOS screen would appear, I would ignore it and the boot would continue but, then, the BIOS screen would reappear. Sometimes I could see that a BSOD occurred just before the BIOS screen reappeared but it was not visible long enough to read any of the info.

Finally, the next step I took was to completely clear the CMOS including the real-time clock by completely removing the CMOS battery and then changing RT jumper for 10 secs and then moving the jumper back to its original position and then reinserting the CMOS battery. This procedure did NOT help at all. The system still will not recognize the IBM controller card and I oftentimes get "crashes" while rebooting. By the way, whenever I tried anything to clear the system cache/CMOS, I would always power down completely, unplug the power cord and wait several minutes before rebooting.

I have spent many hours over several days trying to resolve this issue -- with absolutely no success. I have no idea what happened and how I "fix" it. I've tried everything I can think of several times and in several variations. All to no avail. I just cannot believe that the motherboard updates could have caused this problems. By the way, I did not try to reboot the computer after updating the BIOS. I waited until I installed the rest of the updates.

I am totally lost on what to do next. Any help would be greatly appreciated.
Thank you.

See More: ASUS Motherboard Stops Recognizing SATA Controller

Report •

July 25, 2012 at 19:41:57
Whenever you update a BIOS file you need to immediately enter the BIOS screens and reset some of the values. If you were booting to a controller card you may need to set SCSI device as the first boot device. You will need to have a look.

Report •

July 28, 2012 at 11:09:15
I did go into the BIOS right after updating it. Actually, it wasn't "immediately after the update"... I did install some of the related motherboard updates first but I then I went to the BIOS and reset the defaults. There really wasn't anything to change except for changing the SATA setting from "IDE" to "AHCI". I am not booting from the Intel controller but from a 128 Gb Samsung 830 SSD.

Report •
Related Solutions

Ask Question