are my ram faulty?

February 2, 2010 at 07:54:12
Specs: Windows 7 ultimate 64 bit, intel core i7 920, msi X58 pro, 3gb ddr3 1333 ram, palit gtx 260 896 mb graphics
Configuration of my system are,
Intel Core i7 920, MSI X58Pro mother board, GTX 260 graphics card & corsair DDDR3 3X1 GB RAM (1333MHz 9-9-9-24).
Recently I installed windows 7 ultimate 64 bit version. I wanted to increase RAM , so I bought corsair DDDR3 3X2GB RAM (1333MHz 9-9-9-24), identical in every respect. I installed them but after booting, computer started to freeze, sometimes during booting or after 10-15 min. no key works at that time. I had to hard reset everytime. Sometimes system just restarts. Iit occurs at random. When I am using only new 6GB kit it is working fine. But whenever I mix two , problem occurs. But they should not . they are identical in every respect except capacity. I want to know where is the problem. Are the ram slots are faulty? I have six ram slots in my mobo. Alternately they are coloured blue & black. Mobo manual says first ram should be in black slots, after filling up black go for blue slots. So whenever I am using either 3GB kit or 6GB kit I am always using black slots and in those are not creating any problem. Whenever I mix the two problem occurs. So the ram I bought are not defective. How can I make out where the problem lies in ram slots or in mix up? Any idea or advice is valuable to me. Many many thanks in advance.

See More: are my ram faulty?

Report •

February 2, 2010 at 13:03:28
Your problem is COMMON !

"I bought corsair DDDR3 3X2GB RAM (1333MHz 9-9-9-24), identical in every respect."

If the module part numbers are the same, they're identical; if they're not, they may not be compatible with one another or the mboard, even if the specs seem to be the same.

"they are identical in every respect except capacity."

If all the module part numbers are listed for your mboard model / cpu on the list when you look up ram for your mboard model on the Corsair site, they should work fine; if not, the different capacites may not be compatible with one another.

See your mboard manual - you need to make sure the sets are in the right slots.

Ram that works in another mboard , or any ram you buy or have lying around, may not work properly, or sometimes, not at all - even if it physically fits and is the right overall type (e.g. SDram, DDR, DDR2, etc.; PCxxxx, xxx mhz) for your mboard. In the worst cases of incompatibilty your mboard WILL NOT BOOT all the way with it installed, and the mboard may not even beep - the ram has to be compatible with the mboard's main chipset, or in the case of recent mboards, compatible with the memory controller built into the cpu.

If you still have the ram that was installed when the system worked fine, try installing just that ram.

See response 5 in this for some info about ram compatibilty, and some places where you can find out what will work in your mboard for sure:
Correction to that:

Once you know which module ID strings (module part numbers) work in your mboard, you can get them from anywhere you like that has ram with those ID strings.

If you have brand name ram, it is usually easy to look up whether it's ID string is in a list of compatible modules found by using your mboard or brand name system model number.
If the ram is generic, that may be difficult or impossible.

It is easy to test for incompatible ram that has caused your mboard to fail to boot.

Make sure you have a speaker or speakers or the equivalent connected to the mboard so you can hear mboard beeps (see your mboard manual if you need to).
Remove the AC power to the case/power supply.
Remove all the ram.
Restore AC power.
Try to boot.
If nothing else is wrong, you will get no video but you will hear a pattern of beeps that indicate no ram is installed, or a ram problem.
E.g. for an Award bios or a bios based on one, that's often a beep of about a half second, silence for a half second, a beep of about a half second, silence for a half second, continuously.

See response 2 in this - try cleaning the contacts on the ram modules, and making sure the modules are properly seated:

This is common these days.....

Some ram manufacturer's modules do not strictly adhere to the Jedec standards that most mboards use to determine ram settings.
In that case, the ram settings in the bios Setup that the bios has automatically chosen may not be correct.
Check the ram setting in your bios - the ram voltage, and the ram timing numbers - those should be the same as for the specs for modules themselves. Often the ram voltage and timing numbers are printed on the label on the modules.

If the voltage setting or timings settings in the bios are different from the specs for the ram, change them in the bios. The timing numbers must be as close as you to get to the same, or slower timings (higher numbers = slower) - you won't notice the difference the lower settings make.

If you have a mix of different modules
- don't mix ram that different voltages are specified for - the bios will force the ram to use the lowest voltage, if "by spd" or similar is used (default settings) - ram a higher voltage is specified for is more likely to not work properly in that situation.

- the bios settings must be those for the slowest timing settings of all the modules, or slower (higher numbers = slower).

If your ram passes a ram test, it's working fine, even if you can't determine whether it's listed for your mboard or system model anywhere

If you do a ram test, do that AFTER having tried cleaning the contacts and making sure the ram is seated properly - otherwise any errors found may be FALSE.
If the ram is incompatible with the chipset, or on more recent computers, incompatible with the memory controller built into the cpu, it will likely FAIL a ram test - that is NOT a true indication of the ram being faulty - there is probably nothing wrong with it, and it will pass the test if installed in a mboard it is compatible with.
NOTE: Sometimes incompatible modules (or matched pairs) won't work properly when more than one is installed, but will pass when by itself.

If you want to try a memory diagnostic utility that takes a lot less time to run a full pass than memtest86 does, this one is pretty good - Microsoft's
Windows Memory Diagnostic:
It can be toggled (press T) to do a standard or a more comprehensive set of tests - use the default 6 test one first - if it passes one pass of that, use the latter one. A few of the tests in the latter set are intentionally slower.
If you don't have a floppy drive, see the Quick Start Information at that Microsoft link for how to make a bootable CD of the Windows Memory Diagnostic (you need Windiag.iso - you don't necessarily need to use the program they mention to add it to the CD).

Report •
Related Solutions

Ask Question