Another boot problem (perhaps an ACPI issue?)

September 23, 2012 at 11:30:53
Specs: n/a (Linux)
A computer (more precisely a PC with ASUS P5LD2-VM/S motherboard) worked fine until two days ago. It was properly shut down at night without showing any kind of irregularity. But the next day it would not boot any more. Needless to mention that nobody touched the machine over night (unless you believe in Gremlins or the like).

When pressing the power button on the front side of the case, the lights briefly flash and the fan begins to spin, but very soon (approximately one second) the machine shuts down by itself and remains in that state. Of course this period is too short to issue any beep-codes or to display any messages on the screen. In addition any hints like "go into BIOS and try this or that" are pointless as you never get that far.

Actually there is a trick to get the machine back into life. Open the case, remove the power supply lines of all peripherals then press the power button for a long time (more than 20 seconds) and if you are lucky, it will start-up. Of course this is not a really satisfactory solution and i would like to know the reason for this annoying behavior which appears once every couple of months and what could be done about it.

The fact, that the trick works, and that the computer runs after applying it for quite a time until it happens again seems to exclude a hardware defect. It seems to me as if the shut-down procedure sometimes doesn't properly bring the PC into sleep-mode but rather into something like a "coma-mode" from which it would not wake-up again. But my knowledge of the whole power-save stuff as well as the ACPI mechanics are by far not detailed enough to understand what is going on here. Is here someone who really understands that subject?

See More: Another boot problem (perhaps an ACPI issue?)

Report •

September 23, 2012 at 12:10:33
Sounds like a weak power supply. Post all your specs in detail. Especially the power supply, processor, and graphics card.

Report •

September 23, 2012 at 13:49:00
Are you sure about the power supply?

Did you notice, that after applying the "trick" it runs (and boots) well for weeks or even months, until it happens again?

Shouldn't a power supply be either always weak or always sufficient?
And even after removing all peripherals from the power supply it will still not boot (until i apply the "trick"). Can you be more specific about the details of the power-up procedure?

Report •

September 23, 2012 at 15:13:25
Post your specs as requested.

Report •

Related Solutions

September 23, 2012 at 16:08:58
Shouldn't a power supply be either always weak or always sufficient?

They are should but be assured they are not. You symptoms are indicative of a power supply that is running in the ragged edge of supplying sufficient power and sometimes it goes over the edge.

Something as simple a room temperature can make all the difference.

The power supply sends a "power good" signal the the North Bridge when the power is applied and once it has stabilised and is producing the correct voltages. Until the North Bridge gets the power good signal it does noting, goes into a wait state.

There are many things the can inhibit the power good signal, under voltage, over voltage, a failing capacitors a flaky resistor, a lose solder joint. At start up there is a current surge that may be too much for the power supply, but once it is up and running, not too much to cause problems

So your problems are almost certainly with the power supply.


Report •

September 25, 2012 at 13:47:11
In the mean time i tried to find out more about the problem and here are my results so far:

1) The power supply is a "QTechnolgy Model NO: QT05360G" (who ever may be happy with that information) The specifications of it (as printed on a label on the outside of the cage) are the following:
+3.3+5V Combined 130W
360W MAX

2) I used a Voltmeter to measure the voltages on the cables which supply the peripherals (5V and 12V) These are the only ones that are accessable.

2.1) When working properly:
2.1.1) completely off (hardware switch): 0.0V and 0.0V (well that's not surprising)
2.1.2) stand-by: 0.35V and 0.0V
2.1.3) running: 11.96V and 5.2V

2.2) When NOT working properly:
2.2.1) completely off (hardware switch): 0.0V and 0.0V (again not surprising)
2.2.2) stand-by: 0.36V and 0.0V (not surprising either)
2.2.3) attempting to start: 11.4V and 5.12V
of course both values appear for just a very short time, so these are not stable values. Immediately after that the two voltages fall back to 0.

3) When the computer works (at least as far as needed to enter BIOS) there is a "Hardware Monitor" which also gives some information about internal voltages. The values shown oscillate constantly within a certain range therefore i give the limits:
VCORE: 1.280 .. 1.304
3.3V: 3.216V .. 3.408V
5V: 5.222V .. 5.273V
12V: 11.932V .. 12.038V

4) After off-hooking all peripherals and applying the above described "trick" the machine came back to life until i hooked the hard disk on again. Repeating that procedure a couple of times confirmed, the trouble returns as soon as i hook the hard disk. That seems to suggest, that the hard disk is the culprit.

BUT things are not quite as simple, as a couple of questions remain:

- If the hard disk is oververloading the power supply, why does it so only since saturday? It worked fine until friday and nobody changed it over night.

- After off hooking the hard disk the assumed overload should have gone and the machine should resume working, but it doesn't. It does so only after applying the "trick".

- It appears to remember a once experienced overload even across a total (hardware) power off. Only pressing the (soft) power button for a long time (longer than 20 sec) seems to make it "forget" its bad experience. Is this so? How does it work? Is that documented somewhere? The board's documentation doesn't tell anything about it.

- Is it really a hardware issue? Perhaps the power-up mechanics (north bridge???) are just a little bit too impatient? Is there a (software) time-constant somewhere that tells it how long to wait until it decides whether the power is good or bad?

Report •

September 25, 2012 at 13:53:27
The above information will be helpful once you post the rest of your specs. Of interest are the CPU model and the graphics card, if one is in use.

Report •

September 26, 2012 at 09:42:46
The cpu is an Intel Pentium4 running at 3 GHz and there is no separate graphics card, as the internal graphics of the motherboard is used.

Report •

September 26, 2012 at 10:29:46
I am assuming this same configuration used to work without this problem? Did you make any hardware changes since the rig started up correctly?

Check the motherboard for bulging or leaking capacitors. See the second link below to learn what to look for.

You could also re-seat all cards and RAM. Snap each RAM stick in and out 4 or 5 times to burnish the contacts.

Try installing CPUID hardware monitor to monitor the voltages in real time. Get it from the link below.

I still suspect a weak power supply.

Report •

September 26, 2012 at 12:21:18
No, i did not make any hardware changes prior to the first failure of the system. Of course i afterwards did make changes to narrow down the possible cause (un-hookimg devices and the like). But things keep on getting even more confusing.

As described in a previuos post, un-hooking the hard disk allowed the machine to boot. Without a hard disk there is not so much you can do with such a computer, but you can still boot a life CD (Puppy Linux in that case). That was on sunday.

When trying the same again on tuesday, i already had to hook off the CD-burner (in addition to the hard disk) but the DVD reader was still tolerated. However trying to boot from that device (the same one that worked fine on sunday) didn't work anymore, the boot process freezes in the middle of its way, the read light of the drive goes out, apparently it just stops working.

During all that time i had a volmeter hooked to the 5V and 12V power supply lines of the drive (alternativly, as i only have one voltmeter). Needless to say, that the voltages were all OK.

Having only the floppy drive left as usable boot medium, i booted some old MS-DOS system. Under that system i could list the directory of the CD that would not boot anymore and i even "succeeded" in copying the largest file on that CD to NUL without DOS complaining about any read error. That seems to suggest that the CD and the drive is OK.

Does all this still look like a power supply issue?

(Thank you for the links, but without a hard disk and hence without a regular operating system, this software is of very limited use to me)

Report •

September 26, 2012 at 12:28:29
I missed the implication that the hard drive might be the issue.

I recommend you download a hard drive fitness test from the manufacturer of the drive.

There are a number of issues that could come into play. Your BIOS MAY have an option to increase the search time for the hard drive. If the hard drive is a SATA II and the controller is SATA I, that can cause issues in some cases. There may be jumper pins on the drive in that case to force the drive to run at SATA I speeds.

Report •

September 26, 2012 at 13:18:10
I now had a closer look at all the capacitors on the main board. They all look fine, though i know, that this doesn't garantee that they actually are good, but what else could i do?

I do have hard drive fitness test programs but the problem is, as soon as i re-hook the hard disk, the system will not boot anymore, as the power goes away. But without power, the fitness tester wont be very helpfull.

Report •

Ask Question