AlpsTpad drivers ; DX 9c updates

Sony / Pcg-fx120
February 4, 2009 at 15:23:44
Specs: Windows 98SE; XP, 700mhz / 128mb
Justin - I HATE that pesky "Enter as many details about your problem..." balloon!

Alps Touchpad drivers for 98SE.

I have been reloading a Sony PCG-FX120 laptop for a friend of mine.
It is a hand-me-down, he has no Recovery CD for it, and one is not available for it on the web - (drivers) CDs yes; actual Recovery CDs no.
It originally had Win 2000 on it, and the Product Key for that is on the case, but he has no Win 2000 CD, and he and I know of no one that has one we could copy.
He has no spare money to buy an OEM XP CD.

Earlier releases of this model had ME on them, and often ME drivers work fine with 98SE, so he loaded Win98SE on it when Win 2000 was not working right anymore.
We found that although Sony has ME drivers for this model, they don't have them for everything, and not all of them will load in 98SE. Some driver installations seem to be looking for something that's not present when Windows is installed from a regular Windows CD but it's there when the original Sony software installation is there, and quit, others yield error ???? messages and quit.

I eventually found drivers that installed in 98SE fine for everything (NONE of them were on the Sony site), EXCEPT the Alps touchpad, which the Sony web site has only 2000 drivers for, for that model, and for other models in the same FXxxx family.

When no drivers for the touchpad are installed, there is an entry in Device Manager PS/2 Compatible mouse port with a yellow baloon with a ? on it.

Apparently some FXxxx models had the 98SE drivers for it on the original (drivers; whatever the actual title is) CD that came with the model, but I can't find the Sony supplied 98SE (or ME) drivers on the Sony site or anywhere on the web. 98SE Alps drivers I found on their site for other Sony models will not install unless the laptop is a specific model. (drivers) CDs I have found on the web for the FX120 have only 2000 drivers for it.

He says the touchpad was working fine in 2000 before he loaded 98SE, and it worked fine when he briefly tried XP using a borrowed XP CD.

I tried 4 or 5 versions of Alps touchpad drivers for 98SE from other sources, but NONE of them work properly, despite my consulting much t-shooting info on the Sony site and elsewhere.
The Alps config utility they install is for both Alps regular mice and touchpads - it's supposed to show pictures of a touchpad in it - sometimes it does but the touchpad doesn't work - most of the time it shows a regular mouse and the touchpad doesn't work.
Sometimes the touchpad works for a few seconds or minutes after rebooting after installing the Alps software, then never again.
Before I re-loaded Win98SE, one version of the Alps drivers worked but poorly - frequent freezing of the cursor and button functions - for a few days, then never again.

Usually the Alps touchpad entry in Device Manager has the yellow balloon with the ? on it - once in a blue moon I did something and that was ok, but the touchpad did not work.

I looked up it's PNP ID number in System Info under problem devices, but it's a generic one.
Device Manager accepts Microsoft or Logitech PS/2 mouse port mouse for drivers, but still the touchpad will not work, except the Logitech one worked briefly, the cursor only, after rebooting the first time.

Apparently the Alps touchpad is supposed to use PS/2 mouse resources, including IRQ12. The laptop has no physical PS/2 port, though one is available in the dock if you have the dock for it. The PS/2 mouse is in the bios Setup - you can toggle dual operation mode on or off, whatever that is I found no info about, but you cannot disable it (to get the touchpad to use the resources for it, if applicable, but he didn't have to do that before in 2000 or XP). I tried disabling the PS/2mouse port in Device Manager, then installing the Apls drivers - the Apls entry is then disabled. It gets the yellow balloon with the ? on it when you enable it .
work when you enable it
Nothing in System Info but the PS/2 mouse port is using IRQ 12, whether or not the Alps drivers are installed.
I have tried
- installing only the drivers, which also installs it's config utility too, but then there is nothing to un-install in Add/Remove Programs
- running the Setup program for the drivers and apps, which DOES install an entry in Add/Remove Programs
- toggling PNP OS in the bios on and off
- using a serial mouse while installing the software. Oddly, some serial mice work, some don't.
- using a USB mouse while installing the software, rebooting without unplugging it, rebooting after unplugging it, and rebooting after disabling it in Device Manager and unplugging it.
- loading bios defaults
- many other t-shooting things

The hardware components of the Alps touchpads are apparently often made by Cirque. Cirque's Glidepoint software is often supplied for other vendor's touchpad mice. The entry in Device Manager when the Alps software is installed says Alps Glidepoint. I tried the Cirque drivers, but they're meant for plug in serial, PS/2, or USB touchpad mice.
That was a disaster! The keyboard then stopped working! I had to fiddle around to remove stuff, as well as un-installing them.
Cirque's own touchpads also work fine with standard serial, PS/2, or the generic MS USB mouse drivers, respectively - you just can't tweak as many settings.

Anybody got any suggestions?

The other subject is....

installing the DirectX 9.0c updates, in XP, on an XP installation that already has 9.0c (that has SP2 updates, or SP2 and SP3 updates).

I have not successfully installed them on ANY such XP installation so far, even on a fresh one. I have not found any info about why that would be. I have tried the latest updates, and several slightly older ones.

Anybody know what is going on with that, or some work around, for that, etc?

See More: AlpsTpad drivers ; DX 9c updates

Report •

February 4, 2009 at 16:34:32
Oops - I may have posted about the touchpad too soon (although I've spent days on this already).

I just started up the Sony laptop to look up the PNP ID number - *PNP0F13\0 - but didn't actually enter his password and load the desktop for a few minutes. When I did, I found the entry in Device Manager for PS/2 Compatible mouse port DID NOT have a yellow baloon with a ? on it!
I tried the touchpad and it worked fine!
I went to Device Manager, clicked Remove the entry, Refresh, it still DID NOT have a yellow baloon with a ? on it!
Too good to be true?

I rebooted, with the serial mouse disconnected, to make sure it would continue to work.
It didn't.
When the desktop loaded the mouse cursor was jumping all over the place, and eventually stopped.
I rebooted again, without the serial mouse connected, and Windows did not find a PS/2 mouse while booting.
I shut down the computer, connected the serial mouse, booted, looked in Device Manager. PS/2 Compatible mouse port has a yellow baloon with a ? on it again - clicking Remove and then Refresh didn't enable it without the yellow baloon with a ? on it.

Since the cursor was jumping around that makes me think there may be an intermittant connection between the touchpad and the mboard. Come to think of it, he had the laptop apart while trying to t-shoot his non working display (it's plugged into a CRT monitor). Maybe THAT'S the real cause of the problem.

Report •
Related Solutions

Ask Question