Adding 5.25 FD to W98 PC

Epson / Sd-600
December 3, 2009 at 08:15:23
Specs: Windows 98
I am trying to add 5.25 FD (Epson SD-600)to a W98 PC. It now has only 3.5 FD. When I configure the BIOS for both drives (3.5 A:, 5.25 B:), after reboot LED on both drives are on and neither reads FD. When I disconnect 5.25 (power and data), 3.5 reads fine. Also tried to set 5.25 as A: or B: and get the same results. Need 5.25 to read and convert some old drawings. Any ideas? Thanks in advance.

See More: Adding 5.25 FD to W98 PC

Report •

December 3, 2009 at 09:32:06
try just the 5.25 by itself. fact is causes a short knocking out the 3.5 would indicate the drive is bad.

Those must be some really OLD drawings

Report •

December 3, 2009 at 12:30:07
Sounds like a jumper problem.

I assume you've got the 'twisted cable' for the floppies? The a: drive goes after the twist, at the end of the cable. The b: drive goes on the middle connector.

Floppy drives have drive select (DS) jumpers. They can have as many as 4. When there's 4 they're numbered either from DS0 to DS3 or from DS1 to DS4. You want it jumpered at the second selection--DS1 or DS2 depending on how they're numbered.

Most newer 1.44's are hardwired at the second DS so you normally don't need to worry about them, unless yours is different and you've changed its jumper.

The jumpering is different if you're using a non-twisted cable. Then drive a: is the first DS and drive b: is the second DS and their position on the cable is irrelevent.

Onward to 300

Report •

December 4, 2009 at 04:34:30
Thanks for the help. I do have a twisted cable. Located jumpers on 5.25 labeled 0 through 3. Jumper is in second position on 1. Connected as you suggested - still the same problem - both LEDs are on and neither drive wants to read. In W98 Explorer both FD are displayed. Tried to work with just 5.25 - same result.

Report •

Related Solutions

December 4, 2009 at 14:04:28
The drives are connected on opposite sides of the twist? Some cables have both pin and slide-on connectors giving a total of 4 but they're not separate. There'll be a pin and slide-on at the cable end to connect either type of drive, but you can't use both of them to connect two drives. Same is true for the middle connector. Usually they are too close together to connect two drives but I thought I'd make sure that's not the case.

Or possibly the cable is bad.

Are you sure the SD-600 is good? It sure sounds like a jumper problem and if that's not it then maybe the drive is bad. The 5.25 may have other jumpers too and maybe a terminating resistor. Since it's on the middle connection you wouldn't need the terminating resistor but I don't think that would stop it from working.

Check this recent thread:

Go ahead and install the driver update. I don't think it'll help but it's not going to hurt to try.

Also make sure it's identified as a 1.2 meg and not a 360 K in cmos/bios setup.

Onward to 300

Report •

Ask Question