ADATA Superior SH-12 USB 3.0 1 TB External HDD issue.

Dell Alienware m11x 11.6" black notebook...
January 3, 2013 at 10:51:05
Specs: Windows 7, CPU: i7-2637m 1.7ghz. Ram: 4gb

I bought this device from Bangladesh. And I'm in America now. At first, this device used to work just fine but after 1-2 weeks it just automatically stopped working. Here's what it does

My computer: Alienware m11x R3
HDD: ADATA Superior SH-12 USB 3.0 1 TB External HDD

When I plug the device, it connects. The blue light keeps flashing which means its trying to read the files to the computer (as far as I know). After 15-20 minutes windows tells me that I need to format the disk to use it. I tried formatting it, when the format tab comes up, I clicked start format, after 15-20 minutes it says "windows cannot format your drive"

But I went to this computer repair shop, to check if the problem is with the cable or not. They plugged my cable in their computer and it read right away. Also they have used their own cable to verify it that the problem is not in the cable.

I have tried plugging the device on multiple computers and laptops, it had said that "you need to format this disk before using."

Please help me, my entire collection of documents, movies, family pictures and personal programs are in there. Thank you.

See More: ADATA Superior SH-12 USB 3.0 1 TB External HDD issue.

Report •

January 3, 2013 at 11:47:45
Formatting it before trying to recover the files was a bit of a pity.

Sounds like the drive has failed but try Recuva on it (to put your files onto the main HD if there is room):

If that doesn't work then I know of no easy or inexpensive option I'm afraid.

For the future it is best to have two copies of everything important, on two different devices.

Always pop back and let us know the outcome - thanks

Report •

January 3, 2013 at 12:15:23
I didn't format it. The OS tells me to format it before using. The other store i've mentioned in my thread, i plugged it in there and all my files are still there.

Report •

January 3, 2013 at 12:58:00
I see now, it presumably never actually managed to "do" the format you started.

I can't understand why the shop could read it but no other computers. It is hard to imagine that all the computers were faulty, so presumably there is something wrong with the drive.

Maybe the shop could copy the contents onto a replacement drive for you.

Always pop back and let us know the outcome - thanks

Report •

Related Solutions

January 3, 2013 at 13:10:19
yeah thats where im headed right now, a place called computer geeks. now i dont have any other option besides buying 40 bluray discs and copying them in it... thank you very much for everything

Report •

January 3, 2013 at 13:24:09
Yes, pity but good luck with it anyhow.

Report •

Ask Question