adata classic ch11 external HDD not recognized

August 24, 2015 at 03:25:28
Specs: Windows 7
My computer can't detect my ADATA class CH11 external HD. What can I do to rectify this problem?

See More: adata classic ch11 external HDD not recognized

Report •

August 24, 2015 at 04:57:57
When you plug the hard drive into the usb port do any lights come on, on the hard drive? can you hear it spin up?

has the drive ever worked?

it could just be the enclousre that the hard drive is in is faulty, very common. You can either buy another enclosure or buy a hard drive dock which will allow you to recover your data.

However if you provide more details about what exactly happens when you plug it in we can hopefully narrow down the possible causes.

Report •

August 24, 2015 at 05:50:05
Thank you so much for responding.
When I bought the Hard Drive, it couldn't work until I used the PC back ports. But when I upgraded from Windows 7 to 8, it could not be detected even if I used the back ports. I have since tried to use it on other computers but still it can't be detected despite the light being on. I can hear it spin and just slightly warm.

Report •

August 24, 2015 at 06:37:40
Have you tried to format it (assuming you have no data on there)
Have you checked under 'Manage' to see if the drive is formatted and ready for use?

How To Access Disk Management in Windows 7

1. Click on the Start button and then choose Control Panel.

2. Click on the System and Security link.

Note: If you're viewing the Large icons or Small icons view of Control Panel, you won't see this link so just click on the Administrative Tools icon and skip to Step 4.

3. In the System and Security window, click on the Administrative Tools heading located near the bottom of the window.

4. In the Administrative Tools window, double-click on the Computer Management icon.

5. When Computer Management opens, click on Disk Management on the left side of the window, located under Storage.

How To Access Disk Management in Windows 8 or 8.1
1. Open Control Panel

2. Click on or touch the System and Security link.

Note: You won't see System and Security if your Control Panel view is set to Small icons or Large icons.

3. In the System and Security window, click or touch the Administrative Tools heading, located at or near the bottom of the screen. You may need to scroll down to see it.

4. With Administrative Tools now open, double-tap or double-click on Computer Management.

5. With Computer Management now open, click or touch Disk Management, located on the left-hand side of the Computer Management window, under the Storage heading. If you don't see it, you may need to expand Storage by clicking or touching the |> icon next to it.

If the drive appears Black then you may have to format it

message edited by AlwaysWillingToLearn

Report •

Related Solutions

August 24, 2015 at 07:03:19
Thanks for more information.
I have never formatted this drive before. However with your instructions I have managed to get to 'Disk Management' but I cant see the drive. It's not there despite the light on the drive being on.

Report •

August 24, 2015 at 07:13:02
That would then confirm to me that the drive exclosure if probably faulty, you see within the enclosure you have a control board which converts the internet SATA interface to USB. It is extremely common that these control boards fail, i have replaced many for this very problem.

I would recommend trying to take the hard drive out of the enclosure and installing it directly into the PC if you know how to?

or perhaps wait and see what others here have to advise..

Report •

August 24, 2015 at 07:26:38
You may be point on. Thanks a lot for the help though.

Report •

August 24, 2015 at 07:35:30
No problem, please do let us know how you get on and what actions you take this will help others that may search the site for similar issues.

So are you going to take it out of the enclourse and install directly into the PC?

Report •

August 24, 2015 at 07:42:42
I am on it!

Report •

August 24, 2015 at 22:06:30
Since it hasn't worked since you upgraded to windows 8, check in device manager to make sure there's no problem showing there with the USB ports. You may need to install windows 8 drivers.

Report •

August 24, 2015 at 23:48:42
Ahh, i think i may have misunderstood post #2, i didnt quite understand what you meant. DAVEINCAPS may be correct, if indeed your device WAS detected prior to upgrade to Windows 8.

Report •

August 24, 2015 at 23:59:31
I think it's most likely physically failed in some way since it doesn't seem to be detected on other computers but as a 'just in case' I thought I'd mention drivers given the timing of it all.

Also it looks like those drives are USB 3.0. If the other computers only were 2.0 they may not be able to see it. I'm not sure if or how a 2.0 port would see a 3.0 capable drive.

See if this applies about it not being seen by disk management:

That's windows 7 but I imagine windows 8 would be much the same.

message edited by DAVEINCAPS

Report •

November 4, 2015 at 23:53:07
In this case .If you confirm that your HDD and the HDD interface are good.well .the there are 2 most likely reason: turned off the option of SATA HDDS,turn it on in BIOS
2.your motherboard is a BIOS motherboard.BIOS does not suppot GPT HDDs.if your HDD is GPT HDD,you gotta convert it to MBR(which BIOS supports only).then you need a software named"MINITOOL partition wizard",to convert it,just few clicks ,and totally safe and easy

Report •

Ask Question