Acer Aspire System Date/Time Problem

February 25, 2011 at 15:05:31
Specs: Windows Vista, Intel Core Duo T5450 3BG Ram
I have an Acer Aspire 5920 laptop with MS Vista. I have been experiencing problems with the system clock. It lags at times and if I remove the main battery, the date/time goes back to April 2007. I was told before that it was the CMOS battery so I replaced it. Now it's doing the same thing again. Would anyone be able to give me some advice. Thanks Karen

See More: Acer Aspire System Date/Time Problem

Report •


#1
February 25, 2011 at 15:50:38
- Check to see if you have Vista Service pack 2 (SP2) installed.

- The CMOS battery could be bad again (how long ago was it changed?), depending on where you bought it from, and whether it is a fresh battery or not. I had ordered a CMOS battery off eBay for an HP nc6000 laptop, and it lasted only a few months.

- See this also: http://www.howtogeek.com/howto/wind...

- There's a BIOS update as well from 12-8-08 that MAY help (no description of the fixes in this BIOS update though): http://support.acer.com/us/en/produ...

Just another stupid saying...


Report •

#2
February 25, 2011 at 16:13:16
Thanks for replying. Yes I have SP 2 version installed on my laptop.
The battery that I bought off of e-bay claimed to be New, but it came from Hong Kong, so there was no verification that it was new. I can't find anywhere on the internet that sells CMOS batteries.
Thanks for the links, I'll check them out and get back to you!
Thanks again!

Report •

#3
February 26, 2011 at 10:14:32
LOL! That's where I bought MY CMOS battery (Hong Kong)!

Just another stupid saying...


Report •
Related Solutions


Ask Question