Acer Aspire Battery vs AC Adapter wierdness

November 1, 2018 at 16:33:10
Specs: Windows 10
I have an Acer Aspire E17 (E5-773G) that is about two years old. I use it unplugged for a few hours, then plug it back in to be recharged. Always worked great.

Quite suddenly, about a month ago, the battery suddenly became critically low while using it for just a couple hours unplugged, and then wouldn't start. It only gives a "critically low battery" message when you attempt to start it.

The weird thing is that this happens even with the AC adapter plugged in. If you open the laptop and disconnect the battery, then it will start normally with the AC adapter. Reconnect the battery, and it won't start.

I've checked the AC adapter, and it's good (also tried a new AC adapter, same behavior). I've checked the power jack harness inside the computer and it's good.

I've purchased a new battery, which came at 10% charge, and when started with the battery connected and the AC adapter plugged in, the laptop would start off the battery, but advise me that the battery was low and to please plug in the adapter (which was of course already plugged in).

So, when the battery is connected, the laptop behaves as if the AC adapter is not (even if it is), which unfortunately includes the battery not being recharged. When the battery is disconnected, the AC adapter works fine.

BTW, I've also tried all the various solutions involving uninstalling the computer's battery drivers, resetting the power settings, etc. None have made a difference.

Anyone have any ideas on the problem? Alternatively, can anyone recommend a balanced charger for AL15A32 battery?

Thanks!


See More: Acer Aspire Battery vs AC Adapter wierdness

Reply ↓  Report •

#1
November 1, 2018 at 16:46:11
One more thing...

With the new battery at 10%, I thought I'd try updating the BIOS on the laptop (it's like v1.07 and the latest is 1.15). With battery connected and AC adapter connected, running the BIOS updater tells me that it cannot run without an AC adapter connected. Of course, it is connected. So, I disconnect the battery, which I know will allow the AC adapter to be recognized. Now running the BIOS updater fails with a message that I have to have a battery connected. Doh!

Since this behavior all started about the time of the mid-October Windows 10 updates, I'm wondering if there's something in those updates that munged the battery power management??? Just a thought.


Reply ↓  Report •

#2
November 1, 2018 at 21:19:57
A couple of possibilities here.
Typically when the laptop runs on the AC cord but not when the battery is plugged in, it is a battery with a shorted cell internally.
Assuming for a moment that the new battery is a good one (not positive without testing further) and it is not charging, then the charger may be putting out a lower than required voltage. It takes a higher voltage to push the power into the battery that the battery outputs so the laptop will run on the ac cord but maybe not with the battery connected. The battery needs to be tested and the output voltage of the charger needs to be tested.
The lesser possibility is that the internal charge circuit inside the laptop is bad or was damaged by the bad battery.

You have to be a little bit crazy to keep you from going insane.


Reply ↓  Report •

#3
November 2, 2018 at 13:41:57
Thanks a lot for the reply, @Fingers.

The AC adapters are good. The original is putting out 19.52V, and the new one is at 19.64V. And the power jack on the laptop is also good, passing through this same voltage.

I'm still figuring out how to test the batteries, as they have this tiny (8S-JXT-XH?) connector, which is too small to connect to with anything on my meter. But with the original battery, could it have suddenly developed a shorted cell internally, after working fine for a couple years? And the new battery have the same issue? Since the new battery worked fine until it's charge was depleted (well, it didn't charge, but it powered the computer no problem), it may not be a battery problem.

So, best bet looks like the internal charge circuit is now bad, unless something's become munged with the battery/power software. Does it seem strange that the charge circuit would go bad suddenly? And I still wonder how coincidental this was with the new Win10 update.

I assume the only repair for this would be installing a new motherboard?

Thanks again for your help!


Reply ↓  Report •
Related Solutions


Ask Question