Solved Acer Aspire 8940G Keyboard Malfunction

June 19, 2012 at 11:33:38
Specs: Windows 7
Last night I was playing a game on my laptop when it suddenly crashed. I think it was because my laptop was overheated (been gaming for hours, diablo 3 is way too addictive! :p) I've let my laptop cool off, put it on again to check if something wasn't working right and everything was ok, keyboard included. Today, however, I started my laptop again and my keyboard doesn't work...
Doesn't matter what key I touch, it instantly types a q and opens the "file" menu above (like in a text document). After that, no matter what I try to type, nothing gets through. When I click something, it instantly opens the properties menu of the file I clicked, so obviously, something gets stuck. The touchpad, normally locked when I start my laptop, is unlocked every time and works properly, though I can't lock it anymore, no matter how many times I push the button. Once I click shut down, the touchpad gets locked... I can still use an external keyboard (USB), so it's got nothing to do with wrong settings or anything like that.The only keys that do work are the extra keys I have, for instance the play, stop, rewind,... keys.
I've had this problem once before. One of my friends checked it out and after a while, everything worked properly again. He didn't do anything special though... So my question is, obviously, how do I fix this?

Tnx in advance for the answers!

See More: Acer Aspire 8940G Keyboard Malfunction

Report •

June 19, 2012 at 11:38:42
Check the built in keyboard for keys that are stuck in the depressed position.

Report •

June 19, 2012 at 18:07:25
✔ Best Answer
Did that last time too, but that wasn't the problem...

Got it fixed though, in a strange way, but doesn't matter, it works, that's the most important thing! :p

I wanted to shut down the computer, but pressed cancel when he asked to force or not, because I noticed the light of the touchpad lock was suddenly on. I pressed it a few times, worked like it should, tried typing and everything was ok again! Dunno how I've done it exactly, but it works! :)

Report •
Related Solutions

Ask Question