Solved Accidentally tried to un-install my laptops HDD

Acer / Aspire 5742
December 22, 2012 at 17:53:24
Specs: Windows 7, 2.399 GHz / 5814 MB
I have an Acer Aspire 5742 6458 laptop. The problem started with the failed installation of a Western Digital 3Tb My Book external back-up drive. The drive didn't install properly and part of the recommended troubleshooting from WD was to check Device Mgr and see if the drive was even being recognized. I now understand this is a fairly common problem with the WD 3Tb My Book. When I looked in Device Mgr I saw an entry listed in Disk drives as: WDC WD6400BPVT-22HXZT1 which I assumed to be the WD external drive, as another external WD drive I have lists in Disk drives with a 3 letter prefix starting with WD. So I thought I would try to re-install it to see if it would be recognized. Well the un-install failed thankfully, and I was prompted to re-boot. On re-boot, in Win 7, an con appeared in the lower right of the taskbar saying

"'Installing Device driver software Click here for details'"

I was confused as I still was under the mistaken notion that it was trying to again re-install the external drive that had failed to install. After the icon disappeared it prompted me to reboot again. This time the icon appeared after re-boot saying

"'Device driver was not successfully installed click here for details'"

When I clicked the details button the message said

"Device driver was not successfully installed

Please consult with your device manufacturer for assistance getting this device installed
Microsoft WPD Enhanced Storage Password X Failed

What can I do if my device did not install properly?"

the link under 'What can I do ...' led me to Win 7 basic info about doing a manual installation with correct drivers, consulting the manufacturer, etc

Only then did it occur to me that I had actually tried to un-install my Acer laptops internal HDD. So I checked in the BIOS and sure enough my laptop's HDD is listed as WDC WD6400BPVT-22HXZT1 The exact listing I had tried to un-install from the Device Mgr's Disk drive menu.

So now I am stuck in an endless loop. I re-boot and the whole thing starts over with attempting to install drivers, prompting to re-boot, and then the final error message

"Device driver was not successfully installed

Pleae consult with your device manafacturer for assistance getting this device installed
Microsoft WPD Enhanced Storage Password X Failed

I don't want to do anything else until I get some advice as to what to do next. I have the original Acer Drivers and Applications disk, and the Recovery disks if needed. I did check the Drivers and Applications disk but I see no drivers for HDD, just for Intel chipset, Wireless LAN, Touchpad, Sound card, etc - but nothing related to HDD.

So what would you advise I do next? I don't want to make this worse. I was in the process of backing up data when this started, which I am finishing, in case this gets ugly.

See More: Accidentally tried to un-install my laptops HDD

Report •

December 22, 2012 at 18:41:05
✔ Best Answer
I guess you're running on generic drivers, since you are accessing the drive. Get your data copied over for safety. Then go to device manager again, right click on the drive and "update drivers", allowing windows to search. If that doesn't work you can visit the Acer site, and also run Windows update manually and check there. If that fails do a System Restore via control panel / system / system protection

Report •

December 22, 2012 at 19:12:31
Thanks for the reply Paul.

I am in the process of backing up and migrating data between drives. I bought a new Seagate 3Tb today after the WD fiasco. That drive was indeed faulty and the store gave me a refund. When the back-up and data migration is done I will finish.

But first, I guess I'm making an assumption that I need to clear up. Would my internal HDD normally be listed in Device Mgr under Disk drives? It's been so long since I've done anything like this kind of troubleshooting that I can't remember what's what.

Before I posted here I let Windows search for the updated driver and it wasn't able to find one, telling me to "consult with your device manufacturer for assistance getting this device installed." That's why I looked in the Acer Drivers and Applications disk

I will check the Acer site as you suggested, try Windows update manually and \ or use System Restore if needed.

I can't believe I did this. What a bonehead move. It all started out of frustration with the WD drive that failed and my haste to resolve that without thinking. I'll let you know how it goes but it may be tomorrow now before I'm done backing up

Report •

December 22, 2012 at 20:54:12
Yes, the drive will be in DM. Check its Property sheet to make sure you've go the right drive. You're not the first one to do this.

But I suggest you take an image of your system, so in case of disaster you can be up and running in an hour or so - files, apps, settings, etc.

Report •

Related Solutions

December 25, 2012 at 08:49:21
OK Paul, I just got around to dealing with this now. Xmas holiday family obligations had me living my offline life.

I went to Acer and downloaded the only driver related to HD's and it was a SATA AHCI Driver, that was already installed. The error on re-boot had gone away this morning, so I went back into device manager and checked the drive under Disk drives and it appeared to be normal. However, when I went to Ctrl Panel>Devices and Printers, there was still a yellow asterisk on my computer's icon. When I clicked it and wet into troubleshoot, it tried to download the driver and failed. The error 'Microsoft WPD Eenhanced Storagge Password X Failed Driver came back.' So I waded into the Microsoft knowledge base. They recommended going item by item through Device Mgr to see where the yellow warning asterisk appeared there. It was under Portable devices>Microsoft WPD Enhanced Storage Password Other users reported simply right clicking and un-installing it. Tried that and it went away, and no more yellow asterisk on my computer icon in Devices and Printers. All seems to be normal. So how this got tripped or glitched by trying to un-install the HDD I don't know, but that was when the error message initially immediately came up. I have no portable devices installed so I figured it was OK. I only have a couple HD backups connected through USB. So do you figure it would be OK to just leave the WPD Enhanced Storage Password uninstalled? Thx for your help Paul

Report •

December 25, 2012 at 09:28:16
Two easy things you can try. Now that it's uninstalled, go back and do a hardware scan and see if it's picked up again.

Or do a system file check: Start, type in CMD, right click and select Run as Administrator. Now type in SFC /SCANNOW and let it run. It may help.

Try a reboot and see if the error is back. Any device in DM you can right-click and have windows search for driver updates. Another trick is to roll back the drivers there. If there's an older one it might not be corrupted. I'm not sure what this driver affects - user passwords or cryptographic services, which are related, or something else

Report •

December 28, 2012 at 11:48:49
Just to follow up Paul ...

So far the error message has not come back, so for now I'l assume that's fixed. I did rescan and noting new came up and no errors so I think whatever I did has fixed it. Thanks again for responding and your help Paul

Report •

Ask Question